RV Trip Planning Discussions

Go Back   iRV2 Forums > Blogs > donnyman
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Rate this Entry

up date

Posted 01-23-2019 at 03:34 PM by donnyman

I broke down and replace almost everything in the steps and they are operating fine.


I recently installed new batteries all around.



now my a/c control panel lost power so no a/c or heat! trouble shooting is underway.


I installed a new battery control circuit board and things seem ok but little problems keep popping up.


I did a check up on the generator and it showed improvement, when i start it I get power almost instantly now but I think the carburetor is a piece of junk, the gen. surges until that knob on the bottom of the bowl is twisted a few times



my engine seems to run ok but it seems harder to start after it warms up. as soon as I can i will install a new fuel filter.



my bedroom tv went dead.


my brakes surge while stopping it maybe a bent rotor or the anti lock system is on the fritz.
Posted in Uncategorized
Views 181 Comments 1 Edit Tags
« Prev     Main     Next »
Total Comments 1

Comments

  1. Old Comment
    Posted 01-29-2019 at 03:10 AM by buteci buteci is offline
 
» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.