RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 03-20-2019, 02:16 PM   #1
Senior Member
 
Join Date: May 2015
Location: Oxford, Ma
Posts: 164
14 Meridian 42E king bed issue.

So we finally got our new to us 14 42E and I got it home yesterday and we really starting going through it and re-checking our checklist of things that we had found on the walk through that needed to be addressed and we found that only one half of the air bed is working. We thought we had touched and tried everything but we never checked it on our first walk through. One control is working perfectly and the other controller isn't doing anything at all. It's not even lighting up. I'd prefer to just fix it here if it's something simple but if not it will be going back. Any ideas? Thanks :-)
__________________

__________________
Mike & Yolanda
2014 Itasca Meridian 42E
2016 Jeep Wrangler Unlimited 2017 Ford Raptor
Digger29 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 03-20-2019, 02:36 PM   #2
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 886
Hi, we had that happen once. The bed tilt mechanism pinched the cord on one side of the bed and it was enough to break the cord. Follow your cord from the controller to the air pump to find it.

Here’s the thing, it’s an Ethernet cable. 6-tiny 22ga wires. I found that all of them had to be connected before it worked. Period.

I got my wire stripper and soldering iron and cut, striped and soldered each of the 6-wires back together.

At the pump it’s a standard Ethernet connector but at the controller it’s hard wired inside the controller. Otherwise you could simply replace it like an Ethernet cable.

PS. After ours did this on a camping trip I pulled the whole I-Deal Rest Mattress out and bought a new mattress that works 100% of the time.
__________________

__________________
2017 Winnebago Adventurer 37F
2016 Lincoln MKX Toad
creativepart is offline   Reply With Quote
Old 03-20-2019, 02:41 PM   #3
Senior Member
 
Join Date: May 2015
Location: Oxford, Ma
Posts: 164
Quote:
Originally Posted by creativepart View Post
Hi, we had that happen once. The bed tilt mechanism pinched the cord on one side of the bed and it was enough to break the cord. Follow your cord from the controller to the air pump to find it.

Hereís the thing, itís an Ethernet cable. 6-tiny 22ga wires. I found that all of them had to be connected before it worked. Period.

I got my wire stripper and soldering iron and cut, striped and soldered each of the 6-wires back together.

At the pump itís a standard Ethernet connector but at the controller itís hard wired inside the controller. Otherwise you could simply replace it lit an Ethernet cable.

PS. After ours did this on a camping trip I pulled the whole I-Deal Rest Mattress out and bought a new mattress that works 100% of the time.
Thanks a bunch, I'm heading out there shortly and will check the wires. We've been loading all of the stuff from a old coach into it and man did we collect a lot of stuff in the 4yrs that we owned our last coach. My poor wife is in full purge mode right now and saying why did we have all of this stuff in there.... :-)
__________________
Mike & Yolanda
2014 Itasca Meridian 42E
2016 Jeep Wrangler Unlimited 2017 Ford Raptor
Digger29 is offline   Reply With Quote
Old 03-21-2019, 04:02 PM   #4
Senior Member
 
Join Date: May 2015
Location: Oxford, Ma
Posts: 164
Quote:
Originally Posted by creativepart View Post
Hi, we had that happen once. The bed tilt mechanism pinched the cord on one side of the bed and it was enough to break the cord. Follow your cord from the controller to the air pump to find it.

Hereís the thing, itís an Ethernet cable. 6-tiny 22ga wires. I found that all of them had to be connected before it worked. Period.

I got my wire stripper and soldering iron and cut, striped and soldered each of the 6-wires back together.

At the pump itís a standard Ethernet connector but at the controller itís hard wired inside the controller. Otherwise you could simply replace it like an Ethernet cable.

PS. After ours did this on a camping trip I pulled the whole I-Deal Rest Mattress out and bought a new mattress that works 100% of the time.
That was it. All fixed and working fine now. Thanks again, Mike
__________________
Mike & Yolanda
2014 Itasca Meridian 42E
2016 Jeep Wrangler Unlimited 2017 Ford Raptor
Digger29 is offline   Reply With Quote
Old 03-21-2019, 04:06 PM   #5
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 886
Quote:
Originally Posted by Digger29 View Post
That was it. All fixed and working fine now. Thanks again, Mike
Did you have to take care of all 6 22-ga wires or did you get lucky?
__________________
2017 Winnebago Adventurer 37F
2016 Lincoln MKX Toad
creativepart is offline   Reply With Quote
Old 03-21-2019, 04:20 PM   #6
Senior Member
 
Join Date: May 2015
Location: Oxford, Ma
Posts: 164
Quote:
Originally Posted by creativepart View Post
Did you have to take care of all 6 22-ga wires or did you get lucky?
Just one wire was broken. Lucky me :-)
__________________

__________________
Mike & Yolanda
2014 Itasca Meridian 42E
2016 Jeep Wrangler Unlimited 2017 Ford Raptor
Digger29 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Meridian/ Journey 42E Retractable Bed Finhawk Winnebago Industries Owner's Forum 9 09-30-2015 12:46 PM
Lift and hold bed on 2013 Itasca Meridian 42e cliffm Winnebago Industries Owner's Forum 10 11-06-2014 10:11 AM
2013 Itasca Meridian 42E Drivers Seat problem zehrteam Winnebago Industries Owner's Forum 12 03-24-2013 06:06 AM
Dripping Meridian 42E Finhawk Winnebago Industries Owner's Forum 3 09-23-2012 10:32 PM
Winnebago Unveils 2012 Journey & Meridian 42E DriVer RV Industry Press 5 01-27-2012 06:51 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.