Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-07-2017, 07:09 PM   #1
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 149
Brand New Adventurer - Ent/GPS/Monitor quits

On the trip home from purchasing my 2017 Adventurer 37F the GPS/Ent/Cam Monitor system started acting up. And by the time I got home 800 miles later it stopped working all together.

I had the good sense to record the issues on my iPhone - just in case it started working again and the dealer couldn't recreate the issue.

Then, I tried something new for correcting the issue. My Winnebago dealer couldn't get me in for a whole month and even then it was only 5 days before I was due to go on a month-long trip to Colorado. I was sure I'd be in waiting for parts limbo.

So, I contacted the manufacturer and showed him the videos I'd taken. Riverpark (the manufacturer) immediately stepped up and said "we'll send you a new one." The core unit is easy to get to in the cabinet over the passenger seat area, so I'll just switch out the old non-working unit for the new one.

Simple as that. No need to involve the dealer at all. That iPhone video made all the difference. I think I'll do this more often.

I'll attach the shorter of the two videos I sent them. The big video I didn't attach shows the whole thing stop working. But this one shows the precursor to that event.
Attached Files
__________________

__________________
2017 Winnebago Adventurer 37F
creativepart is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-07-2017, 07:27 PM   #2
Senior Member
 
macnut's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: Dublin, CA
Posts: 1,100
I had the same thing happen and took a video to show the Winnebago Service Center. They are also replacing the core unit. Hope this isn't something that keeps happening again and again.
__________________

__________________
macnut is offline   Reply With Quote
Old 08-10-2017, 04:05 PM   #3
Senior Member
 
Join Date: Aug 2009
Posts: 180
I have a 2016 38 q. What is the core unit? All i have in the overhead is the matrix.
__________________
cpoo is offline   Reply With Quote
Old 08-10-2017, 04:38 PM   #4
Senior Member
 
AKIQPilot's Avatar


 
Join Date: Mar 2017
Location: Alaska in Summer Snow Birds in Winter
Posts: 339
I can't believe the luck you are having with your brand new coach. Glad Riverpark stepped up and is getting you all sorted out.

Sure is a beautiful motorhome.
__________________
Tom and Sherry W.
06 Winnebago Adventurer 38J Workhorse W24 Lots of motor and suspension mods in the works
02 Itasca Suncruiser 35U. Workhorse W22 w/Safe-T-Plus, Koni FSDs, UltraTrac, etc, etc.
AKIQPilot is offline   Reply With Quote
Old 08-10-2017, 05:01 PM   #5
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 149
Quote:
Originally Posted by AKIQPilot View Post
I can't believe the luck you are having with your brand new coach..
Don't jinx me now...

We going out for 4-days next week. More "shakedown" I have an appointment at the nearest WBGO dealership (60 miles away) for the 24th of Aug. So, if anything new goes wrong at least I already have an appointment locked in.

So, far, after the radio/GPS/Monitor issue the only other issue is a loud banging noise on the passenger side front. But I've already figured out what that issue is and it should be an easy fix. It's a loose corner on the panel that frames the front passenger-side tire. It's banging very loudly in the wind as you drive.

The day after labor day we have a month-long trip to Durango with stops in Santa Fe and Albuquerque. ABQ is the final stop and we'll be there about 5 days. AND, that's where we bought the Adventurer - so if any issues pop up along this trip we'll be at a good place to get things fixed.

Fingers Crossed!
__________________
2017 Winnebago Adventurer 37F
creativepart is offline   Reply With Quote
Old 08-10-2017, 05:04 PM   #6
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 149
Quote:
Originally Posted by cpoo View Post
I have a 2016 38 q. What is the core unit? All i have in the overhead is the matrix.
Here's what the core unit looks like it's above the passenger dash in the far right upper cabinet. On my 37F it's just to the right of the matrix.
Attached Thumbnails
Click image for larger version

Name:	riverpark.jpg
Views:	30
Size:	293.4 KB
ID:	172418  
__________________
2017 Winnebago Adventurer 37F
creativepart is offline   Reply With Quote
Old 08-10-2017, 05:33 PM   #7
Senior Member
 
AKIQPilot's Avatar


 
Join Date: Mar 2017
Location: Alaska in Summer Snow Birds in Winter
Posts: 339
Quote:
Originally Posted by creativepart View Post
Don't jinx me now...

We going out for 4-days next week. More "shakedown" I have an appointment at the nearest WBGO dealership (60 miles away) for the 24th of Aug. So, if anything new goes wrong at least I already have an appointment locked in.

So, far, after the radio/GPS/Monitor issue the only other issue is a loud banging noise on the passenger side front. But I've already figured out what that issue is and it should be an easy fix. It's a loose corner on the panel that frames the front passenger-side tire. It's banging very loudly in the wind as you drive.

The day after labor day we have a month-long trip to Durango with stops in Santa Fe and Albuquerque. ABQ is the final stop and we'll be there about 5 days. AND, that's where we bought the Adventurer - so if any issues pop up along this trip we'll be at a good place to get things fixed.

Fingers Crossed!
Sounds like a great trip. How are the Air Conditioners holding up in the hot weather. Does the dash AC put out enough cold air in this weather. The coach AC can keep up too.

Poor AC performance is one of the things all us Old Coach owners seem to be dealing with. I turned on the basement AC in the Itasca last week when it was about 86F out. We were plugged in to 50 amps and it blew massive cold air. After about 15 minutes my wife got up and turned it off saying, "well thats enough of that".

Dash AC's in the old Workhorse chassis Begos has never been much to write home about.
__________________
Tom and Sherry W.
06 Winnebago Adventurer 38J Workhorse W24 Lots of motor and suspension mods in the works
02 Itasca Suncruiser 35U. Workhorse W22 w/Safe-T-Plus, Koni FSDs, UltraTrac, etc, etc.
AKIQPilot is offline   Reply With Quote
Old 08-10-2017, 07:54 PM   #8
Senior Member
 
Join Date: Aug 2009
Posts: 180
Thanks for the pic. I had no idea that was related to the screen. I had the same issue with the panel but mine was driver side. Made a flange and screwed it tight. Good luck. P.S. The more noisey thing was my hood that was loose. I just tightened the screws with the rubber pads a couple of turns.
__________________
cpoo is offline   Reply With Quote
Old 08-21-2017, 03:58 PM   #9
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 149
Well, the guy helping me with this from Riverpark flaked out and didn't get the replacement sent. I had to go to a supervisor and they are sending it 2-day air today finally.

This is a must have for our 3000 mile month-long trip coming in 2-weeks.

I have found that by switching the cabling for the 10.4" main screen with the 7" passenger monitor that I could use the main monitor. But having both will be better. Plus, the 7" monitor doesn't work exactly the same way as the 10.4" monitor. The touch controls are different. So, now the big driver monitor doesn't work as well with these different controls.
__________________
2017 Winnebago Adventurer 37F
creativepart is offline   Reply With Quote
Old 08-21-2017, 08:04 PM   #10
Senior Member
 
macnut's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: Dublin, CA
Posts: 1,100
Just had mine replaced in Junction City at the Winnebago Service Facility. The new unit worked fine on the 550 mile trip home. However, it did not have the current firmware. River Park was supposed to call me today with instructions to update. Winnebago would have done that, but I didn't want to stay till Monday! Without the firmware update, the controls on the left side of the main monitor do not work, and the navigation hangs up after a few miles when you have a destination entered. It works ok just showing your location on the map.

Best of luck on your replacement and hopefully it comes with latest firmware!
__________________
macnut is offline   Reply With Quote
Old 08-21-2017, 09:35 PM   #11
Senior Member
 
creativepart's Avatar
 
Winnebago Owners Club
Join Date: Sep 2009
Location: Spring Branch, TX
Posts: 149
They told me they were going to flash it before sending it out today.
__________________
2017 Winnebago Adventurer 37F
creativepart is offline   Reply With Quote
Old 08-21-2017, 09:40 PM   #12
Senior Member
 
macnut's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Jun 2012
Location: Dublin, CA
Posts: 1,100
Great! Wish they had updated mine! :-)
__________________
macnut is offline   Reply With Quote
Old 08-22-2017, 03:01 AM   #13
Senior Member
 
747Driver's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Sep 2003
Location: Vacaville, Ca
Posts: 114
Update is on a memory card. Takes just a few minutes to do. My Infotainment has been replaced as well. Be careful pushing in the main box, the HDMI cables are not that durable. When ours was replaced, they shoved it in and broke the HDMI cable for AUX, which was 45' long and went from front to half way back in the RV, in the overhead. They ran new cable under floor, very clean install.
__________________
Chris and Sharon Dellinger
2016 Adventurer 35P, F-53, 24K
2000 Ford Ranger Toad
747Driver is offline   Reply With Quote
Old 08-22-2017, 03:03 AM   #14
Senior Member
 
747Driver's Avatar
 
Winnebago Owners Club
Ford Super Duty Owner
Join Date: Sep 2003
Location: Vacaville, Ca
Posts: 114
Quote:
Originally Posted by AKIQPilot View Post
Sounds like a great trip. How are the Air Conditioners holding up in the hot weather. Does the dash AC put out enough cold air in this weather. The coach AC can keep up too.

Poor AC performance is one of the things all us Old Coach owners seem to be dealing with. I turned on the basement AC in the Itasca last week when it was about 86F out. We were plugged in to 50 amps and it blew massive cold air. After about 15 minutes my wife got up and turned it off saying, "well thats enough of that".

Dash AC's in the old Workhorse chassis Begos has never been much to write home about.
New Ford A/C much better than our 2003 WH unit. Get close to 100 on the road, still need to use house units.
__________________

__________________
Chris and Sharon Dellinger
2016 Adventurer 35P, F-53, 24K
2000 Ford Ranger Toad
747Driver is offline   Reply With Quote
Reply

Tags
adventurer, gps, vent



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Repair of brand-new 2016 Suncruiser LCD GPS monitor Jpcoleman MH-General Discussions & Problems 3 02-25-2017 08:24 PM
2012 Serrano 34M Ent.Center Key Skip3370 Thor Industries Owner's Forum 3 10-10-2015 08:09 AM
1 week old 2014 ent, anthem johnnyreno Entegra Owner's Forum 1 10-19-2013 01:10 PM
brand new to irv2 and brand new starcraft tt tlvn Travel Trailer Discussion 4 07-18-2011 06:55 PM
TKE Ent Doors and Drawers Dan Hen Excel Owner's Forum 6 05-11-2010 03:15 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.