Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-16-2008, 01:40 PM   #1
Senior Member
 
stearn's Avatar


 
Workhorse Chassis Owner
Join Date: Jul 2008
Location: Lambertville Mi
Posts: 747
Went to pick up the MH,only to find all three batteries dead. I store it inside and had just checked it two weeks ago. I turned off the battery switch, thinking that would be enough. I guess I will need to see how much amp drain I have when stored. Isn't the chassis battery seperate? I was suprized that all three batteries were drained. The place I store has no elec. Am I missing a battery disconnect, or something? My Dolphin I would take the ground off the house batteries. Never had the eng battery go dead??
__________________

__________________
06 Adventurer 38R

Equinox Toad
stearn is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-16-2008, 01:40 PM   #2
Senior Member
 
stearn's Avatar


 
Workhorse Chassis Owner
Join Date: Jul 2008
Location: Lambertville Mi
Posts: 747
Went to pick up the MH,only to find all three batteries dead. I store it inside and had just checked it two weeks ago. I turned off the battery switch, thinking that would be enough. I guess I will need to see how much amp drain I have when stored. Isn't the chassis battery seperate? I was suprized that all three batteries were drained. The place I store has no elec. Am I missing a battery disconnect, or something? My Dolphin I would take the ground off the house batteries. Never had the eng battery go dead??
__________________

__________________
06 Adventurer 38R

Equinox Toad
stearn is offline   Reply With Quote
Old 11-16-2008, 02:57 PM   #3
Senior Member
 
skigramp's Avatar
 
Join Date: Sep 2005
Location: HOME: Oshkosh, WI
Posts: 2,102
stearn ..

There are three things that I know of that could drain the chassis batteries on my coach ...
1) surround sound if I forget to change power source
2) retractable entrance steps
3) leaving the ignition key in ON or AUXILIARY position

I have had a couple of senior moments ... 1) and 3) caused me some angst by draining my starting batteries on a couple of occasions
__________________
2012 Buick Enclave
Present At home Home: Oshkosh, WI

former owner 2004 Winnebago Journey 39W
skigramp is offline   Reply With Quote
Old 11-17-2008, 04:32 AM   #4
Senior Member
 
John_Canfield's Avatar
 
Join Date: Jan 2005
Location: Back at the ranch
Posts: 2,538
Your battery disconnect switch only cuts off the house batteries (at least on my Horizon that's the way it works.) You may or may not have a chassis battery switch - my chassis battery switch is a mechanical marine-type located at the rear of the coach and immediately in front of the engine.
__________________
--John

2005 Horizon 40AD, 2005 Jeep Liberty CRD
John_Canfield is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead House Batteries maclonchas Winnebago Industries Owner's Forum 11 02-22-2009 02:45 PM
Dead Batteries Fritzo Class A Motorhome Discussions 3 10-18-2008 04:43 PM
Oh No -- All Batteries Dead LanceMan Workhorse and Chevrolet Chassis Motorhome Forum 11 08-30-2008 06:50 AM
Dead batteries, etc., etc. CHIPPYSGT Winnebago Industries Owner's Forum 11 02-27-2006 05:17 PM
Dead batteries DKispert Newmar Owner's Forum 5 12-26-2005 04:18 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:17 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.