RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-04-2017, 05:39 PM   #169
RV Mutant #172
 
Electra 225's Avatar


 
Newmar Owners Club
Winnebago Owners Club
Ford Super Duty Owner
Freightliner Owners Club
Join Date: Feb 2014
Posts: 3,834
That is NOT normal Tev! Make sure you don't have a window cracked open anywhere, especially the master bath. The fumes should not be getting into the coach at all. Check the exhaust pipe and see if any exhaust is coming out. The pipe should be warm too, it's a hot exhaust. If no smoke at end of pipe, could be a mouse nest in pipe or some kind of blockage.

Let us know what's happening, and be careful, those fumes will KILL you till yer dead in short order.

Regards,
W.D.
__________________

__________________
BILL {aka-"Admiral"-"Deuce"-"W.D."}
2014 Itasca Ellipse 42QD,
Freightliner Maxum, 450HP Cummins ISL, 3000 Allison,
Roadmaster Nighthawk II towing a 2011 Lincoln MKX.
2012 Newmar Canyon Star (first coach) FMCA F428511/ Good Sam/ Passport America.
Electra 225 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-05-2017, 08:23 AM   #170
Senior Member
 
tb919's Avatar
 
Join Date: Sep 2014
Location: Plano, TX
Posts: 141
Thanks. I knew it wasn't normal so that's why I shut it down. Fortunately we won't be anywhere to use heat before servicing. I'm pretty sure it hasn't been serviced yet so that's definitely on the list.
We use the AC much more often than the heat so really aren't experienced with it. Any tips?
Tev
__________________

__________________
2015 Itasca Ellipse 42HD. Just the two of us and our Sheltie.
tb919 is offline   Reply With Quote
Old 11-06-2017, 01:03 AM   #171
Senior Member
 
jwmaustin's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: May 2013
Location: Nashville, IN 47448
Posts: 693
The advice to check for obstructions and getting it serviced seem like good advice. Is that your question?

On your other comments we love our coach and are fixing up a few things though. Will get work done in January at LD. Is anyone here in TN - we see several down here at the Nashville KOA today.

Bill
__________________
Bill & Jenny - 2016 Winnebago Itasca Ellipse 42HD, 43 ft, Cummins 8.9 ISL - Blue Ox and SMARTCAR. Once/month traveler in Midwest and (as ofen as possible) Southern US. Home - Nashville, Indiana (Beautiful Brown County)
jwmaustin is offline   Reply With Quote
Old 11-12-2017, 12:39 PM   #172
Member
 
tdjackson56's Avatar
 
Join Date: Oct 2013
Location: Woodbridge VA
Posts: 99
Trim Sealant issue/question

All,
Has anyone else had issues with the sealant cracking around the trim on the slides? See my attached pic. My2016 Grand Tour motorhome is still under warranty but it looks like they may have painted "on top" of the sealant used. Any advice or similar issues?
Attached Thumbnails
Click image for larger version

Name:	Pic-8b.jpg
Views:	83
Size:	55.4 KB
ID:	182708   Click image for larger version

Name:	Pic -8.jpg
Views:	83
Size:	89.2 KB
ID:	182709  

tdjackson56 is offline   Reply With Quote
Old 11-12-2017, 04:44 PM   #173
Senior Member
 
XBoater's Avatar
 
Winnebago Owners Club
Join Date: Sep 2007
Posts: 355
Quote:
Originally Posted by tdjackson56 View Post
All,
Has anyone else had issues with the sealant cracking around the trim on the slides? See my attached pic. My2016 Grand Tour motorhome is still under warranty but it looks like they may have painted "on top" of the sealant used. Any advice or similar issues?
I had the same issue with my 2014 Journey. I complained at Lazy Days and they removed and replaced the caulking under warranty. I am disappointed I did, they did a poor job and the new caulking was hard, yellowed and pulled away after another year. Lazy Days gave me a price to fix it again, I declined.
__________________
Rich & Michelle
2014 Journey 42E
Chip & Dale, our kitties
XBoater is offline   Reply With Quote
Old 11-13-2017, 10:21 AM   #174
Senior Member
 
Gordon Dewald's Avatar
 
Winnebago Owners Club
Join Date: Mar 2014
Posts: 12,215
Ours is good on a 2015 Tour. I would take it back to the factory if you are anywhere close. If you contact Service and register the issue you may be able to bring it in later. They did that for us on some warranty work (we did it through the dealer).
__________________
Gordon and Janet
Tour 42QD/InTech Stacker
Gordon Dewald is offline   Reply With Quote
Old 11-20-2017, 07:40 PM   #175
Member
 
tdjackson56's Avatar
 
Join Date: Oct 2013
Location: Woodbridge VA
Posts: 99
2016 Grand Tour w/ Firefly electrical distribution- door LEDs are dim/partually lit

All,
My LEDs above the door and the lighted interior step lights are really dim, flicker, and LED very minimally light up with I use the switches on the lights control panel (both panels - the one by the door and the one by the passenger seat - as the switches in those panels both control the same set of lights.
What is strange is that when I use the keypad to unlock and enter the coach all the lights are bright and work correctly.
I'm assuming a loose connection somewhere- any ideas or where to look ?? on the G6 Firefly boards or elsewhere??
Thanks.
tdjackson56 is offline   Reply With Quote
Old 11-20-2017, 07:41 PM   #176
Member
 
tdjackson56's Avatar
 
Join Date: Oct 2013
Location: Woodbridge VA
Posts: 99
Additionally info.. it just started happening out of the blue on out current RV excursion.
tdjackson56 is offline   Reply With Quote
Old 11-20-2017, 10:19 PM   #177
Senior Member
 
akcretired's Avatar
 
Winnebago Owners Club
Join Date: Dec 2016
Posts: 179
Quote:
Originally Posted by tdjackson56 View Post
All,
My LEDs above the door and the lighted interior step lights are really dim, flicker, and LED very minimally light up with I use the switches on the lights control panel (both panels - the one by the door and the one by the passenger seat - as the switches in those panels both control the same set of lights.
What is strange is that when I use the keypad to unlock and enter the coach all the lights are bright and work correctly.
I'm assuming a loose connection somewhere- any ideas or where to look ?? on the G6 Firefly boards or elsewhere??
Thanks.
Check your connections in your firefly circuit boards. They are located under the bed. Bottom left side you will see the control panel behind a fake drop door. I had a bad connection in the circuit board that was giving me about your same situation...

Good luck
akcretired is offline   Reply With Quote
Old 11-23-2017, 09:16 PM   #178
Member
 
tdjackson56's Avatar
 
Join Date: Oct 2013
Location: Woodbridge VA
Posts: 99
Having the same exact issues with our 2016 Grand Tour. Motor 2 (Front) in rear drivers side slide failed. Took a while to troubleshoot and get the slide in. Now need to order a $500 motor.
Also had the OTD LEDs go out and discovered frayed wires going to the awning.
tdjackson56 is offline   Reply With Quote
Old 12-10-2017, 09:36 PM   #179
Senior Member
 
akcretired's Avatar
 
Winnebago Owners Club
Join Date: Dec 2016
Posts: 179
My relay box for my retractable bed is flashing red/green and the wall switches will not operate. If I push the reset button on the bed relay it will move a few inches and start flashing again. It takes about a dozen times to get the bed stowed to bring in the sides.

Any idea what the problem may be?
akcretired is offline   Reply With Quote
Old 12-11-2017, 06:01 AM   #180
Member
 
tdjackson56's Avatar
 
Join Date: Oct 2013
Location: Woodbridge VA
Posts: 99
Bed Relay Flashing response

It needs to be reset.
There is a procedure from Schwintek on how to do it on line . It you can't find it send me an email to tdjackson56@att.net and I'll find my ecopy stored on my computer.
Be careful as right now your auto stops are not set and you could grind up your tracks and gears when you get to the raise and lower end points .
Speaking from experience.
tdjackson56 is offline   Reply With Quote
Old 12-16-2017, 06:46 AM   #181
Member
 
tdjackson56's Avatar
 
Join Date: Oct 2013
Location: Woodbridge VA
Posts: 99
Did you get the tilt bed controller reset ? Let me know as I have the documents / instructions needed.
tdjackson56 is offline   Reply With Quote
Old 12-20-2017, 07:20 PM   #182
Senior Member
 
tb919's Avatar
 
Join Date: Sep 2014
Location: Plano, TX
Posts: 141
One of our headlights went out and we're on the road (of course!). Should we 1)get it replaced by Camping World 2)go to another RV dealer 3)call one of the roadside assistance programs we have or 4) wait till we get back home and have our dealer take care of it? We NEVER drive at night so it isn't an emergency. I'm thinking it won't be something easy for us to replace or is it??
Tev
__________________

__________________
2015 Itasca Ellipse 42HD. Just the two of us and our Sheltie.
tb919 is offline   Reply With Quote
Reply

Tags
42hd, 42hl, ellipse, itasca, winnebago



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 Winnebago Ellipse 42HD--just about to purchase jwmaustin Winnebago Industries Owner's Forum 16 02-05-2017 06:20 AM
Winnebago/Itasca Ellipse 42HD :: 2016 Winnebago Ellipse 42HD jwmaustin iRV2 Owners Registry 2 02-04-2017 07:36 AM
Winnebago/Itasca Ellipse 42QD :: 2014 Itasca Ellipse 42QD KTgirl iRV2 Owners Registry 0 10-04-2016 11:07 AM
2015 Winnebago Tour 42HD Jerry J Winnebago Industries Owner's Forum 37 12-24-2014 03:21 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.