RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-06-2005, 01:37 PM   #1
GG1
Senior Member
 
GG1's Avatar
 
Winnebago Owners Club
Join Date: Aug 2002
Location: WHITING,NJ,USA
Posts: 1,086
Just got back from the dealer after heater core replacement and discovered that the dash radio does not work when the main/auxiliary radio dashboard switch is in the main radio position and the digital temperature/compass is not working. Under the front hood there are push in circuit breakers, there is one that is popped that cannot be reset it is labeled "chassis battery feed". Any advice would be appreciated my dealer is 50 miles away I really do not feel like going back again
__________________

__________________
07 Itasca Ellipse 40fd, 2014 Honda CRV, greyhound lab mix, pit pointer mix(RIP bessie) , shar pei mix, stupid cat, wife
GG1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-06-2005, 01:37 PM   #2
GG1
Senior Member
 
GG1's Avatar
 
Winnebago Owners Club
Join Date: Aug 2002
Location: WHITING,NJ,USA
Posts: 1,086
Just got back from the dealer after heater core replacement and discovered that the dash radio does not work when the main/auxiliary radio dashboard switch is in the main radio position and the digital temperature/compass is not working. Under the front hood there are push in circuit breakers, there is one that is popped that cannot be reset it is labeled "chassis battery feed". Any advice would be appreciated my dealer is 50 miles away I really do not feel like going back again
__________________

__________________
07 Itasca Ellipse 40fd, 2014 Honda CRV, greyhound lab mix, pit pointer mix(RIP bessie) , shar pei mix, stupid cat, wife
GG1 is offline   Reply With Quote
Old 09-06-2005, 02:57 PM   #3
Senior Member
 
John_Canfield's Avatar
 
Join Date: Jan 2005
Location: Back at the ranch
Posts: 2,538
What a bummer You might pull up your coach's wiring diagrams on the Winnie web site and just start tracing the circuits. For an investment of maybe an hour of research, you might save yourself a trip back to the dealer.

-Or-

Look around where where they were working. Maybe you can spot something amiss.


--John
__________________
--John

2005 Horizon 40AD, 2005 Jeep Liberty CRD
John_Canfield is offline   Reply With Quote
Old 09-06-2005, 03:32 PM   #4
GG1
Senior Member
 
GG1's Avatar
 
Winnebago Owners Club
Join Date: Aug 2002
Location: WHITING,NJ,USA
Posts: 1,086
Thanks for the advice thats what I plan to do in the daylight tomorrow but I am not much of a mechanic I really don't know what to look for. I did find out that when my generator is on there is no electric to the coach but when I plug into electric everything works in the coach except the 2 previous dashboard items.
__________________
07 Itasca Ellipse 40fd, 2014 Honda CRV, greyhound lab mix, pit pointer mix(RIP bessie) , shar pei mix, stupid cat, wife
GG1 is offline   Reply With Quote
Old 09-06-2005, 03:57 PM   #5
Member
 
JanBCarter's Avatar
 
Monaco Owners Club
Join Date: Jul 2005
Location: Northern California
Posts: 89
GG1: I found a similar case of radio, temp etc not working (along with the remote mirrors and HWH leveling system) and traced it to the accessory fuses in the panel over the gen set. There are several 10amp and 15amp fuses which you can easily pull and visibly examine to see if they're blown. While you're there look at the switch on the slanted top of your gen set and switch it over. I found that to work when I could not get the AC to work when I ran the genset while on the road. Hope it helps... good luck
__________________
J.B. & B.J. Carter

& Raleigh the Cavalier Wonder Dog Navigator
JanBCarter is offline   Reply With Quote
Old 09-07-2005, 06:48 AM   #6
Senior Member
 
RVDriver's Avatar
 
Join Date: Nov 2003
Location: Maplewood, MN, USA
Posts: 204
On my 2003 Adventure it was a fuse "the 15A blade fuse in the Workhorse fuse box labeled "Radio/Accessory", everything was hooked up to it, Mirrors, radio, temp/direction, electric window (door), and the Leveling Jacks. If when lowering the jacks you lowerred the window, "pop goes the fuse
'. And yes it is the "Radio Accessory" fuse!

Bruce
__________________

__________________
Bruce and Dyanne
RVDriver is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical project want advice shirlock1 Newmar Owner's Forum 5 07-16-2008 04:56 AM
12v Electrical System Troubleshooting novi2some Damon 14 05-20-2008 03:25 PM
Need Electrical Advice BB501 Workhorse and Chevrolet Chassis Motorhome Forum 2 12-10-2007 11:49 AM
Need electrical advice CADUCEUS RV Systems & Appliances 17 11-12-2007 05:20 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.