RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-25-2015, 10:16 PM   #1
Junior Member
 
Join Date: Aug 2008
Location: San Antonio, Tex
Posts: 2
Lost power

I have a 2005 Winnebago Voyage. I recently lost power to my Level Jacks, Drivers Power Window, Window Heaters, Window adjusters, CB, Backup Camera, and Overhead Windshield fans all at the same time. I have looked for fuses and relays and have had no luck. Can anyone tell me where I would look for a common fuse, relay or junction where all of these items meet in common. Would appreciate any information about where to look. You can answer here or email me at djmaustell@yahoo.com. Thank you for your help
__________________

DJMAustell is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-26-2015, 07:11 AM   #2
Senior Member
 
grtharris's Avatar


 
Winnebago Owners Club
Join Date: Apr 2003
Location: Skiatook, OK
Posts: 2,368
DJMAustell, It is fed from one of the chassis fuses under or by the dash. What chassis do you have?
LD / 14 YEL IGNITION SWITCH ACCESSORY POWER SOURCE GENERAL PURPOSE(AUX FANS,RELAY TRIGGER,ETC.)
__________________

__________________
Grant & Pat
2014 Adventurer 35P
2012 Jeep Wrangler Rubicon
grtharris is offline   Reply With Quote
Old 03-01-2015, 03:47 PM   #3
Junior Member
 
Join Date: Aug 2008
Location: San Antonio, Tex
Posts: 2
Lost power

I have the Chevy Workhorse chassis, I have checked all the fuses I can find, not sure where to locate a junction or relay if that is the problem.
DJMAustell is offline   Reply With Quote
Old 03-01-2015, 05:39 PM   #4
Senior Member
 
grtharris's Avatar


 
Winnebago Owners Club
Join Date: Apr 2003
Location: Skiatook, OK
Posts: 2,368
DJMAustell, see attached drawing looks like 3rd fuse up on the left. Don't know what there is on the Workhorse side before it gets here. Move the the key in ignition switch and see if anything happens. If you can check the fuse socket with a volt meter.
Attached Thumbnails
Click image for larger version

Name:	LD fuse.jpg
Views:	45
Size:	79.7 KB
ID:	87494  
__________________
Grant & Pat
2014 Adventurer 35P
2012 Jeep Wrangler Rubicon
grtharris is offline   Reply With Quote
Old 03-10-2015, 11:42 PM   #5
Member
 
CalifCruiser's Avatar
 
Join Date: Apr 2012
Location: La Mesa, CA
Posts: 46
I had the exact same problem on my 2002 Itasca Suncruiser / Workhorse chassis, lost power to HWH jacks, power mirrors, power window, radio, and windshield fans. There is a fuse box under the tip up dash. the fuse is a 15 amp labeled as "RADIO - ACC". Replaced and all was good.
I actually learned about this when it happened by searching this forum, what a great thing.
__________________
2002 Itasca Suncruiser
CalifCruiser is offline   Reply With Quote
Old 03-17-2015, 07:37 PM   #6
Junior Member
 
Join Date: Mar 2015
Posts: 1
make sure to check the 12 volt grounds that go to the chassis
__________________

rich mohring is offline   Reply With Quote
Reply

Tags
power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TV AMP lost power. rodallg Class A Motorhome Discussions 8 12-02-2014 07:59 AM
Power inverter issues BigDBright RV Systems & Appliances 6 09-27-2014 06:56 PM
2003.Discovery help no ignition power Alanboss Class A Motorhome Discussions 3 03-28-2014 06:05 AM
Captains chairs lost power Inventor Monaco Owner's Forum 29 01-23-2014 08:53 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.