RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-27-2019, 04:56 AM   #1
Junior Member
 
Join Date: Jun 2019
Posts: 4
No trailer brake lights

I have a 2004 Ultimate Advantage and all the tails, turns and brake lights work great. When I plug in the 7 way in from my brand new car hauler, the trailer tails and turn signals work fine, but the brake lights do not, however all the lights on the coach still work properly. The coach has separate amber turn signals and I have read that this affects the wiring. What is the resolution?
__________________

Chris Hyde is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-27-2019, 05:05 AM   #2
Senior Member
 
Join Date: Jul 2015
Location: Watertown NY USA
Posts: 2,406
Quote:
Originally Posted by Chris Hyde View Post
I have a 2004 Ultimate Advantage and all the tails, turns and brake lights work great. When I plug in the 7 way in from my brand new car hauler, the trailer tails and turn signals work fine, but the brake lights do not, however all the lights on the coach still work properly. The coach has separate amber turn signals and I have read that this affects the wiring. What is the resolution?
See my response in your post in Class A Motorhomes.
Lynn
__________________

__________________
2002 Fleetwood Storm 30H on Workhorse P32 chassis 8.1 gas.
LETMGROW is offline   Reply With Quote
Old 06-27-2019, 05:29 AM   #3
Senior Member
 
Ranger Smith's Avatar
 
Join Date: Jul 2012
Location: Where the Rig is Parked
Posts: 1,065
There is an inexpensive combiner box they make that wires into the signal and brake lights on the coach side and the output of the combiner gets wired to the 7 way plug. That will fix your issue


__________________
Steve and Joy
2011 Itasca Meridian 40u
Where we are now
Ranger Smith is offline   Reply With Quote
Old 06-27-2019, 06:10 AM   #4
Senior Member


 
Holiday Rambler Owners Club
Join Date: Aug 2015
Posts: 4,276
Chris-

I responded on your other thread.
__________________
Mark
2008 Holiday Rambler Admiral 30PDD (Ford F-53 chassis)
2009 Honda Fit Sport
l1v3fr33ord1 is offline   Reply With Quote
Old 07-05-2019, 10:18 AM   #5
Senior Member
 
Winnebago Owners Club
Join Date: Aug 2012
Posts: 165
Chris, I assume you're on a freightliner chassis. There is a separate fuse for each circuit in the trailer harness, Check the 7 pin connector at the coach and I'll bet there is no signal at those 2 pins. Find the fuse panel (call WBGO 800.537-1885 for help locating it) and you'll probably find blown fuses. I'd check there before you get into something more complex. I had a similar problem and was ready to start a major repair when I called WBGO and they straightened me out.

Skip Y
2010 Journey 40TD
WIT 47083, FMCA F263635
Skip Y is offline   Reply With Quote
Reply

Tags
brake, brake lights, light, lights, trailer



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash lights, running lights and brake lights are intermittent! flyr4u Monaco Owner's Forum 8 05-27-2019 06:32 AM
No signal lights, headlights, docking lights, brake lights dvleemin Class A Motorhome Discussions 10 08-06-2017 05:01 PM
Marker lights,clearance lights and brake lights Ahall Entegra Owner's Forum 1 04-18-2014 05:39 AM
Motor home brake lights work but trailer brake lights don't Gerdean Toads and Motorhome Related Towing 9 09-11-2013 10:04 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.