RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-18-2006, 03:06 PM   #1
Senior Member
 
Winnebago Owners Club
Join Date: Oct 2003
Location: Solon, Ohio USA
Posts: 424
Send a message via ICQ to W8RLM
Hi Everyone,

I have a 2003 Brave on the Workhorse P32 chassis. I've lost both turn signals. Every once in a while, they will flash mokentarily, then nothing. The fuse is OK. I checked it, and if it was bad, they wouldn't flash at all. I think that its the flasher, but I can't find it.

The hazard flasher works, and all of the bulbs light, so I know that it is not a bulb or the circuits to the bulb.

According to my dealer, it is probably taped to one of the harnesses. I checked with Workhorse, and they said that the coach builder mounts it.

According to one of the Owner Relation guys, its on the bottom of the inside fuse panel. On mine, the only thing there are two 30 amp breakers - not the flasher. I think that he is referring to the "W" chassis.

I found the hazard flasher, but the turn signal flasher is not there.

Does any of you know where it is?

I need answers fast. I appreciate any help.

W8RLM - Bob
__________________

__________________
2006 Winnebago Journey, Model 39K, 2013 Dodge Dart
W8RLM is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-18-2006, 03:06 PM   #2
Senior Member
 
Winnebago Owners Club
Join Date: Oct 2003
Location: Solon, Ohio USA
Posts: 424
Send a message via ICQ to W8RLM
Hi Everyone,

I have a 2003 Brave on the Workhorse P32 chassis. I've lost both turn signals. Every once in a while, they will flash mokentarily, then nothing. The fuse is OK. I checked it, and if it was bad, they wouldn't flash at all. I think that its the flasher, but I can't find it.

The hazard flasher works, and all of the bulbs light, so I know that it is not a bulb or the circuits to the bulb.

According to my dealer, it is probably taped to one of the harnesses. I checked with Workhorse, and they said that the coach builder mounts it.

According to one of the Owner Relation guys, its on the bottom of the inside fuse panel. On mine, the only thing there are two 30 amp breakers - not the flasher. I think that he is referring to the "W" chassis.

I found the hazard flasher, but the turn signal flasher is not there.

Does any of you know where it is?

I need answers fast. I appreciate any help.

W8RLM - Bob
__________________

__________________
2006 Winnebago Journey, Model 39K, 2013 Dodge Dart
W8RLM is offline   Reply With Quote
Old 10-18-2006, 03:42 PM   #3
Senior Member
 
MikeT's Avatar
 
Winnebago Owners Club
Nor'easters Club
Workhorse Chassis Owner
Join Date: Feb 2000
Location: Silver Springs, FL 34488
Posts: 466
Do your brake lights work? I blew a 20 Amp brake fuse and lost the turn signals ---

Winnebago should know where they put it ---
__________________
MikeT__and_Mo T
'05 Voyage, W20, SMI, '06 CR-V
Ginger, the cat --Daisy, the dog
MikeT is offline   Reply With Quote
Old 10-18-2006, 04:27 PM   #4
Senior Member
 
Winnebago Owners Club
Join Date: Oct 2003
Location: Solon, Ohio USA
Posts: 424
Send a message via ICQ to W8RLM
Mike T,

Thanks for the reply. I checked the fuse, and it is good. Also, the hazard flashers work, and they would go through the brake light/turn signal filaments.

The intersting thing about Winnebago is that none of the diagrams in the chassis manual show a turn signal flasher at the bottom of the inside or outside fuse panels, so I don't understand the Owner Relation response.

I guess that I'll have to wait until I get home - tomorrow - and the dealer and I will try and find it.
__________________
2006 Winnebago Journey, Model 39K, 2013 Dodge Dart
W8RLM is offline   Reply With Quote
Old 10-18-2006, 04:46 PM   #5
cwg
Senior Member
 
Join Date: Sep 2004
Posts: 753
The turn signals on my Horizon quit working this week out of the blue. You may wish to do a search of the archives; mine disclosed that other Freightliner-based Horizons and Vectra's had bad circuit boards which had to be replaced. While yours is not a Freightliner, there may be some information within a search. Most of us thought there was a relay part or module which was responsible for the failure.

As a point of interest, a call to my local FFL dealer to have him order a new circuit board revealed a more proper diagnosis---- the service manager revealed it turns out not to be a board failure but a problem in the wiring harness which he said he has seen several times of late.
cwg is offline   Reply With Quote
Old 10-18-2006, 04:56 PM   #6
Senior Member
 
Winnebago Owners Club
Join Date: Oct 2003
Location: Solon, Ohio USA
Posts: 424
Send a message via ICQ to W8RLM
Thanks CWG,

I did a search of Flashers and "Brave Flashers". There wasn't anything about the flasher location for the Brave. I did see the discussion of the circuit booard that you mentioned.

W8RLM - Bob
__________________

__________________
2006 Winnebago Journey, Model 39K, 2013 Dodge Dart
W8RLM is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Four Way Flasher & Turn Signal Relay donny b Freightliner Motorhome Chassis Forum 2 09-19-2008 03:48 PM
Turn signal flasher location rgrstndgby Winnebago Industries Owner's Forum 7 09-09-2008 12:20 PM
Where is the turn signal flasher ? rvtips Monaco Owner's Forum 5 01-04-2008 12:28 PM
Turn signal flasher Rich Novak Newmar Owner's Forum 4 10-08-2007 04:58 PM
location of turn signal flasher Tuna Winnebago Industries Owner's Forum 9 05-07-2007 03:01 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.