Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-06-2010, 09:44 PM   #1
Junior Member
 
Join Date: Aug 2009
Posts: 1
turn signal fuse blowing problem

I had a problem with turn signal fuses blowing on my 2007 Itasca Suncruiser. After wasting a couple of days trying to fix a non existent toad wiring problem I discovered the problem in the steering column area. Winnebago adds a nice plastic cover around the lower steering column. This is mounted to a metal bracket clamped to the column. The large wire bundle from the steering wheel lays on this and managed to wear through the insulation on a wire causing the problem. Easy to fix but very hard to find. Hopes this helps someone. I have notified Winnebago and maybe will notify the NTSB. By the way this also make the 'auto park' fail.
__________________

__________________
pschroede17 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-07-2010, 09:44 PM   #2
Senior Member
 
Gary CA's Avatar
 
Join Date: Aug 2004
Location: Simi Valley, California
Posts: 576
I appreciate reading posts that identify a problem and after hours of your work you come up with a solution. Thanks for the post
__________________
Gary CA
2016 Fleetwood Southwind 34A
2011 Toyota Tacoma
2000 Jeep Wrangler 4X4
Gary CA is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with fuse blowing solution LandHo Winnebago Industries Owner's Forum 10 04-26-2008 05:39 PM
E450 Turn signal problem on "00 Shasta class C New Whale Class C Motorhome Discussions 3 03-06-2008 12:59 PM
Turn Signal or Electrical Problem max49 Workhorse and Chevrolet Chassis Motorhome Forum 23 10-30-2007 03:07 PM
Turn signal problem Gary RVRoamer Freightliner Motorhome Chassis Forum 9 08-23-2007 12:14 PM
Blowing Trailer Signal Fuses afrank1971 Winnebago Industries Owner's Forum 4 05-10-2007 02:23 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.