Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Winnebago Industries Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-17-2017, 02:49 PM   #1
Member
 
Trynforpar's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Location: Northeast
Posts: 95
Water coming out of Main Supply

I have a 2016 Itasca Meridian Model 40R. When I turn on the water pump, the water is coming out of the main water supply opening (where you connect the hose). Why would this be happening. The valve labeled Normal / Tank Fill is in the normal position and the water tank is 3/4 full.
__________________

__________________
Tom n Nancy, 2016 Itasca 40R, 2015 Jeep Wrangler
Chessie and Travis "The Pups"
Trynforpar is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-17-2017, 03:02 PM   #2
Senior Member
 
Podivin's Avatar


 
Join Date: Dec 2015
Posts: 1,044
Perhaps the Norma/Fill valve has gone bad and is allowing water to get past it?
You might try just turning that valve a few times to see if that helps.
__________________

__________________
1996 Fleetwood Southwind 34'
Podivin is offline   Reply With Quote
Old 09-17-2017, 03:05 PM   #3
Senior Member
 
MikeO58's Avatar
 
Join Date: Jul 2017
Posts: 143
I have the same issue on my 2017 Discovery 40E. When using water pump water comes out of the hose which is on a reel
__________________
Mike & Kelly
Palm Springs area
2017 Discovery 40E Freightliner Cummins 380hp
MikeO58 is offline   Reply With Quote
Old 09-17-2017, 06:19 PM   #4
Member
 
Join Date: Jun 2015
Posts: 67
Same here on my 2016 journey 40r. There is a check valve built into the connector your hose hooks to. I went to Lowe's and purchased a plug. When I unhook my hose I just screw in the plug.
__________________
gcamper is offline   Reply With Quote
Old 09-17-2017, 06:42 PM   #5
Senior Member
 
Join Date: May 2017
Posts: 258
Yep, check valve has failed on the city water fill connection. It is an easy and relatively inexpensive repair.
__________________
DryCreek is online now   Reply With Quote
Old 09-17-2017, 06:55 PM   #6
Senior Member
 
winniman's Avatar
 
Join Date: Jan 2013
Posts: 583
My friends coach does the same thing. He just uses a plastic plug after he fills his tank. No leaks and no problems. I told him there is a check valve in behind it, but he wouldnt believe me. The plug will work fine if you dont want to repair the check valve.
__________________
2000 coachmen santara 370 5.9 cummins300 hp isb
winniman is offline   Reply With Quote
Old 09-17-2017, 07:25 PM   #7
Member
 
Join Date: Feb 2016
Location: End of West Texas
Posts: 53
Yes, there is a check valve built in to the hose connection. Under 20 bucks to replace the connector.
__________________
Me and the wife
'16 Winnebago 31BE
Vhol5 is offline   Reply With Quote
Old 09-23-2017, 08:56 PM   #8
Member
 
Trynforpar's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Location: Northeast
Posts: 95
How is the check valve replaced.
__________________
Tom n Nancy, 2016 Itasca 40R, 2015 Jeep Wrangler
Chessie and Travis "The Pups"
Trynforpar is offline   Reply With Quote
Old 09-24-2017, 08:43 AM   #9
Member
 
Join Date: Feb 2016
Location: End of West Texas
Posts: 53
I know there are a couple of different types, but mine was just held in place by the 3 flange screws. Once those are out, the hose fitting is disconnected by hand, no tools other than the screwdriver. The fitting is like most of the hoses you buy to connect water lines to home faucets and toilets.
I think the other types may require a wrench to remove them from the old check valve/hose connector.
Pretty simple either way.
__________________
Me and the wife
'16 Winnebago 31BE
Vhol5 is offline   Reply With Quote
Old 09-24-2017, 08:55 AM   #10
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: St. Lucie West, FL
Posts: 4,925
Yes, your check valve has failed. The easy fix is a plug for the hose end. The benefit is it prevents critters from visiting your water hose.

Camping World, Ace Hardware, etc.
USH Replacement Hose Plug (RV-460C) - R V Accessories - Ace Hardware
__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is offline   Reply With Quote
Old 09-25-2017, 05:41 AM   #11
Member
 
Trynforpar's Avatar
 
Winnebago Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Location: Northeast
Posts: 95
Thanks to all for the assistance. I removed the hose connection and found that the check valve had some debris lodged in it so i cleaned it out and all is well. Thanks again.
__________________

__________________
Tom n Nancy, 2016 Itasca 40R, 2015 Jeep Wrangler
Chessie and Travis "The Pups"
Trynforpar is offline   Reply With Quote
Reply

Tags
water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'07 Hurricane 34B Main slide out creaping out while driving. ocfd_179 Thor Industries Owner's Forum 1 07-15-2012 11:05 AM
no hot water coming out of water heater J. Ingram iRV2.com General Discussion 12 05-31-2012 11:16 AM
Wiring RV Generator to supply main house ??? DonGott MH-General Discussions & Problems 22 11-09-2010 05:46 AM
Main slide one side not coming in all the way JimO Winnebago Industries Owner's Forum 5 10-16-2010 12:44 PM
Fresh Water Tank Leak - At main supply Connection Old Rv'er Alpine Coach Owner's Forum 7 09-06-2008 07:24 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.