Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-22-2016, 07:47 AM   #1
Member
 
Join Date: Jul 2015
Location: Rochester, NH
Posts: 38
2004 Nemar Dutchstar 41' - Cummins 370 - Filters

Talking to a Truck Driver while sitting broke down at the Cummins Repair shop in Maryland, I had mentioned that I thought the problem might be with the filters and that I actually carry some with me, but was afraid to change because I thought I would have to prime them etc.

He mentioned that I could have removed them with the engine shut off, replace, and then turn the key to accessory and wait for all the preliminary lights and sensors to be completed but not to start. He stated do that about 3 times and that it will prime them automatically in the Cummins 370 etc.

Has anyone known this and are there any other suggestions when replacing the filters?

Thanks
__________________

__________________
Corvetteman is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-22-2016, 10:18 AM   #2
Senior Member
 
siggyd's Avatar
 
Freightliner Owners Club
Join Date: Aug 2005
Location: Chicagoland
Posts: 656
Cycling the IGNITION ON should work , but a simple way is to pre-fill the filters with CLEAN diesel through the outer holes. I have done this and seen
the pro's do it and it has never failed.
Some filter heads have a pump attachment.

Siggy
__________________

__________________
Siggy & Ursula.
2011 Newmar DSDP 4020 (no Tag, no DEF, 07 emission),
FTL XCR ,ISL 400,2015 Jeep Cherokee Limited, 4x4, V6, Active Drive II, BrakeBuddy
siggyd is offline   Reply With Quote
Old 08-22-2016, 11:45 AM   #3
Senior Member
 
dennis45's Avatar


 
Join Date: Jun 2012
Location: BC
Posts: 6,354
You can install the filter dry and use the ignition to prime as the trucker said. In fact that is how Cummins reccomenends. I cycle the ignition at least four or five times to be sure it's fully primed.
__________________
Dennis & Carol
2003, 4006, 41' DutchStar, Spartan, ISC 8.3L W/BanksPower - 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake. And the 04 Bird, Sunshine Car.
dennis45 is online now   Reply With Quote
Old 08-22-2016, 04:34 PM   #4
owr
Senior Member
 
Tiffin Owners Club
Join Date: Jun 2015
Posts: 105
ditto

I usually do it 6 times to be sure and then turn the engine over and start. works on my 2004 ISL
__________________
2018 Tiffan Phaeton 40IH diesel pusher..
Cummins /Allison 10 KW gen,
Demsco SS dolly
owr is offline   Reply With Quote
Old 08-22-2016, 04:48 PM   #5
Member
 
Join Date: Jul 2015
Location: Rochester, NH
Posts: 38
As always, I thank all of you for taking the time to help!!!
__________________
Corvetteman is offline   Reply With Quote
Reply

Tags
cummins



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator/Antifreeze - 2004 Nemar Dutch Star - 41' - 370 Cummings Diesel Corvetteman Newmar Owner's Forum 10 12-25-2015 05:31 PM
Electrical / Battery Confusion - 2004 Nemar Dutch Star 41' Corvetteman Newmar Owner's Forum 23 11-21-2015 11:55 AM
Filters, filters and more filters tbbg II Newmar Owner's Forum 3 09-02-2015 10:00 AM
2004 isl 370 cummins coolhand108 Cummins Engines 4 06-16-2014 05:46 AM
2004 DSDP 4015 w/370 Cummins JC2 Newmar Owner's Forum 9 03-28-2012 10:43 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.