RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-18-2019, 12:40 PM   #1
Senior Member
 
tdjackson56's Avatar
 
Join Date: Oct 2013
Location: Woodbridge VA
Posts: 134
2006 Dutch Star Electrical Issues

My neighbor is having powers issues to electrical plugs for microwave and other appliances when using shore power.
Tested voltage from pedestal to Progressive Industries surge guard through Transfer switch and getting 238 volts. So that's normal.

Microwave light is dim and doesn't heat. Coffee pot barely works. TV's cut out anytime an appliance is tried or used.

These appliances work fine when using an extension cord from the 120v pedestal plug.
Everything works great when using the generator. I don't have a manual for the EMS displays but it's showing that it's reading 50amp coming in from shore power.
Suggestions.. I've checked and tighten all connections up to and through the transfer switch. 50 amp power cord seems to be in good shape. No circuits are tripping.
Thanks.
__________________

tdjackson56 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-18-2019, 02:30 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 19,487
The next step is to check and tighten the connections in the main breaker panel.

From there, its on to the inverter 120 volt connections.

The generator may be 120 volt, with 2 outputs, so a bad neutral may not cause voltages to get weird when the neutral is loose. 240 volts with a bad neutral will.

Have to checked the voltage at the microwave outlet, with and without a load on it ?
__________________

twinboat is offline   Reply With Quote
Old 09-19-2019, 07:02 AM   #3
Senior Member
 
tdjackson56's Avatar
 
Join Date: Oct 2013
Location: Woodbridge VA
Posts: 134
Quote:
Originally Posted by twinboat View Post
The next step is to check and tighten the connections in the main breaker panel.

From there, its on to the inverter 120 volt connections.

The generator may be 120 volt, with 2 outputs, so a bad neutral may not cause voltages to get weird when the neutral is loose. 240 volts with a bad neutral will.

Have to checked the voltage at the microwave outlet, with and without a load on it ?
I will test the connections as you suggested. I have not tested the outlet with a load on it. It tested good with no load.
Thanks
tdjackson56 is offline   Reply With Quote
Old 09-19-2019, 10:30 AM   #4
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 29,896
Do you have a cord reel?
Cord reel problems in QT's#3 and this sticky link.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 09-19-2019, 02:07 PM   #5
Member
 
Join Date: May 2019
Location: Smithfield, VA
Posts: 59
Temporarily connect without the surge protector. That will eliminate one possible source of a problem.
__________________
Tom & Carol, Smithfield, VA
2000 Dutch Star DP 3851 Spartan
CWO2 USN-Ret
tomgrigsby is offline   Reply With Quote
Reply

Tags
dutch star, electric, electrical



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newmar Dutch Star 4320 :: 2006 Newmar Dutch Star 4320 Archmark iRV2 Owners Registry 0 12-17-2018 07:15 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×