Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 02-04-2012, 10:32 PM   #1
Junior Member
 
Join Date: Jul 2010
Posts: 18
AC problem

I have a 1996 Dutch Star dp on a spartan chassis. One day while on the road my dash AC quit working. I noticed that the switch to activate the AC on the dash panel had got very hot. The dash fan would still work but no cold air. Then the dash fan also quit working. A 25amp block fuse on the firewall failed so I replaced it. The dash fan would come back on but the compressor didn't turn and the condenser fan did not run. I replaced the condenser fan with a new one and a new thermostat. The compressor turns now but the condenser fan still does not run. The switch on the dash panel still gets very hot. Where should I go from this point to trouble shoot. Could it be the condenser fan relay? I'm not sure where the condenser fan relay is.
__________________

__________________
sharring is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 02-05-2012, 02:49 AM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,726
I would check th motor for condenser fan, some thing is seized and you will keep blowing the fuse or cause possibly a fire around the switch area.
Can you manually turn the fan maybe some oil on shaft could free it up.
Who is the mfg of your AC/ Heater unit?
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 02-05-2012, 03:08 AM   #3
Junior Member
 
Join Date: Jul 2010
Posts: 18
The AC unit is an Evans Tempcon unit. There are no markings on the fan. I suspected the old fan was drawing too many amps so I bought a brand new one. It turns real easy.
__________________
sharring is offline   Reply With Quote
Old 02-10-2012, 12:43 AM   #4
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 26,726
Here is a link to Evans Temp may have trouble section.
Here is a wiring control diagram.
This information is in Quick Tips.
The relay may be on the Evans unit or near fuse panel.
You need to keep your questions in same thread gets confusing chasing down your problems.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake Safety Problem w/Key Off EngineerMike Alpine Coach Owner's Forum 18 03-23-2012 01:59 PM
Starting Problem - Electrical dave1518 Winnebago Industries Owner's Forum 8 06-27-2011 09:03 AM
Dometic Frig Problem dieselclacker RV Systems & Appliances 2 07-29-2009 04:12 AM
Journey slide problem Savannah Winnebago Industries Owner's Forum 9 07-20-2009 04:21 PM
Magnadyne DVD Problem - Possible Fix Robin_M Monaco Owner's Forum 21 07-06-2009 08:58 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.