RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-22-2019, 11:48 AM   #1
Senior Member
 
Join Date: May 2016
Posts: 208
AC Problems

Have a almost new Dometic AC on the MH was in it this week and it stopped blowing cold air. The fan blows but I donít hear the compressor kicking on. This is not but about a year old. It is one of the bigger units. Iím a disabled veteran on disability and canít really hire any one to work on this so I need to try to fix it. Need it going in a few days. Would be very thankful for any help.
__________________

okie mopar is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-22-2019, 12:15 PM   #2
Senior Member
 
Switt's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Feb 2015
Location: Kingsport,Tennessee
Posts: 167
Had the same problem once turn off battery disconnect for about 1 minute and no more problems. Worth a try.
__________________

__________________
Sam&Tobe
2019 Ventana 4037
2014 CRV
Switt is offline   Reply With Quote
Old 06-22-2019, 01:39 PM   #3
doc
Senior Member
 
doc's Avatar
 
Appalachian Campers
Join Date: Sep 2002
Location: Dixie !! (north Georgia) USA
Posts: 3,345
Don't know about Dometic, but that "disconnect all power for a few minutes" is the same advice I got from a tech in Rapid City. He didn't want to make a 100 bucks for a trip to the park apparently. Worked like it was supposed to when we powered back up
doc is online now   Reply With Quote
Old 06-22-2019, 07:46 PM   #4
Senior Member
 
Join Date: May 2016
Posts: 208
AC

Do I need to have it turned off are running when Turn off the switch ?
okie mopar is offline   Reply With Quote
Old 06-22-2019, 07:48 PM   #5
Senior Member
 
Join Date: May 2016
Posts: 208
Ac

Do I need to be unhooked from the AC power too
okie mopar is offline   Reply With Quote
Old 06-23-2019, 06:28 AM   #6
Senior Member
 
Switt's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Feb 2015
Location: Kingsport,Tennessee
Posts: 167
You can turn unit off first but no need to unhook AC power.
__________________
Sam&Tobe
2019 Ventana 4037
2014 CRV
Switt is offline   Reply With Quote
Old 06-25-2019, 07:29 PM   #7
Senior Member
 
Join Date: May 2016
Posts: 208
Ac

I cut the switch off and waited and it didnít work. Iím going to check the capaciter and see if it is bad. Gotta get this AC going.
okie mopar is offline   Reply With Quote
Old 06-26-2019, 07:09 AM   #8
Senior Member
 
FLJOE's Avatar
 
Join Date: Oct 2017
Location: Full Timing From SW Florida
Posts: 1,209
If you are in a motorhome it might be called the "salesmen switch"? Turn that darn thing off and back on.
__________________
2017 Newmar 4369 Ventana
Toad: 24' enclosed w/Harley, Mini Cooper, Kayaks
U.S. Army: VN 71-72 (64B20)
FLJOE is offline   Reply With Quote
Old 06-26-2019, 07:56 AM   #9
Dom
Senior Member
 
Join Date: Apr 2018
Posts: 236
Quote:
Originally Posted by FLJOE View Post
If you are in a motorhome it might be called the "salesmen switch"? Turn that darn thing off and back on.
You might try disconnecting all power sources, ac and dc, as I had one unit I was working on that was getting dc power through through the inverter> Also you could try turning fan to lowest setting and listen real hard to see if you notice any unusual sounds, like a motor trying to start, like a stalled compressor. Do you have access to an ammeter?
Dom is offline   Reply With Quote
Old 06-26-2019, 05:35 PM   #10
Senior Member
 
Join Date: May 2016
Posts: 208
Tools

I have got a meter and just about any thing I need to have. Ijust have to wait till early in the morning when it's cool before I get up there, I'm a disabled vet on o2 all the time so I have it do a little at a time to get stuff done. It sure gets warm in here .
okie mopar is offline   Reply With Quote
Old 06-27-2019, 08:10 AM   #11
Dom
Senior Member
 
Join Date: Apr 2018
Posts: 236
You could measure the amps from down below of you can split the power line going to MH
Dom is offline   Reply With Quote
Old 06-30-2019, 02:38 PM   #12
Senior Member
 
Join Date: May 2016
Posts: 208
AC

Got the capacter out of the AC it has no power.in it
Tried to discharge it snd it is completey dead no spark at all, So I'll get a new one and see if it will work. THANKS
__________________

okie mopar is offline   Reply With Quote
Reply

Tags
ems, problem, problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dealers for Palazzo Problems & Thor Slide Problems "007" Thor Industries Owner's Forum 29 11-10-2015 05:29 AM
A/C Problems with heavy condensation problems Help Please!! Tevans Newmar Owner's Forum 6 06-21-2015 08:26 AM
Workhorse springs and supply problems Max Tunnell Workhorse and Chevrolet Chassis Motorhome Forum 14 11-29-2008 12:22 PM
Problems with Directv receiver during Set Up wagonmaster2 Technology: Internet, TV, Satellite, Cell Phones, etc. 10 11-23-2008 12:41 PM
Leaking problems with Hybrid anyone else have problems? Barrie Expandables, Hybrids, & Lightweights Discussion 2 11-20-2005 08:08 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:02 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.