RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-28-2011, 12:22 PM   #1
Junior Member
 
weazel5's Avatar
 
Join Date: Nov 2010
Posts: 6
Bad circuit boards!?

Both front slides went kaput! No sound of the motor even running. Took it in to service and they said that the circuit boards were bad! They were replaced, and it's good as new (except for the atwood leveling jacks- they suck)

Yes, I had the mh plugged in to 50 amp juice...
Any thoughts or similar issues on this?
__________________

weazel5 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-28-2011, 08:35 PM   #2
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 29,103
Welcome to the Newmar forum & irv2.
In the Quick Tips link you have a COM_NET link that will give you info on your coach.
In QT there is also info on your slide system, not sure what your problem was with slides but I have 8 year old controls without problems.
What was your problem with slides?
Jacks should work off just your batteries, but they are a problem.
Enjoy the forums and do post often.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC Circuit Overload Blue Ribbon MH-General Discussions & Problems 3 07-21-2010 02:42 AM
Onan circuit board is toast inspectorudy Winnebago Industries Owner's Forum 3 07-06-2010 01:24 AM
Bad Breaker on Air Conditioner? deaton Monaco Owner's Forum 16 07-04-2010 06:16 AM
Charging Circuit killing house batteries in storage BellaBo Workhorse and Chevrolet Chassis Motorhome Forum 5 08-28-2008 04:22 AM
Charging Circuit killing house batteries in storage BellaBo Gulf Stream Owner's Forum 1 08-27-2008 06:31 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.