RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-14-2018, 10:08 AM   #1
Junior Member
 
Join Date: Oct 2015
Posts: 2
blank silver leaf screens

help,

have a 2014 mountain aire ,my screens for my silverleaf monitoring systems both are blank with white background. coach was in storage for a short while and battery went dead, after complete 24 hr charge everything in coach is fine EXCEPT silver leaf screens. any idea's


jim
__________________

jim32174 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-14-2018, 10:13 AM   #2
Member
 
don mccoy's Avatar
 
Join Date: Mar 2017
Location: seaford va
Posts: 50
Quote:
Originally Posted by jim32174 View Post
help,



have a 2014 mountain aire ,my screens for my silverleaf monitoring systems both are blank with white background. coach was in storage for a short while and battery went dead, after complete 24 hr charge everything in coach is fine EXCEPT silver leaf screens. any idea's





jim


Unplug screen for a few minutes then reply and see what happens Also check plug-in close to insure contact on all pins
__________________

don mccoy is offline   Reply With Quote
Old 01-14-2018, 06:16 PM   #3
Senior Member
 
Stealth01's Avatar
 
Newmar Owners Club
Join Date: Jun 2013
Location: MidWest
Posts: 1,027
Quote:
Originally Posted by jim32174 View Post
help,

have a 2014 mountain aire ,my screens for my silverleaf monitoring systems both are blank with white background. coach was in storage for a short while and battery went dead, after complete 24 hr charge everything in coach is fine EXCEPT silver leaf screens. any idea's


jim
If both screens are blank, assuming you have two displays, it's not the display units. the displays are "agnostic" to the system. First I would try a complete AC/DC reset of the coach... All power off and then bring DC on followed by AC. If their still blank I would check the connections to your TM-102 module, it's the "heart" of your system. The TM-102 is located behind your power cord reel in your electrical bay. The connector you want to check is located on the upper right side of the module. If the connection is good, check fuses F1 and F2 on the Relay Interface Board in that same compartment. If they are good it's time to call Silverleaf...
__________________
Ken & Anita 2011 Newmar Essex,4522,Cummins 500 ISM,2013 CRV,RVI2 Brake with TPMS **Our Travel WebSite**
Stealth01 is online now   Reply With Quote
Old 01-15-2018, 08:22 AM   #4
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 29,939
Battery supplies for screens maybe at fault also this link has locations of battery supply.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply

Tags
scr



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Silver Leaf 330 CLarence39 Monaco Owner's Forum 7 04-29-2012 08:50 AM
Silver Leaf 330 In Dash CLarence39 Monaco Owner's Forum 9 01-20-2012 09:39 PM
Data port switches, Silver Leaf system Charlie L Alpine Coach Owner's Forum 5 08-05-2011 09:04 PM
Silver Leaf System big jimbo Alpine Coach Owner's Forum 3 01-02-2008 03:06 AM
Silver River SP, Silver Springs, FL Jody & Jeff Camping Locations, Plans & Trip Reports 2 07-19-2005 07:34 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×