RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-13-2018, 10:42 PM   #1
Member
 
Join Date: Jan 2017
Posts: 41
Blowers On Twin Temp Furnace Not Working

We have Precision Temp, Twin Temp Hydronic Heating/Water Heater. The unit heats with both 110 and LP and during winter mode it circulates the heated fluid in the floor. We have hot water coming from the faucets, the floor is warming, BUT the blowers in each of the two zones are not working. Checked the thermostat and it is working because the heat pump ran just fine, however it is going to get cold enough tonight it will not function. So we were going to use the furnace and there are no blowers working to move the warm air. Looked all over to see if there was a fuse that might be blown, couldn't find one. Does anyone have any other ideas to check out. Appreciate any advice. Thanks.
__________________
David and Sherry
2010 Dutch Star DP 4386, 2009 Harley Davidson
2014 Ford Edge John 3:16
krzy parents is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Reply

Tags
furnace, ace



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
One of the 4 heater blowers is not working 05 American Eagle Monaco Owner's Forum 14 01-07-2018 10:35 PM
Furnace heat blowers jimbo2013 Newmar Owner's Forum 3 05-23-2017 06:38 AM
Twin Temp operating instructions dwarner109 Newmar Owner's Forum 5 10-20-2016 06:47 PM
W22 Twin Electric Fans Not Working bowpulpit Workhorse and Chevrolet Chassis Motorhome Forum 6 06-08-2013 01:57 PM
Precision Twin-temp Jr Question Terry43 Newmar Owner's Forum 4 08-09-2012 06:49 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.