Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-03-2011, 07:46 PM   #1
Junior Member
 
Newmar Owners Club
Join Date: Apr 2008
Posts: 8
City Water?

2007 CanyonStar. We only get water when we have water in our fresh water tank. We have tried every up and down option on the City Water/Fill lever, and tried all pumps. We just are never able to use the City Water option and when we do fill our fresh water tank, it seems to take forever. We don't get it... HELP!
__________________

YukieBear is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-03-2011, 07:55 PM   #2
Senior Member
 
Tiffin Owners Club
Join Date: Aug 2008
Location: Las Vegas, NV
Posts: 123
Send a message via MSN to Saber77
Make sure your demand water pumps are turned off when using city water. Same for when filling your water tank.
__________________

__________________
Roger & Fran
US Army (Ret)
2018 Tiffin Wayfarer, 2012 Honda CRV with Invisibrake
Saber77 is offline   Reply With Quote
Old 04-03-2011, 07:56 PM   #3
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 27,868
You may have a problem with the fill valve that goes to left to fill fresh water tank and straight up for city water use.
When you have on city water shut off water pump.
Do you have a picture of your water closet?
We have Canyon Star owners so be patient I'm sure you will get other answers.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 04-03-2011, 09:19 PM   #4
Senior Member
 
Luv2go's Avatar
 
Newmar Owners Club
Nor'easters Club
Appalachian Campers
Ford Super Duty Owner
Coastal Campers
Join Date: Dec 2007
Posts: 2,032
YukieBear, does your coach have a built-in water filter? Ours does and we noticed our flow decreasing and fill times increasing drastically. Finally figured out that the filter had clogged! Replaced it and we have great flow and fills the water tank really fast.
__________________
Stewart, Brenda and kids
2008 Newmar Canyon Star 3410
2006 Roadtrek Versatile 210
Luv2go is offline   Reply With Quote
Old 04-03-2011, 09:41 PM   #5
Community Administrator
 
JohnRR's Avatar


 
Fleetwood Owners Club
Workhorse Chassis Owner
Join Date: Sep 2010
Location: Marquette, Michigan "Da UP"
Posts: 17,184
Quote:
Originally Posted by YukieBear View Post
when we do fill our fresh water tank, it seems to take forever.
Are you by any chance using a inline water pressure regular with a very small hole?
__________________
John & Cathy R.
06 Pace Arrow 38L W24
08 14 Lincoln MKX AWD
See My RV Upgrades
JohnRR is offline   Reply With Quote
Old 04-04-2011, 02:18 PM   #6
Junior Member
 
herboni's Avatar
 
Newmar Owners Club
Join Date: Jun 2010
Posts: 13
Had the same problem. It was the knob on the water valve switch- it was sliding on top of the valve stem. Remove the plastic knob and use pliers to turn the valve.

Herboni
2007 MADP
herboni is offline   Reply With Quote
Old 04-04-2011, 05:06 PM   #7
Senior Member
 
wa8yxm's Avatar
 
Damon Owners Club
Workhorse Chassis Owner
Join Date: Mar 2009
Posts: 23,948
You said "It seems to take forever to fill the tank" via the quick fill valve.

I'm guessing, and I stress GUESSING, one of two issues here.

1: A problem with the quick fill valve,, Odds are fairly high on this.. This valve can fail and when it does the symptoms (Well one failure mode) would match what you describe... Other failure modes.. different.

2: The city water inlet...Lower odds here as you said you get NO water if you do not have the pump on and the tank takes forever to fill. IF this was the case I would expect either a trickle of water w/o the pump, it the tank not to fill at all.
__________________
Home is where I park it!
wa8yxm is offline   Reply With Quote
Old 04-04-2011, 07:47 PM   #8
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 27,868
I recall someone else with herboni's answer having same problem.
If the valve is working correctly city water is a direct short into fresh water tank through your water filter no pump is involved, water will flow fast into fresh water tank.
Have you checked the water filter, is it new?
__________________

__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans, now in good hands
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 American coach control panel in city water compartment Gene G. Fleetwood Products Owner's Forum 2 04-02-2011 09:05 AM
City water inlet leaking 1998 national tradewinds gperryrv National RV Owner's Forum 16 02-21-2011 08:08 PM
city water connection england, and cheap wifi england europe harryoxford2 Technology: Internet, TV, Satellite, Cell Phones, etc. 3 09-23-2010 03:22 PM
City Water Inlet Leaking gator67 Alpine Coach Owner's Forum 2 08-26-2009 05:34 PM
Kit Kamper Projects - Project #14, Water Heater Replacement RedneckExpress Vintage RV's 5 10-28-2008 04:31 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.