RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-30-2011, 04:59 PM   #1
Junior Member
 
Join Date: Nov 2010
Posts: 13
Engine Brake quit working

I have an 06 Dutch Star with a 400 Cummins, and all of the sudden my engine brake quit working. The "ON" swith does not light-up when I engage it.

Is there a fuse for the auxillary brake?
__________________

SOTA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-30-2011, 09:24 PM   #2
Member
 
Join Date: Apr 2010
Posts: 94
There is a five amp fuse in our '06 DSDP in a basement compartment on the passenger side just in front of the rear wheel. Inside that compartment is a 3x6 inch black box that contains fuses. That's where we found ours when we had this problem.
jdocter7 is offline   Reply With Quote
Reply

Tags
brake



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 alpine exhaust brake quit working CRSANISLO Alpine Coach Owner's Forum 3 08-16-2011 06:09 PM
Engine brake problem georgetown350 MH-General Discussions & Problems 2 01-13-2010 09:36 AM
Engine Brake & Supplemental Braking System Jim_L Toads and Motorhome Related Towing 3 04-06-2008 05:03 PM
Engine Brake Paulin Duramax Engine Forum 6 02-09-2008 02:38 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.