RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 07-29-2018, 09:16 AM   #1
Senior Member
 
Newmar Owners Club
Join Date: Jan 2015
Posts: 171
Erratic Readings for Black Tank on New (2018) Tank Monitor

We have the new tank monitor which worked great initially. After using it for about 1.5 months it stopped reading 0 for the black tank after dumping. Watching the display, it would go down to 0 as the tank was emptying but a few seconds later it jumps back up to anywhere from 50 to 65%. Flushing it doesn't seem to make a difference.

I'm curious how many people are having similar problems with this new system.

Click image for larger version

Name:	EmptyBlackTank65.png
Views:	181
Size:	195.7 KB
ID:	212914

Thanks,
Dan
__________________

__________________
2018 Ventana 4369
dxg0001 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-29-2018, 10:14 AM   #2
GKU
Senior Member
 
GKU's Avatar
 
Join Date: Apr 2014
Location: Leesburg, Florida
Posts: 207
Following this thread to find out the answers to this one.
__________________

__________________
George & Kathy
2019 Mountain Aire 4551
2018 Jeep Cherokee TrailHawk
GKU is offline   Reply With Quote
Old 07-29-2018, 04:35 PM   #3
Senior Member
 
Fitztrux's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Oct 2017
Posts: 133
Quote:
Originally Posted by dxg0001 View Post
We have the new tank monitor which worked great initially. After using it for about 1.5 months it stopped reading 0 for the black tank after dumping. Watching the display, it would go down to 0 as the tank was emptying but a few seconds later it jumps back up to anywhere from 50 to 65%. Flushing it doesn't seem to make a difference.

I'm curious how many people are having similar problems with this new system.

Attachment 212914

Thanks,
Dan
Had similar issue with false readings on water. Returned to dealer for recalibration.
__________________
Toney & Linda Fitzgerald
2018 Dutch Star 4326
Intech 20' Trailer / 2013 Subaru Outback - 2005 Chevrolet SSR
Fitztrux is offline   Reply With Quote
Old 07-29-2018, 05:02 PM   #4
Senior Member
 
Sicduc's Avatar
 
Newmar Owners Club
Join Date: Oct 2011
Location: Pompano Beach Fl
Posts: 474
We spent 2 1/2 mo on the road and we did have any major problems with the tank gauges until we left our last stop in New Orleans. I dumped the tanks and I thought all was good for the ride home to So Fla until the wife went to use the 1/2 bath to pee and she said the red light was on the flush button so I went looking for some bumps in the road hoping that would take care of the problem but it didn't and it read 100% full... Some time over the next 2-3hrs of driving it freed up and all was good the rest of the way home... Even after dumping before this it rarely went back to 0% I'll be taking it to the Mothership on Oct 1 and I will have it addressed then with the other 30+ items...
__________________
Mitch & Laura
And The Doodle Brothers
2018 DSDP 4369/2016 Subaru Crosstrek 5spd
Sicduc is offline   Reply With Quote
Old 07-29-2018, 05:04 PM   #5
Senior Member
 
Desertboyz's Avatar
 
Newmar Owners Club
Join Date: Apr 2015
Location: Could be anywhere
Posts: 483
We have the identical problem. Sometimes the amber "getting full" light shows just after emptying.
__________________
[SIGPIC][/SIGPIC]

Randy, Donald and Zoe (Rat Terrier)
2018 Newmar Dutch Star 4369 K2/2016 Jeep Cherokee High Country
Desertboyz is online now   Reply With Quote
Old 07-29-2018, 05:20 PM   #6
Member
 
gesmone's Avatar
 
Newmar Owners Club
Join Date: Jun 2010
Posts: 83
Quote:
Originally Posted by Desertboyz View Post
We have the identical problem. Sometimes the amber "getting full" light shows just after emptying.


I have had the same issue on the black tank. Flushing with the black water rinse has always resolved the issue.
__________________
2018 Dutch Star 4018: 45 years rving
Georgia
gesmone is offline   Reply With Quote
Old 07-29-2018, 06:12 PM   #7
Senior Member
 
Ken C's Avatar
 
Join Date: Nov 2007
Location: Fulltime, Formally SF Bay Area
Posts: 317
I have the same issue. After dumping and flushing the black tank, it will read in 40% area. Sometimes eventually goes back down the next day. Gray tank & fresh water level seems to read correctly.

Ken C
2018 DS 4052
Jeep Cherokee Trailhawk
Ken C is offline   Reply With Quote
Old 08-01-2018, 10:43 PM   #8
Senior Member
 
VP Chianese's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Oct 2014
Location: FL
Posts: 1,035
Quote:
Originally Posted by Ken C View Post
I have the same issue. After dumping and flushing the black tank, it will read in 40% area. Sometimes eventually goes back down the next day. Gray tank & fresh water level seems to read correctly.

Ken C
2018 DS 4052
Jeep Cherokee Trailhawk
Same problem. It takes a couple of flushes to get it to go down but it never goes to the bottom like it did in the beginning.

Will be at the plant on the day after Labor Day for a list of about 20 items. Most just little adjustments.
__________________
Vinny, Sandy and JD a Working Portuguese Water Dog
2018 DS DP 4369 #607121 Cummins ISL9 450 HP
"We are from, where ever we were yesterday"
VP Chianese is offline   Reply With Quote
Old 08-01-2018, 11:21 PM   #9
Senior Member
 
Winepress's Avatar


 
Join Date: Jul 2012
Posts: 1,344
Erratic Readings for Black Tank on New (2018) Tank Monitor

Residue left on the tank walls. Try Happy Camper, it works.
__________________
2018 Dutch Star 4369
Everything was working fine, until it wasn't.
Winepress is online now   Reply With Quote
Old 08-02-2018, 07:54 AM   #10
Senior Member
 
Newmar Owners Club
Join Date: Jan 2015
Posts: 171
Quote:
Originally Posted by Winepress View Post
Residue left on the tank walls. Try Happy Camper, it works.


We are actually in Nappanee for warranty work. The consensus is that there is residue on the wall, however, the system is supposed to deal with a bit of residue. They had the developer (KIB) of the monitoring system looking at it. In fact, they brought in the programmer to improve the algorithm. It all looked good when they tested by filling it with water then dumping. Tested several times and it went down to 0. First time of "real" use it's back to the same problem. And yes, we are using Happy Camper.

We are still waiting to see if they come up with a solution ...
__________________
2018 Ventana 4369
dxg0001 is offline   Reply With Quote
Old 08-02-2018, 09:22 AM   #11
Junior Member
 
Newmar Owners Club
Join Date: Dec 2017
Posts: 29
Mine quit working completely - it showed zero levels on the tanks and no readings on the batteries. My coach has been at the dealer for more than 2 weeks getting it replaced. The replacement panel was also defective, so now we're waiting on the second one from Newmar/KIB.
__________________
Bob & Barbara
2018 Ventana 3407
2016 Jeep Wrangler
Ventana303 is offline   Reply With Quote
Old 08-02-2018, 10:35 AM   #12
Senior Member
 
Pikkleballer's Avatar
 
Join Date: Sep 2017
Location: Southwest Michigan
Posts: 122
We have been having issues with the gray tank monitor. It won't go to zero after dumping. It goes down to 10 or 15%.
Even after a good rinsing and driving a few miles with it nearly full of soapy water it didn't solve the issue.
__________________
Mark & Candy
2018 Newmar Canyon Star 3513
2009 Honda Fit Sport (toad)
Pikkleballer is offline   Reply With Quote
Old 08-02-2018, 11:00 AM   #13
Junior Member
 
Join Date: May 2017
Location: Lake Michigan
Posts: 7
Occasionally we would get false readings with black tank due to residue... since adopting a routine of adding Dawn dish soap each time we empty and a capful of water softener in areas with hard water, plus a heavy tank rinse every 3rd time we empty... we have had zero problems. One time we had a false read on the gray tank but hasn't happened since (fingers crossed).
roadwoody is offline   Reply With Quote
Old 08-02-2018, 11:57 AM   #14
Senior Member
 
BBelanger's Avatar
 
Newmar Owners Club
Join Date: Apr 2016
Location: Caribou, Maine
Posts: 1,832
Quote:
Originally Posted by dxg0001 View Post
We have the new tank monitor which worked great initially. After using it for about 1.5 months it stopped reading 0 for the black tank after dumping. Watching the display, it would go down to 0 as the tank was emptying but a few seconds later it jumps back up to anywhere from 50 to 65%. Flushing it doesn't seem to make a difference.

I'm curious how many people are having similar problems with this new system.

Attachment 212914

Thanks,
Dan

I have the same problem, most of the time. I've learned to ignore it. If someone finds an answer, I'd like to know. My grey tank always fills way before black, so I just dump both everytime.
__________________

__________________
Bill & Chris Bélanger (KI1Z)
'04 Georgetown XL > '17 4018 DSDP FL > '18 DSDP 4327 K2
2018 JL Wrangler Rubicon 2 Door
BBelanger is offline   Reply With Quote
Reply

Tags
black tank, monitor, tank



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic readings on air pressure gauge on DP desertdd Class A Motorhome Discussions 3 05-26-2018 11:35 PM
Erratic black tank readings 2017 MoHoGo Entegra Owner's Forum 12 03-31-2017 06:04 AM
Monitor Panel readings vs. voltage meter readings larrydp Class C Motorhome Discussions 15 09-26-2012 02:26 PM
Erratic Readings on Oil Pressure and Speedomoter K5EAG MH-General Discussions & Problems 4 09-18-2010 11:47 AM
Erratic Gauge Readings Margarittamobile Freightliner Motorhome Chassis Forum 1 07-20-2010 09:12 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×