RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-10-2017, 04:28 PM   #1
Rd1
Senior Member
 
Join Date: Mar 2016
Posts: 419
FWS stopped, no ignition power, no accessory power

While bringing in the FWS, it stopped halfway. DOA. The other elec slides and everything else in the coach works. However, the dash, ignition and accessories were all dead.

Turning off the main chassis battery was no good, as there was no power to the switch either. The silverleaf actually showed the chassis batt charging and 13.7v. Coach was on shore power. Has anyone experienced this?? Found out what the problem is, but do not know what was the cause!!!


There is a chassis fuse/controller/relay box in the chassis batt compartment. Rear right hand side of the coach. (please see pics) Right next to the chassis batt on/off switch, there is panel. Removing the panel(4 bolts), you will find the fuse box. I think this would be common at least to MA, LA and EX units. There are 2 x 150A fuses that protect batt power into the entire system. One is for ignition supply and the other for the accessories. They are marked on the box cover. One was blown. Not sure what cause it. IF you do not have the 150A, you might want to get some. I know freightliner dealers may have them, perhaps auto parts too. About $9.00 each.
Attached Thumbnails
Click image for larger version

Name:	Chassis-Fuse (3).jpg
Views:	66
Size:	214.7 KB
ID:	176164   Click image for larger version

Name:	Chassis-Fuse (1).jpg
Views:	107
Size:	242.9 KB
ID:	176165  

Click image for larger version

Name:	Chassis-Fuse (2).jpg
Views:	78
Size:	173.4 KB
ID:	176166  
__________________

Rd1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-10-2017, 06:13 PM   #2
Senior Member
 
Skip426's Avatar


 
Join Date: Apr 2011
Location: Powell River, B.C.
Posts: 18,492
Your chassis has a much nicer set up than mine .

The connection with corrosion ( yellow circle ) may be contributing to the fuse failure , when corrosion causes the voltage to drop , amp draw goes up as volt supply goes down.
Attached Images
 
__________________

__________________
99DSDP 3884, Freightliner, XC, CAT 3126B, 300 HP /ALLISON 3060
2000 Caravan toad, Remco & Blue Ox.
Skip426 is offline   Reply With Quote
Old 09-12-2017, 06:08 AM   #3
Rd1
Senior Member
 
Join Date: Mar 2016
Posts: 419
So far, the only culprit appears to have been the chassis ON/OFF switch. The wire/nut were tight. However, the mechanics of the switch had some play.
Rd1 is offline   Reply With Quote
Reply

Tags
ignition, power



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn on Ignition Accessory or Not? 2013 MKT LaserMark4 Toads and Motorhome Related Towing 4 09-27-2015 10:48 AM
Blue Ox Patroit and accessory power concern KayChuck Toads and Motorhome Related Towing 4 04-22-2014 12:10 PM
No power to generator or accessory side of key switch Jon bennett Freightliner Motorhome Chassis Forum 4 02-19-2014 09:27 AM
Ignition accessory switch Grandhiker Tiffin Owner's Forum 8 12-23-2008 03:33 AM
Anyone stopped OR NOT stopped for pulling motorcycle trailer behind TT? tammyinwv Trailer Towing and Tow Vehicles Discussion 17 02-26-2007 08:54 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×