RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-05-2018, 10:32 AM   #1
Senior Member
 
Join Date: May 2010
Location: Tucson
Posts: 131
High idle.

2018 Dutchstar on a Freightliner. About 5 seconds after start up engine goes to high idle of 1250 rpm. It also goes to high idle when ever the parking brake is engaged. The idle drops to 850 rpm when stepping on the brake pedal or disengaging the parking brake. Is this normal? Is there a way to disengage the high idle? I have tried with the cruise control but no luck. Any help please.
__________________

__________________
2018 DUTCHSTAR 4002, 2014 JEEP UNLIMITED RUBICON, 3 CAIRN TERRIERS, MODEL RAILROADER
TUCSONRAIL is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-05-2018, 11:22 AM   #2
Senior Member
 
Ford Super Duty Owner
Join Date: Jan 2011
Location: Kitts Hill, OH
Posts: 2,158
Quote:
Originally Posted by TUCSONRAIL View Post
2018 Dutchstar on a Freightliner. About 5 seconds after start up engine goes to high idle of 1250 rpm. It also goes to high idle when ever the parking brake is engaged. The idle drops to 850 rpm when stepping on the brake pedal or disengaging the parking brake. Is this normal? Is there a way to disengage the high idle? I have tried with the cruise control but no luck. Any help please.
I think it is normal Our newer school buses do the same thing. I think it this programming of the ECM may help it meet emmissions standards.
__________________

__________________
(RVM#26) THE U-RV 94 F-700/24 foot U-haul box home built RV
Mekanic is offline   Reply With Quote
Old 08-05-2018, 01:25 PM   #3
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Oct 2014
Location: Lake McClure, CA
Posts: 703
I'm on a Spartan and after start up hit the "on button" for cruise control and the cruise "set button" and the idle goes up to 1000rpm. I then hit the "Res+"and it will go to 1250. I do this all the time , faster warm up, faster air up and better for the motor.
__________________
2018 Dutch Star 4369 Spartan Chassis
2016 Jeep Cherokee, 1952 Willys CJ3A
10 fan is offline   Reply With Quote
Old 08-05-2018, 02:24 PM   #4
Senior Member
 
Algoma's Avatar
 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 3,082
Quote:
Originally Posted by TUCSONRAIL View Post
2018 Dutchstar on a Freightliner. About 5 seconds after start up engine goes to high idle of 1250 rpm. It also goes to high idle when ever the parking brake is engaged. The idle drops to 850 rpm when stepping on the brake pedal or disengaging the parking brake. Is this normal? Is there a way to disengage the high idle? I have tried with the cruise control but no luck. Any help please.
Try turning the a/c off.
__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is offline   Reply With Quote
Old 08-05-2018, 02:25 PM   #5
Senior Member
 
Ricci's Avatar
 
Newmar Owners Club
Tiffin Owners Club
Join Date: Feb 2017
Posts: 630
Hi - No that doesn't sound right. If the engine has been idled too long it will go into that mode. Not knowing how you use the coach it's hard to say but if you take it for a 30 minute drive at highway speeds and it still does it then something is amiss. Could be emissions related. Are there any codes present?


Tom
__________________
Tom and Annie & Java
Fulltiming since 2011 / 2018 DS 4369
2020 DSDP 4369 Spartan (Build 7/12)
Ricci is offline   Reply With Quote
Old 08-05-2018, 04:07 PM   #6
Senior Member
 
Join Date: May 2010
Location: Tucson
Posts: 131
Thank you all for your responses. It was indeed the dash A/C causing the high idle. What a great forum this is.
__________________

__________________
2018 DUTCHSTAR 4002, 2014 JEEP UNLIMITED RUBICON, 3 CAIRN TERRIERS, MODEL RAILROADER
TUCSONRAIL is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High idle...how high? Fugitive861 Cummins Engines 6 09-16-2016 08:45 PM
To idle or not to idle jmoffat Caterpillar Engine Forum 36 05-11-2014 10:54 PM
454 W/ VERY HIGH IDLE AT INITIAL STARTUP tjwolf Workhorse and Chevrolet Chassis Motorhome Forum 9 11-04-2007 03:35 AM
high idle FrankReno Workhorse and Chevrolet Chassis Motorhome Forum 4 08-30-2007 08:32 AM
High Idle Grizwald2 Toy Haulers Discussion 2 12-20-2006 09:56 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.