RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-17-2016, 05:34 PM   #1
Senior Member
 
slabman's Avatar
 
Ford Super Duty Owner
Join Date: Oct 2002
Location: Plano TX
Posts: 2,237
Is this going to be the norm?

When my coach was new, I had to re-set the tank readings as displayed on the Silverleaf screen. ( fyi....this is a different monitoring setup than is used on the Dutch Star units, etc.) Now, two years later, I have the same inaccurate readouts. It appears to display fluid levels normally, but at the 80% point it jumps to 100%. However, the tank is not nearly full. Looks like I need to get to another dealer to have display readouts adjusted again. Question: Is this something others have had to do periodically?

Note: This occurrnce began soon as I drove off the North Trail lot.
I also noticd a temperature thermistor now shows it's -459 degrees in the bedroom...no matter what the temp really is..... And, oh yeah...the entire coach electrical system was disconnected for a few hours while I installed those new batteries a couple weeks ago.


The only things I had them do was adjust my porch awning and find a reason for and reset the engine "mil" light that had been lit up for the last 1500 miles.
__________________

__________________
Slabman
2014 Newmar Essex 4544
2007 Lexus LX470 Toad
slabman is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-17-2016, 07:23 PM   #2
Senior Member
 
FLSteve's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Mar 2011
Location: Fort Myers, FL
Posts: 1,179
slabman ... I don't have the Silverleaf system so am no help on that.

However I was going to ask you how your overall service experience went at NorthTrail. From drop off to pick-up. Also how was the communication between you and your service adviser?

Mine is in there right now and the jury is still out on how I will ultimately answer these questions.

Steve
__________________

__________________
Steve & Lisa
2019 Dutch Star 4018
2018 JL Rubicon & 2019 Cherokee Trailhawk Elite
FLSteve is online now   Reply With Quote
Old 04-17-2016, 07:29 PM   #3
Senior Member
 
David D.'s Avatar
 
Join Date: Nov 2013
Posts: 347
Maybe you should down grade to something that would be less technical. Like a V. Anything to make life simpler!!!😅😅😅
David D. is offline   Reply With Quote
Old 04-17-2016, 08:04 PM   #4
Community Moderator
 
TonyDi's Avatar


 
Newmar Owners Club
Join Date: Feb 2011
Location: Central NJ
Posts: 16,728
Most systems in the Essex are well engineered. Newmars service techs will help you get the gauges reading correctly again. (574) 773-7791

I'm curious, why did you have to install new batteries in the MH? That could be the cause of the reading being off. It's like radios, if you totally power them off you lose the preset stations.
__________________
Tony & Ruth........... FMCA#F416727
Newmar Dutch Star 4320, Spartan MM Chassis, Cat C9, 2018 Jeep Wrangler Unlimited, Blue Ox Aventa LX, and AF1. TST 507 TPMS
TonyDi is offline   Reply With Quote
Old 04-17-2016, 09:03 PM   #5
Senior Member
 
slabman's Avatar
 
Ford Super Duty Owner
Join Date: Oct 2002
Location: Plano TX
Posts: 2,237
Tony, you can research my other posts, but the oem Discover batteries would only give me 1.5 hours of service time when dry camped. All batts load tested good, but after a short period, some/all? experienced a sudden drop off in voltage to well below 12.0 Can't live with that! Newmar evaluated them last summer and pronounced them fine..so much for others doing this kind of testing.

The new Lifelines will easily deliver over 18 hrs. Of service.

Now tell me about Newmar service techs....are you thinking I'd actually get someone on the phone who could adjust/recalibrate? I can't see that as an option at all....but sure wish it could be. Thanks.
__________________
Slabman
2014 Newmar Essex 4544
2007 Lexus LX470 Toad
slabman is offline   Reply With Quote
Old 04-18-2016, 07:23 AM   #6
Senior Member
 
Stealth01's Avatar


 
Newmar Owners Club
Join Date: Jun 2013
Location: MidWest
Posts: 967
Slabman,
Have you tried a Silverleaf "dry tank" calibration? Select "Features"; "Tank Calibration" and then select the specific tank. When the tank is empty select "calibrate".
__________________
Ken & Anita 2011 Newmar Essex,4522,Cummins 500 ISM,2013 CRV,RVI2 Brake with TPMS **Our Travel WebSite**
<a href=https://i1129.photobucket.com/albums/m512/kengallagher/copper_a_zps0e12153d.jpg target=_blank>https://i1129.photobucket.com/albums...ps0e12153d.jpg</a>
Stealth01 is offline   Reply With Quote
Old 04-18-2016, 09:00 AM   #7
Senior Member
 
slabman's Avatar
 
Ford Super Duty Owner
Join Date: Oct 2002
Location: Plano TX
Posts: 2,237
Yup! Sure did. It at least allowed me to get to the current situation, but this jumping from 80 to 100% instantly was what it did when I first took delivery. Seems like this may be some kind of default setting.
__________________

slabman is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Microwave Digital Display going, going, gone! Tagalong RV Systems & Appliances 13 03-19-2009 08:45 AM
Going...going...gone! Jackm MH-General Discussions & Problems 16 07-09-2008 08:11 AM
Where is Norm (Oregon Coyote) Tom and Patty Alpine Coach Owner's Forum 4 09-19-2007 03:50 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:48 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.