RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-10-2019, 10:05 AM   #1
Member
 
ktnhog's Avatar
 
Join Date: Nov 2002
Location: Ketchikan, AK
Posts: 85
New owner

Just upgraded to a Ď19 DS 4018 and the gray water indicator in the overhead isnít working, just showing empty. Far from the dealer now. Any ideas where I should look for a loose wire or something? Thanks
__________________

ktnhog is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-10-2019, 10:34 AM   #2
Senior Member
 
deaton's Avatar


 
Monaco Owners Club
Newmar Owners Club
Texas Boomers Club
Spartan Chassis
Join Date: Jan 2010
Location: New Braunfels, Texas
Posts: 1,146
New owner

I canít directly help with the problem, although I did own a 2017 DS 4018, but if you advise your present location, assume itís not Alaska, someone on the forum might direct you to closest good shop. I assume you are under warranty. Let Newmar fix it.

And congratulations on your new coach!
__________________

__________________
Dan & Linda
FMCA 399045 NKK 22240
2020 Dutch Star 4081 - Spartan K2 - On Order
2017 Dutch Star 4018 - Sold
deaton is offline   Reply With Quote
Old 11-10-2019, 10:56 AM   #3
Senior Member
 
MikeyG's Avatar
 
Monaco Owners Club
Join Date: Apr 2010
Location: Pleasanton, CA
Posts: 271
Had the same problem one our first trip.
Turn the "salesman switch" or house battery switch (the one with the red indicator light on it) under the passenger armrest off for 30 seconds or so, then turn it back on. That should reset the KIB panel. It will also reset the Xite radio if you ever have a poroblem with that.
That worked for me. Haven't had a problem since.
Good luck
__________________
Mike G
2019 Newmar Dutch Star 4018 - Freighliner
2006 Jeep Grand Cherokee or 1973 Toyota FJ40
MikeyG is offline   Reply With Quote
Old 11-10-2019, 10:57 AM   #4
Senior Member
 
Tizbad's Avatar
 
Join Date: Apr 2012
Location: Il
Posts: 260
This happened to us while at Newmar. Our tech told us to "treat" the gray tank with the same chemical that we use in the black tank. Many times sensors will come back to life due to cleaning the gray tank. He said that the brand of chemical makes no difference. Since then, we treat ours every other dump of the black tank.
He also told us to stop using antibacterial soaps, since we need the bacteria in our tanks to keep the sensors clean. ..... If you use Dawn dishwashing soap, only use blue.
......Hope this helps.
__________________
2016 Newmar Essex 4519
2015 AWD Ford Explorer
Tizbad is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW THOR OWNER THREAD -- Things every new Thor owner must know MEWright Palazzo Motorhomes 14 10-12-2018 01:46 PM
New Newmar owner questions from Owner's Manual TarheelGal Newmar Owner's Forum 14 07-05-2018 09:25 PM
New Owner of 2018 33.3 (well almost owner) mom2my2 Palazzo Motorhomes 5 06-05-2018 09:58 PM
Old NRV owner wanting to be a new NRV owner. hutchman National RV Owner's Forum 2 01-05-2013 07:18 PM
Be a TIFFIN owner or Newmar Owner??? VACMAN Tiffin Owner's Forum 23 11-02-2009 03:09 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×