RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-04-2019, 06:04 AM   #1
Senior Member
 
Newmar Owners Club
American Coach Owners Club
Join Date: Feb 2000
Location: Oxford, Conn & Davenport,Florida
Posts: 678
Newmar My Site Chassis Battery Not Charging

Have a 2017 Mt Aire......I am plugged up to 30 amps and house batteries are charging at 13.6v but the chassis batteries are not charging...
Silver Leaf shows them go thru the stages of Bulk,Absorbtion,and then Float......the Silver Leaf also shows them " Bridged"....which should be both charging......
But Chassis batteries not charging but actually down to 12.2v....
Any thoughts on what to check....C
__________________

__________________
2017 45 FT Newmar Mountain Aire Seville Freightliner..with a 2015 Granite Grand Cherokee
Limited....GO NOLES
2012 (Piglet)American Tradition Merlot-Spartan>>SOLD
chuckster52 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-04-2019, 06:30 AM   #2
Senior Member
 
Join Date: Nov 2018
Location: Beaver Dam, Wisconsin
Posts: 538
Your system probably has a house/chassis disconnect solenoid. Typically it would disconnect when the ignition switch is off. The intent is that you will not draw down your chassis batteries while camping. It would connect and charge when you are driving to charge the house batteries. I don't know if there is a switch to join the banks when the ignition is off.
__________________

__________________
Paul Bristol
Kodiak Cub 176RD
Nissan Pathfinder 2015
Persistent is offline   Reply With Quote
Old 06-04-2019, 07:05 AM   #3
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 13,317
Hi chuckster52,
Please do not believe Persistent's post. As a non Newmar owner he displays no knowledge of how a Newmar coach works.

Your chassis and coach batteries should be charging when connected to shore power. Newmar service can lead you through the checks. You will need a meter to do the checks. As a summary, you will need to check your BIM/Bird system.
1. Your chassis batteries will charge only when the house batteries are fully charged.
2. Take a reading across the house battery terminals. It should be 13.5+ V if charging when you connect the meter so as to be looking at 2 6 volt batteries in series.
3. Take a reading across the chassis battery (when connected either battery will do). It should be 13.5+ volts if charging.
4. If #3 is no joy then the solenoid connecting the batteries is not working.

It is usually located in the shore cord bay behind a black panel velcroed in place. Newmar customer service can help you on the exact location and maybe with pictures of what it looks like.
__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 06-04-2019, 08:19 AM   #4
Senior Member
 
ewlee's Avatar
 
Join Date: Nov 2015
Posts: 629
Had the same problem with my '17 LADP. The culprit was a bad charge bridge solenoid, located in the back of the shore power cord bay. There are two solenoids in the area. You could try tapping on the solenoid while the SilverLeaf shows them bridged. I was able to limp along for awhile by tapping on the solenoid. I could hear the solenoid click-in when I did.
__________________
Wayne, Cindy, & Golden Retriever Finn
2017 London Aire, 2014 CRV, Go Hokies
ewlee is offline   Reply With Quote
Old 06-05-2019, 05:18 AM   #5
Senior Member
 
Newmar Owners Club
American Coach Owners Club
Join Date: Feb 2000
Location: Oxford, Conn & Davenport,Florida
Posts: 678
Quote:
Originally Posted by ewlee View Post
Had the same problem with my '17 LADP. The culprit was a bad charge bridge solenoid, located in the back of the shore power cord bay. There are two solenoids in the area. You could try tapping on the solenoid while the SilverLeaf shows them bridged. I was able to limp along for awhile by tapping on the solenoid. I could hear the solenoid click-in when I did.
Thanks for the tip....wondered if there was a solenoid in the system
Chuck
__________________
2017 45 FT Newmar Mountain Aire Seville Freightliner..with a 2015 Granite Grand Cherokee
Limited....GO NOLES
2012 (Piglet)American Tradition Merlot-Spartan>>SOLD
chuckster52 is offline   Reply With Quote
Old 06-05-2019, 06:57 AM   #6
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 13,317
This is the solenoid I was referring to. Call Newmar CS and have them help you locate and diagnose it.
__________________

__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Reply

Tags
battery, charging, chassis, newmar



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Chassis Battery not charging dyates773 Vintage RV's 10 08-03-2013 04:34 PM
Chassis Battery Not Charging RickGyver Monaco Owner's Forum 16 08-07-2011 06:16 PM
Bounder: 2004 35E Power Converter/Charger not charging the chassis battery. AB7OH Fleetwood Owner's Forum 4 02-20-2011 10:02 PM
chassis battery not charging woodlash MH-General Discussions & Problems 4 04-23-2010 02:46 AM
F53 Chassis Battery not Charging on Shorepower Dave Phillips Ford Motorhome Chassis Forum 11 06-06-2008 08:25 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.