RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-17-2019, 04:57 PM   #1
Senior Member
 
Wesslvm's Avatar
 
Join Date: Mar 2014
Location: Arcadia, FL
Posts: 173
No charging power at 7 pin connector 2019 Ventana

Any suggestions? Is there a fuse somewhere? Lights are all good.
__________________

__________________
Retired USN, Submarines
2019 Newmar Ventana 4369
2017 Mazda MX-5 (toad)
Wesslvm is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-17-2019, 05:07 PM   #2
Senior Member
 
Mr_D's Avatar
 
Country Coach Owners Club
Winnebago Owners Club
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 35,449
Check the plug, I'm betting it's not wired on the MH. Our two DSDP's weren't and neither was the present Country Coach.
__________________

__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 CR-V
Mr_D is offline   Reply With Quote
Old 04-17-2019, 06:10 PM   #3
Member
 
Someday Came's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2017
Posts: 39
On my 2015 Ventana the fuses for the tow plug are in a black box forward just of the chassis batteries. The box has several connectors on it from multiple sides. Remove the cover & you will find a number of fuses and relays. Sorry don't have the coach near me so can't provide any photos.
__________________
2015 Newmar Ventana 4369 w Hydralift
2000 Road King
2013 Explorer
Someday Came is offline   Reply With Quote
Old 04-17-2019, 06:16 PM   #4
Senior Member
 
jim1521's Avatar
 
Join Date: Dec 2017
Posts: 128
Check that you are actually testing the right pin. I spent 2 days trying to get my TPMS booster hard-wired in to my 7-pin plug. Turns out I was trying to tap into the wrong pin (I had my wiring diagram reversed).
__________________
2016 Grand Design Reflection 313RLTS
2016 Ford F-350 Lariat 6.7L PowerStroke dually
jim1521 is offline   Reply With Quote
Old 04-17-2019, 06:59 PM   #5
Senior Member
 
cc8375's Avatar
 
Newmar Owners Club
Join Date: Dec 2002
Location: Pasadena, Md.
Posts: 1,091
12 V wire my have been run

On my canyon star the Hot wire stopped about 12 in. from the plug. I had to unravel the tape and splice it out to the plug. the feed end was left coiled up by the fuse box. Someone else had post this information here and sure enough the wire had been run but not connected.
__________________
CC..... Happy Rving!!
2013 Newmar - Canyon Star 3940
2012 Honda CR-V toad
cc8375 is offline   Reply With Quote
Old 04-17-2019, 07:36 PM   #6
Senior Member
 
Wesslvm's Avatar
 
Join Date: Mar 2014
Location: Arcadia, FL
Posts: 173
Really? Went through all this on our Canyon Star!
__________________
Retired USN, Submarines
2019 Newmar Ventana 4369
2017 Mazda MX-5 (toad)
Wesslvm is offline   Reply With Quote
Old 04-17-2019, 07:37 PM   #7
Senior Member
 
Wesslvm's Avatar
 
Join Date: Mar 2014
Location: Arcadia, FL
Posts: 173
Quote:
Originally Posted by cc8375 View Post
On my canyon star the Hot wire stopped about 12 in. from the plug. I had to unravel the tape and splice it out to the plug. the feed end was left coiled up by the fuse box. Someone else had post this information here and sure enough the wire had been run but not connected.
That was probably my post for our CS 3710!
__________________
Retired USN, Submarines
2019 Newmar Ventana 4369
2017 Mazda MX-5 (toad)
Wesslvm is offline   Reply With Quote
Old 04-18-2019, 05:37 AM   #8
Senior Member
 
C.Martin's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Posts: 2,407
I would check the chassis battery compartment fuse panel...

Fuse F38 Tow Ignition 30A and Relay R15 Tow Ignition...that is the box on my 2016.

If you have power there...and none at the plug, you'll have to chase the wire.
__________________
Charlie & Ronni
2016 Ventana 4037
C.Martin is online now   Reply With Quote
Old 04-18-2019, 07:06 AM   #9
Senior Member
 
Algoma's Avatar
 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 3,070
I am assuming you have a Freightliner chassis. In which case that 12v pin on the 7-way connector is only live when the engine is running.
__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is offline   Reply With Quote
Old 04-19-2019, 08:02 AM   #10
Senior Member
 
fsudelt's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2016
Location: Forest City, FL
Posts: 695
Quote:
Originally Posted by Algoma View Post
I am assuming you have a Freightliner chassis. In which case that 12v pin on the 7-way connector is only live when the engine is running.


Yep I just learned my lesson as we were testing without key turned & replaced fuse thinking it was bad. Luckily only a $9 mistake 🤣
__________________
Brian
2017 Dutch Star 4310 (bunks)
2018 Ford Explorer Platinum
Previous: 2010 Tiffin Allegro Red 38QBA
fsudelt is offline   Reply With Quote
Old 04-20-2019, 09:07 AM   #11
Senior Member
 
Wesslvm's Avatar
 
Join Date: Mar 2014
Location: Arcadia, FL
Posts: 173
Quote:
Originally Posted by Algoma View Post
I am assuming you have a Freightliner chassis. In which case that 12v pin on the 7-way connector is only live when the engine is running.
Spartan, and thanks. I sent through this on our Canyon Star which was not connected at either end.

We are stationary for the weekend so I'll do some troubleshooting today.
__________________
Retired USN, Submarines
2019 Newmar Ventana 4369
2017 Mazda MX-5 (toad)
Wesslvm is offline   Reply With Quote
Old 04-20-2019, 09:08 AM   #12
Senior Member
 
Wesslvm's Avatar
 
Join Date: Mar 2014
Location: Arcadia, FL
Posts: 173
Quote:
Originally Posted by C.Martin View Post
I would check the chassis battery compartment fuse panel...

Fuse F38 Tow Ignition 30A and Relay R15 Tow Ignition...that is the box on my 2016.

If you have power there...and none at the plug, you'll have to chase the wire.
I'll have to check my Spartan chassis info CD.
__________________
Retired USN, Submarines
2019 Newmar Ventana 4369
2017 Mazda MX-5 (toad)
Wesslvm is offline   Reply With Quote
Old 04-20-2019, 04:21 PM   #13
Senior Member
 
Wesslvm's Avatar
 
Join Date: Mar 2014
Location: Arcadia, FL
Posts: 173
All fixed. Found heavily corroded 6 pin socket wires at toad. Bought parts at Walmart.
__________________

__________________
Retired USN, Submarines
2019 Newmar Ventana 4369
2017 Mazda MX-5 (toad)
Wesslvm is offline   Reply With Quote
Reply

Tags
charging, power, vent, ventana



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
7 Pin Hitch Connector Charging Line volvik Toads and Motorhome Related Towing 26 05-03-2017 07:40 PM
Bounder: Charging Dinghy Battery from 7-pin RV Connector pdestefano Fleetwood Owner's Forum 5 02-26-2017 01:37 PM
7-pin connector question-left turn/stop pin wagonmaster2 Freightliner Motorhome Chassis Forum 12 01-01-2012 05:00 PM
7-pin connector question-turn/stop pin wagonmaster2 Winnebago Industries Owner's Forum 25 12-31-2011 07:27 PM
Help-Need pin-out for Scottsdale 6 pin trailer connector park_ridge_dave Newmar Owner's Forum 2 09-07-2009 06:40 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.