RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-20-2019, 02:16 PM   #1
Junior Member
 
mskier's Avatar
 
Join Date: Mar 2009
Location: Indio
Posts: 27
Oasis ac1 and ac2 not working

We have been stationary at our summer home for several months now. He have been successfully using the electric elements of the oasis for most of our hot water needs. Two days ago we woke up to cold floors and discovered that during the night the breaker on the power pole tripped. Reset the breaker and all seemed well until I check the inside breakers and both of the water heater breakers were tripped. They reset OK but now we have no electric elements. No green lights on the oasis or the inside control panel. The burner continues to work. Any thoughts or suggestions will be greatly appreciated.
THI
__________________

__________________
2017 Dutch Star 4002
mskier is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-20-2019, 02:31 PM   #2
Senior Member
 
Tranquil Jim's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Aug 2015
Location: Northwest Washington State or Western Montana, depending on the season.
Posts: 3,232
Quote:
Originally Posted by mskier View Post
We have been stationary at our summer home for several months now. He have been successfully using the electric elements of the oasis for most of our hot water needs. Two days ago we woke up to cold floors and discovered that during the night the breaker on the power pole tripped. Reset the breaker and all seemed well until I check the inside breakers and both of the water heater breakers were tripped. They reset OK but now we have no electric elements. No green lights on the oasis or the inside control panel. The burner continues to work. Any thoughts or suggestions will be greatly appreciated.
THI
I believe the element indicator lights only come on when heat is called for. Have you tried running the hot-water faucet for a bit to see if (a) you get hot water and (b) the indicator lights come on?

TJ
__________________

__________________
Jim (W7DHC), Diane & Mini Schnauzers, Lizzy & Ellie
2018 Mountain Aire 4047 + 2014 Honda CR-V "toad" w/AF1
Tranquil Jim is offline   Reply With Quote
Old 09-20-2019, 06:19 PM   #3
Member
 
RandDescape's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Jul 2018
Posts: 95
Oasis ac1 and ac2 not working

TJs advice is good - also turn off the burner while you are testing to make sure any demand for heat goes to the electric elements.

You will probably need to use up a gallon or two to ensure the temp in the Oasis drops enough to call for heat.

- Richard
__________________
Richard & Denise
2019 VTDP 4310 K2
2019 Expedition, Nighthawk & AF1
RandDescape is offline   Reply With Quote
Old 09-20-2019, 09:02 PM   #4
Member
 
Join Date: Jul 2018
Location: Cleveland, OH
Posts: 66
Check the electrical wire connections to the top of the Oasis. There were problems with poor wirenut connections causing wires to heat and melted insulation on a few coaches.
__________________
Bob & Jill
Cleveland, OH
2018 3343 New Aire
BPeas is offline   Reply With Quote
Reply

Tags
oasis



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC1 :: 2009 American Coach American Allegiance jimc79 iRV2 Owners Registry 0 02-16-2019 04:49 AM
Oasis Problem AC1 Shed Coral Newmar Owner's Forum 10 12-10-2018 08:13 PM
AC1 and AC2 Bushy Newmar Owner's Forum 20 10-07-2018 03:36 PM
AE Oasis Elite Entry Door Awning Not Working Mike R MH-General Discussions & Problems 5 08-08-2015 09:42 AM
HWH Jacks working, not working and working again? Bob&Pat Winnebago Industries Owner's Forum 6 06-08-2006 04:22 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×