RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-30-2017, 08:10 AM   #1
Member
 
Newmar Owners Club
Join Date: May 2015
Location: Mammoth Lakes, CA
Posts: 77
Oasis Pumps

We replaced one of the Oasis pumps last October, the one that provides heat to zone 1 heat. The zone 2 pump has now stopped working. I would hope that these pumps would last more than 2 years. Has anyone else been having this problem?
__________________

__________________
Joel, Janice and Jack
2015 Dutch Star 4018
2003 Toyota Tacoma 4x4 (flat towed)
jbrown000 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-30-2017, 09:33 AM   #2
JMH
Senior Member
 
Newmar Owners Club
Join Date: Mar 2016
Posts: 856
Yes same problem. Ours is 6 months old and zone 2 pump is out. Oasis tech said they are seeing a spike in pump failures.
__________________

JMH is offline   Reply With Quote
Old 01-30-2017, 10:10 AM   #3
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 277
Our Zone 1 pump quit a couple of weeks ago. Probably had less than 8 hours on it. Glad its not the pump for hot water.

When activated the pump turns slowly, making noise, then stops. I'm guessing that the impeller has failed but ITR says that its usually the internal circuit board.

~$290 for replacement pump. Hoping it can be repaired rather than replaced. Not planning to fix it till we get back home in March.
__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Old 01-30-2017, 12:01 PM   #4
Member
 
Newmar Owners Club
Join Date: May 2015
Location: Mammoth Lakes, CA
Posts: 77
When our zone 2 stopped producing heat I called ITR and they walked me through the diagnostics and determined it was the pump so I ordered another one. Before I put crawled out from the bay I whacked the pump and few times, and surprise it started to work. This lasted for about a week and has gone out again. Fortunately I just received the new pump.
__________________
Joel, Janice and Jack
2015 Dutch Star 4018
2003 Toyota Tacoma 4x4 (flat towed)
jbrown000 is offline   Reply With Quote
Old 01-31-2017, 08:39 AM   #5
Member
 
Newmar Owners Club
Join Date: May 2015
Location: Mammoth Lakes, CA
Posts: 77
A update to the Oasis pump issue. Yesterday we had the zone 2 pump replaced, but when we turned the pump on to test it, it was making a strange crackling noise. We called ITR and told them of the problem and asked if they would send a replacement pump. The tech asked if it was blowing hot air, which it was, so he said no they wouldn't send a replacement. He said there is a 90 day warranty. This is a vendor that Newmar make think about changing.
__________________
Joel, Janice and Jack
2015 Dutch Star 4018
2003 Toyota Tacoma 4x4 (flat towed)
jbrown000 is offline   Reply With Quote
Old 01-31-2017, 09:23 AM   #6
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 277
The pump used on our Oasis is a GRI-INT-G2103. (Gorman-Rupp)

I sent an email via their website hoping to get spare parts source and spec sheet.
__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Old 01-31-2017, 09:42 AM   #7
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 277
Reply from GRI ...

Quote:
Thank you for contacting Gorman-Rupp Industries. The pump model you have referenced was designed and manufactured exclusively for ITR ( International Thermal Research). We are unable to sell direct or provide any information regarding this pump. For technical information or to purchase this pump, please contact ITR at 604-278-1272(X109) .
__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Old 01-31-2017, 09:58 AM   #8
Senior Member
 
Join Date: Nov 2014
Posts: 2,193
Do you have a picture of the pump? Are these mounted inside the control box?
Canuck53 is online now   Reply With Quote
Old 01-31-2017, 10:25 AM   #9
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 277
The pumps are mounted in a separate cabinet from the main burner unit. There are 3 pumps: zone 1, zone 2, and hot water (summer loop?)

I think there may be another pump inside the main unit where the diesel burner is.

The zone 1 pump is the one at lower right in the photo. Zone 2 is above it and the other is hot water.

FWIW, the switch on top of the zone controller turns all three pumps on.
Attached Thumbnails
Click image for larger version

Name:	IMG_3991.jpg
Views:	164
Size:	244.1 KB
ID:	150551  
__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Old 01-31-2017, 10:40 AM   #10
Senior Member
 
Join Date: Nov 2014
Posts: 2,193
Thanks

I'm assuming these pumps are not variable speed which maybe the special part?
Canuck53 is online now   Reply With Quote
Old 01-31-2017, 11:00 AM   #11
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 277
Don't know the answer to that. ITR told me there is a circuit board inside that is a common cause of failure. It could be a speed controller. I didn't notice a change in pump speed but I was only running zone 1 with a bad pump when I was in there.

Quote:
I'm assuming these pumps are not variable speed which maybe the special part?
__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Old 01-31-2017, 01:31 PM   #12
Senior Member
 
Join Date: Nov 2014
Posts: 2,193
Here is the pump details.

GRI Integrated Brushless DC Magnetic Drive Pumps

It is likely between their 1 and 3 series pump with a 2 wire system which is variable speed. The variable speed is likely used to start up the pump slowly to avoid damage.

The pumps are not made by some fly by night company.

https://en.m.wikipedia.org/wiki/Gorman-Rupp_Company
Canuck53 is online now   Reply With Quote
Old 12-09-2017, 10:48 PM   #13
Junior Member
 
Newmar Owners Club
Join Date: Sep 2016
Location: Larkspur,CO
Posts: 5
Oasis Pumps

WE have a 2017 Dutchstar and at one year we are now replacing the 2nd pump. Oasis has been helpful and sent both pumps free of charge however the dealership has to install and concerned if this is going to be an ongoing issue. Anybody else had repeated pump failures?
KPHuber is offline   Reply With Quote
Old 01-06-2018, 06:34 PM   #14
Senior Member
 
judgebobk's Avatar
 
Join Date: Jun 2013
Posts: 715
Quote:
Originally Posted by KPHuber View Post
WE have a 2017 Dutchstar and at one year we are now replacing the 2nd pump. Oasis has been helpful and sent both pumps free of charge however the dealership has to install and concerned if this is going to be an ongoing issue. Anybody else had repeated pump failures?
2016 Dutch Star just replace the pump for heat zone 2 after replacing the heat exchanger. I'm looking to carry an extra pump with me.
__________________

judgebobk is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
REMCO Pumps discontinuing Lube Pumps gregd Toads and Motorhome Related Towing 6 07-21-2015 08:28 PM
Tire pressure air pumps DLane Newmar Owner's Forum 7 11-26-2008 08:36 AM
Mascerator Pumps Mikeso Winnebago Industries Owner's Forum 17 10-18-2007 06:44 PM
Max heat with HydroHot AND heat pumps? footdoc Newmar Owner's Forum 12 11-02-2006 06:58 PM
Stay away from FLOJET pumps Fla2RI Gear and Product Discussions 2 05-12-2005 02:47 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×