RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-29-2016, 06:49 AM   #1
Junior Member
 
Join Date: Aug 2016
Posts: 2
Question Oil leak issue

Early in the last couple of trips out, I've been having an issue with my rig losing power and the check engine light comes on. I am able to pull over, turn it off and then start it again and proceed. After a while, it seems to work itself out and doesn't happen again. We arrived at our destination yesterday to see our tow vehicle and the back of the rig covered in oil. Any suggestions of what I should be checking for first?
__________________

GeorgeA is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-29-2016, 07:02 AM   #2
Senior Member
 
camperkids's Avatar
 
Join Date: Aug 2011
Location: Bel Air, Maryland
Posts: 243
Need more information re; year, rigg, eng etc.
__________________

__________________
Jim/Lois 1999 Newmar Mountain Aire MACA3797 F53 - V10
Bel Air, Maryland 5 Star Tuning & Air Lift Bags
camperkids is offline   Reply With Quote
Old 08-29-2016, 11:52 AM   #3
Senior Member
 
Join Date: Apr 2003
Location: Rochester, MN, USA
Posts: 371
My first move would be to display the PID/MID codes from the dashboard Information display. Use the down arrow button to navigate down to the diagnostics menu and the right arrow button to display the codes. The codes can be interpreted from a number of online sources. Use the source appropriate for your engine.

Have a nice day - Darrel
__________________
2007 3912 KSDP w/350HP ISL Cummins
2003 Grand Cherokee toad w/M&G Brake
Darrel is offline   Reply With Quote
Old 08-29-2016, 12:05 PM   #4
Senior Member
 
dennis45's Avatar
 
Join Date: Jun 2012
Location: BC
Posts: 7,504
Quote:
Originally Posted by GeorgeA View Post
Early in the last couple of trips out, I've been having an issue with my rig losing power and the check engine light comes on. I am able to pull over, turn it off and then start it again and proceed. After a while, it seems to work itself out and doesn't happen again. We arrived at our destination yesterday to see our tow vehicle and the back of the rig covered in oil. Any suggestions of what I should be checking for first?


GeorgeA, we need more details. What breed of rig are we talking about?
__________________
2019 Unity LTV CB, pushed by a 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake
dennis45 is offline   Reply With Quote
Old 08-29-2016, 05:10 PM   #5
Junior Member
 
Join Date: Aug 2016
Posts: 2
Quote:
Originally Posted by camperkids View Post
Need more information re; year, rigg, eng etc.
Newmar 2002 Dutchstar, 33o cat motor.
GeorgeA is offline   Reply With Quote
Old 08-29-2016, 05:37 PM   #6
Senior Member
 
LongRanger's Avatar


 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2012
Location: Florida
Posts: 196
I had a 2004 DSDP 3810 with a 330 Cat. The oil pressure sensor on top, next to the valve cover had a o ring failure. Oil covered my toad. We originally replaced the valve cover gasket but the leak continued. The shop in Stockton CA found the problem. It is a cheap fix to replace the o ring. Good luck.


DickW
Blue Skies and Safe Travels
2014 DSDP 4018
2009 Honda Fit TOAD
__________________
Dick Williams
2014 Newmar Dutch Star - All Electric - 450 ISL
2018 Wrangler on Blue OX with Air Force 1
LongRanger is offline   Reply With Quote
Old 08-29-2016, 05:46 PM   #7
Senior Member
 
Old Scout's Avatar
 
Join Date: Nov 2005
Posts: 4,985
OK--lose of power, check engine light, oil on towed--sounds like more than an o-ring issue....believe the check engine light gives you the best course of action...hopefully the check engine light thru a code that has been captured in the engine ECM....
__________________
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 08-29-2016, 07:57 PM   #8
Senior Member
 
dennis45's Avatar
 
Join Date: Jun 2012
Location: BC
Posts: 7,504
Quote:
Originally Posted by GeorgeA View Post
Newmar 2002 Dutchstar, 33o cat motor.
Okay, have you looked in the engine compartment for signs of oil? Could be carryover from the crankcase breather, are you sure you did not overfill?
Could also be a leaking oil pressure sender. Give the engine a good bath and see if you can find the source of the leak.
Check Engine light. Do you wait until the WAIT Light goes out before you start the engine? Starting before this light clears can cause your CEL.
Find the source of the leak and go from there.
__________________

__________________
2019 Unity LTV CB, pushed by a 2013 Honda CRV, BlueOx Baseplate, Aventa Bar & Patriot Brake
dennis45 is offline   Reply With Quote
Reply

Tags
leak



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil leak .. Oil pan.. Speedjester Cummins Engines 10 03-22-2018 06:12 AM
Slight oil leak...Issue or non Issue? Speedjester Cummins Engines 6 09-03-2015 07:17 AM
Low oil pressure | erratic oil pressure | inconsistant oil pressure GlennLever Cummins Engines 45 08-28-2014 08:24 AM
leak, leak, leak, hit the road Class A Motorhome Discussions 6 12-10-2012 04:03 AM
Southwind 36D Issue after issue after issue.... fixn2gocamp Fleetwood Owner's Forum 4 10-21-2009 07:05 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.