RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-28-2011, 08:08 AM   #1
Senior Member
 
Doc Mark's Avatar
 
Newmar Owners Club
Join Date: Sep 2005
Location: Orange Park, FL
Posts: 813
Onan 10K Won't Stay Running

Got a jump on the monthly maint. stuff today and fired up the genset for its exercise. Shore power turned off, genset under load. And lo & behold the genny quits after about a minute.

Hmmm - this is not good. Fire it off again, let it idle for a minute or 2, turn on load, and it dies again.

Anybody have any ideas about where I should start looking for the problem?

Mark
__________________

__________________
Mark & Sheila Heilman & The 3 Fur-Ball Princesses - Nikko, Mai-Thai & Andy
'07 MADP 4523, 2012 GMC Terrain SLT 2 wd
Blue Ox Alladin Tow Bar, M&G Engineering Dinghy Braking System

Doc Mark is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-28-2011, 09:30 AM   #2
Registered User
 
Join Date: Mar 2011
Posts: 1,943
When it quits, look at the dash gen start button and see how many times it blinks. It's a code that tells you what could be wrong. Better hope it didn't throw the belts on the back. You should have a manual on board. If not go to Cummins Onan site and download one.


Here's for a 12.5KW but I believe they are the same. I have the parts manual too but it is 4.4MB and can't upload it to the forum.
Attached Files
File Type: pdf 682105772_Onan_DKD_Service_Manual.pdf (2.16 MB, 51 views)
__________________

Perry White is offline   Reply With Quote
Old 09-28-2011, 04:39 PM   #3
Senior Member
 
GaryKD's Avatar
 
Newmar Owners Club
Join Date: Jul 2006
Location: Wellington, Florida
Posts: 13,222
Hi Doc Mark,
This happens to me every once and a while. By the third start, the generator runs as advertised. It happens rarely, but does happen. At this time it is not a large enough irritant for me to investigate any further.

It sounds like you are doing everything correctly. Consider putting a small load on the generator and then gradually working up to the normal load.
__________________
Gary
2005 Newmar KSDP 3910 + GMC ENVOY XUV 37K lbs Moving Down The Road
The Avatar Is Many Times Around The USA
Nobody Knows Your Coach Like Somebody Who Owns One Just Like Yours
GaryKD is offline   Reply With Quote
Old 09-28-2011, 06:50 PM   #4
Senior Member
 
Doc Mark's Avatar
 
Newmar Owners Club
Join Date: Sep 2005
Location: Orange Park, FL
Posts: 813
I went outside & removed the service panel after I posted and found the oil filter nearly completely unscrewed, with a nice pool of oil on the ground.

Ordered a new filter and when it arrives I will see if it was low oil pressure that kept switching it off. Didn't see any fault codes but didn't know to look for them so may have missed it.

Mark
__________________
Mark & Sheila Heilman & The 3 Fur-Ball Princesses - Nikko, Mai-Thai & Andy
'07 MADP 4523, 2012 GMC Terrain SLT 2 wd
Blue Ox Alladin Tow Bar, M&G Engineering Dinghy Braking System

Doc Mark is offline   Reply With Quote
Old 09-30-2011, 09:31 AM   #5
Senior Member
 
Doc Mark's Avatar
 
Newmar Owners Club
Join Date: Sep 2005
Location: Orange Park, FL
Posts: 813
OK - filter came in - Kubota filter - and I installed it and proceeded to fill the oil. 4 Quarts later (not filling the filter) and it registered on the dipstick. Sigh . .

Just because gen set was serviced in April, doesn't mean . . . . . Well, you get the idea. Preventive Maint. includes checking the oil level, dummy!

Mark
__________________
Mark & Sheila Heilman & The 3 Fur-Ball Princesses - Nikko, Mai-Thai & Andy
'07 MADP 4523, 2012 GMC Terrain SLT 2 wd
Blue Ox Alladin Tow Bar, M&G Engineering Dinghy Braking System

Doc Mark is offline   Reply With Quote
Reply

Tags
onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
onan generator wont stay running rdm Fleetwood Owner's Forum 5 05-03-2011 09:35 AM
Running the generator while on shore power? Magumba Winnebago Industries Owner's Forum 9 01-14-2010 08:03 PM
Diesel Generator won't stay running Mike-N-Sally Winnebago Industries Owner's Forum 8 01-01-2010 12:08 AM
TV/DVD problems when running Onan RobinGio Technology: Internet, TV, Satellite, Cell Phones, etc. 1 07-28-2008 01:43 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:32 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.