Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-01-2015, 08:14 PM   #1
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 258
Onan Generator Smoke

We have an Onan 8000 generator with 28hrs.. When I started it today, it ran very rough, smoked (blue) a lot, and then shut down after a few minutes.

The indicator on the cabinet was showing flashes in groups of 3 which decodes to "service required"

I restarted it a few minutes later and put it under full load. It was still smoking but not as bad. It seemed to be running normally. I then shut it down for the day.

Does anyone have an idea of what might be going on?

We're planning some dry camping at the beach next week and need a reliable generator.
__________________

__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-01-2015, 09:52 PM   #2
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,027
The smoke is an indication that the fuel/air mix is not correct. This could be caused by a dirty air filter or blocked air intake, clogged injector, etc. Not something to let go, the engine could be damaged by running that way. I'd take it to a Cummins/Onan service center and have it checked.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Old 01-01-2015, 10:03 PM   #3
Senior Member
 
SteveLevin's Avatar
 
Join Date: Feb 2010
Location: Sunnyvale, CA
Posts: 1,195
I have a silly question...how cold it is where you are? And when is the last time you fueled up? I had a similar issue that was traceable to summer diesel and very cold temps...once we got to warm temps the issue went away.

Steve
__________________
The Green Machine -- 2000 Mountain High Coachworks Summit (Spartan chassis / Cummins ISC)
...and F-Troop: Fearghus, Fiona, and Frankie (Cairn Terriers)
SteveLevin is offline   Reply With Quote
Old 01-01-2015, 10:16 PM   #4
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 258
Quote:
how cold it is where you are? And when is the last time you fueled up?
Last fuel (~60gal @$2.79) was a couple of days ago. Temps have been in the teens overnight.
__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Old 01-01-2015, 10:42 PM   #5
KIX
Senior Member
 
KIX's Avatar


 
Join Date: Dec 2006
Location: St. Augustine, FL
Posts: 3,579
If it was me I would renew the air filter. Then change the fuel filter next.
__________________
KIX
'02 Ultimate Advantage 40J Spartan MM - Cummins ISC
2013 Jeep Rubicon JK Unlimited
KIX is offline   Reply With Quote
Old 01-01-2015, 11:04 PM   #6
Senior Member
 
PDR John's Avatar
 
Join Date: May 2012
Posts: 3,623
After changing filters put some hours on it. Like 12 under 1/2 load.


Ours ran a little rough and smoked slightly at first. I let it run (under load) overnight. Turned the block heater on, as well as the Oasis electric elements. Anything that would put a load on.

Now I stopped using the dash air and run the genny with roof airs. Just because I wasn't running it enough. They need to be used or they go bad.
__________________
2013 DSDP 4347, all electric, 450 H.P. ISL
Air & hydraulic leveling
14 Jeep Grand Cherokee Overland toad
[SIGPIC][/SIGPIC]
PDR John is offline   Reply With Quote
Old 01-02-2015, 06:37 AM   #7
Senior Member
 
SteveLevin's Avatar
 
Join Date: Feb 2010
Location: Sunnyvale, CA
Posts: 1,195
I had a mechanic swear by the BG44 additive... which isn't cheap. But I decided what the heck... I'll try it, and ran through a tank of it -- can't tell any difference in my engine, but my generator, I have noticed that the soot level and a very light trace of dark smoke seems gone now over this past summer.

I'm still kinda tracking it to figure out if it was just a mental placebo effect on my part... but I've actually started to convince myself it made a difference.

Steve
__________________
The Green Machine -- 2000 Mountain High Coachworks Summit (Spartan chassis / Cummins ISC)
...and F-Troop: Fearghus, Fiona, and Frankie (Cairn Terriers)
SteveLevin is offline   Reply With Quote
Old 01-02-2015, 06:41 AM   #8
Senior Member
 
homeless's Avatar
 
Join Date: Mar 2012
Location: http://binged.it/1KdDqKO
Posts: 2,310
Blog Entries: 1
I have had mine lop when starting after traveling in the rain. When it happens I go back there and throttle the carb just like an old ford engine until it clears it self
homeless is offline   Reply With Quote
Old 01-02-2015, 06:55 AM   #9
Member
 
Join Date: Sep 2013
Posts: 55
When was the fuel filter changed on your Onan 8000? Fuel filter for sure. Not much of a job. Good luck.
__________________
peterdube is offline   Reply With Quote
Old 01-02-2015, 08:13 AM   #10
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 258
Quote:
When was the fuel filter changed on your Onan 8000?
I changed the oil, oil filter, and air filter at 25hrs following the schedule in the manual. Also serviced the spark arrestor. The fuel filter isn't scheduled for replacement until 500 hrs so I didn't touch it.

I'll replace it today. Its the last thing I can do myself before calling service.
__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Old 01-02-2015, 04:33 PM   #11
Senior Member
 
kamakalama's Avatar
 
Join Date: Sep 2012
Posts: 258
I was heading over to the dealer today to get a fuel filter. I decided to start the generator to see how it was feeling. It started and ran perfectly even under full load. No smoke. The only difference today is that I made sure there was no load when I started up. I'm going to try it a few more times over the weekend before tearing into the filter.

Wondering if the AGS system delays load when it starts the generator?
__________________
Jeff, NE7SS, Olympia, WA.
2014 Ventana 4037/Honda CRV
kamakalama is offline   Reply With Quote
Old 01-02-2015, 05:22 PM   #12
Senior Member
 
Bfmorgan's Avatar
 
Monaco Owners Club
Join Date: Mar 2013
Location: Northern United States
Posts: 266
Transfer switches have a built-in delay for the generator. If there is no delay, then you may have a transfer switch issue.
__________________
Brad & Bonnie
2007 Monaco Dynasty 42 Diamond
Bfmorgan is offline   Reply With Quote
Old 01-02-2015, 06:02 PM   #13
Senior Member
 
BFlinn181's Avatar
 
Gulf Streamers Club
Join Date: Jan 2012
Location: Cincinnati
Posts: 16,027
Your transfer switch should delay connecting to generator to give it time to get to speed. I don't want a load on the transfer switch contacts so I always let the gennie start, settle down and the transfer switch close, then turn on A/C or other loads.
__________________

__________________

Bob & Donna
'98 Gulf Stream Sun Voyager DP being pushed by a '00 Beetle TDI
BFlinn181 is offline   Reply With Quote
Reply

Tags
generator, onan



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Onan starting by itself for no reason N6CUS Class A Motorhome Discussions 11 11-02-2014 07:42 AM
Onan code 33 ldfeat Country Coach Owners Forum 7 10-11-2014 10:37 AM
Onan 5500 filter questions Bilgerat RV Systems & Appliances 3 10-07-2014 12:00 PM
Would you replace a 23 yr old Onan? Pexring RV Systems & Appliances 8 08-13-2014 06:14 AM
onan Emerald Plus 4000 tom41 RV Systems & Appliances 4 09-04-2013 02:20 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 08:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.