RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-14-2018, 04:19 PM   #1
Member
 
BodieJames's Avatar
 
Spartan Chassis
Join Date: Nov 2015
Location: Shorewood, IL
Posts: 85
Relay clicking in 1/2 bath

We came back from being out all day and I am hearing a clicking sound in the electrical panel in the 1/2 bath. It is on the D/C side. I took out each fuse one by one to see if the clicking noise would stop. It did not. Next I shut off the salesman switch - battery disconnect next to front door...waited 5 mins turned back on. Still have clicking going on. A/C’ all running, fridge running, lights on.

2018 DS 4369. Any ideas would be appreciated. I’ll call Newmar CS in the AM.

Thanks,
__________________

__________________
Jim & Kathy
2018 Dutch Star 4369 K2
Toad- 2014 Honda CRV
BodieJames is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-14-2018, 04:41 PM   #2
Senior Member
 
Winepress's Avatar


 
Join Date: Jul 2012
Posts: 1,024
What amp service are you on?

The load management system will shed loads and when it does you hear a relay cycling noise coming from the breaker box. You will see this happen more on 30amp service, but it can happen on 50 amp if one leg has too much load.
__________________

__________________
2018 Dutch Star 4369
Everything was working fine, until it wasn't.
Winepress is offline   Reply With Quote
Old 06-14-2018, 05:03 PM   #3
Member
 
BodieJames's Avatar
 
Spartan Chassis
Join Date: Nov 2015
Location: Shorewood, IL
Posts: 85
I’m connected to 50 amp service. Monitor shows 50 amps.
__________________
Jim & Kathy
2018 Dutch Star 4369 K2
Toad- 2014 Honda CRV
BodieJames is offline   Reply With Quote
Old 06-14-2018, 05:10 PM   #4
Member
 
BodieJames's Avatar
 
Spartan Chassis
Join Date: Nov 2015
Location: Shorewood, IL
Posts: 85
Unhooked from shore power and started generator. Still clicking away.
__________________
Jim & Kathy
2018 Dutch Star 4369 K2
Toad- 2014 Honda CRV
BodieJames is offline   Reply With Quote
Old 06-14-2018, 07:00 PM   #5
Junior Member
 
Join Date: Nov 2016
Posts: 2
Do you have floor heat? Check if they are on!
GTAmerica is offline   Reply With Quote
Old 06-14-2018, 07:09 PM   #6
Senior Member
 
alan1's Avatar
 
Monaco Owners Club
Newmar Owners Club
Join Date: Aug 2000
Location: little rock, ar
Posts: 308
x2 One of my floor heat zones has its relay behind the panel in the half bath.
__________________
2016 Newmar King Aire 4553
2017 Ford Explorer toad
alan1 is offline   Reply With Quote
Old 06-14-2018, 07:28 PM   #7
Senior Member
 
Winepress's Avatar


 
Join Date: Jul 2012
Posts: 1,024
Check your PCM display and see if it shows any load sheds.
__________________
2018 Dutch Star 4369
Everything was working fine, until it wasn't.
Winepress is offline   Reply With Quote
Old 06-15-2018, 05:30 AM   #8
Member
 
BodieJames's Avatar
 
Spartan Chassis
Join Date: Nov 2015
Location: Shorewood, IL
Posts: 85
Found it. Bad fuse buss for the WiFi ranger. My DW went to watch TV and the televator only came up half way. Electrical issue? 1+1=2 so I started unwiring every thing in that panel. When I got to the WiFi ranger fuse buss and pulled the wires the clicking noise stopped and the televator started working correctly.

Thanks for the help and suggestions I really appreciate it.
__________________

__________________
Jim & Kathy
2018 Dutch Star 4369 K2
Toad- 2014 Honda CRV
BodieJames is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Clicking relay Phoelix Vintage RV's 7 12-19-2017 07:18 PM
Clicking, like a relay MIDMONDN Winnebago Industries Owner's Forum 9 06-06-2017 08:26 PM
Coachman Mirada Bath and half vs Fleetwood Bounder Bath and Half retiring1day Class A Motorhome Discussions 18 09-03-2015 08:06 PM
Clicking relay ALAG321 Gulf Stream Owner's Forum 3 11-21-2010 06:48 AM
Relay clicking sound from rear of MH movin-on Winnebago Industries Owner's Forum 4 08-04-2008 02:46 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.