Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 11-23-2017, 10:30 AM   #1
Junior Member
 
Join Date: Oct 2017
Posts: 5
Toilet won't fill

I have a 2015 Dutchstar 4369. The back toilet won’t fill with water. When I push the button to add water or flush I hear a faint click but no water. It will flush when I put water in it. Second bath works fine as do all faucets and shower. Thoughts?
__________________

__________________
KLAFFEY is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 11-23-2017, 03:33 PM   #2
Senior Member
 
Join Date: Mar 2014
Posts: 936
Does the 1/2 bath toilet flush? If it doesn't then it sounds like the black tank is either full or something is telling the Dometic controls that it is full? What color is the tank light indicator on the flush panel?
__________________

__________________
Gary 2017 Dutch Star 4369 Spartan
HWH Active Air Centramatic wheel balancers
Box Elder, SD and the road
ghaynes754 is offline   Reply With Quote
Old 11-23-2017, 05:39 PM   #3
Senior Member
 
HavingABlast's Avatar


 
Join Date: Mar 2015
Posts: 2,019
Are you either on shore water or have your water pump turned on?
__________________
HavingABlast is online now   Reply With Quote
Old 11-23-2017, 05:57 PM   #4
Junior Member
 
Join Date: Oct 2017
Posts: 5
Half bath works fine. On tank and black water is close to empty. I removed the panel next to the toilet and the Oasis system and fan is there. In that compartment is a black box that clicks when you push the flush or fill button. Has to be some type of controller. Has a data type cable going into it and when I pull off the flush electric controller cover it has the same data cable connection. No reset anywhere.
__________________
KLAFFEY is offline   Reply With Quote
Old 11-23-2017, 06:18 PM   #5
Member
 
Join Date: Apr 2015
Posts: 41
There is a electric solenoid valve located in the toilet base that actuates open and closed. Had the same problem in our 2014 Essex. More than likely the valve is stuck and needs replacing. I carry a extra vale now. Replacing valve is simple. You have to remove the bolts holding base to the floor tilt base over somewhat and you easily see the solenoid valve.
__________________
tmh1953 is offline   Reply With Quote
Old 11-23-2017, 06:25 PM   #6
Member
 
Join Date: Apr 2015
Posts: 41
Your valve is more than likely stuck closed. When our valve malfunctioned it failed open and the bowel wouldn't quit filling with water a very bad situation. The black box sends a signal to solenoid valve the valve opens for a predetermined time allowing bowel to fill with water then closes.
__________________
tmh1953 is offline   Reply With Quote
Old 11-25-2017, 03:40 PM   #7
Senior Member
 
Join Date: Jan 2015
Location: Arizona
Posts: 1,030
Blog Entries: 6
If it is a valve sticking a temporary fix is put some Vaseline on the blade and seal. Each application will last a week or more. This will help most toilet seals.
__________________
'04MA DP, Blue Ox, AFO, 900watts of Solar, Safe-T-Plus, SilverLeaf, Lifetime: SKP & Days End
ByeTheWay is offline   Reply With Quote
Old 11-26-2017, 07:09 PM   #8
Junior Member
 
Join Date: Aug 2015
Location: Bluffton, SC
Posts: 2
Replace the valve in the back of the unit. It can be awkward leaning over the bowl but it is doable. You can order a valve from Newmar or Dometic,
__________________
Xintec is offline   Reply With Quote
Old 11-26-2017, 07:43 PM   #9
Junior Member
 
Join Date: Oct 2017
Posts: 5
Thanks we are back from our trip and will get the valve and one as a spare and make the replacement. I appreciate the help!
__________________
KLAFFEY is offline   Reply With Quote
Old 11-26-2017, 09:27 PM   #10
cwg
Senior Member
 
Join Date: Sep 2004
Posts: 729
I had the same problem. The rear toilet would open to flush but not refill the bowl. I dreaded what all I perceived the problem would entail but found it a simple answer. Apparently one of us had held the flush button down too long. The programming changed to the water saver mode. The solution was this: hold the flush button down for five seconds... when the light flashes let go and it reverts back to the normal water fill.

This may not be your solution but if you have electric switched toilets for operation it worked for me last week. Good luck
__________________

__________________
cwg is offline   Reply With Quote
Reply

Tags
toilet, water



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Toilet won't fill or flush MTFOSTER Newmar Owner's Forum 10 10-15-2016 08:46 PM
Pro-Fill Battery fill system is awful right out the gate Civdiv99 Gear and Product Discussions 13 09-23-2016 05:38 PM
Sealand 510 toilet won't fill with water Basampso Winnebago Industries Owner's Forum 11 07-07-2015 08:36 PM
Question for Pro-Fill/Qwik-Fill users buck454 Class A Motorhome Discussions 7 05-30-2013 06:28 PM
Toilet won't fill bowl? Wannabe Monaco Owner's Forum 6 01-29-2012 01:22 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:15 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.