Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 09-21-2017, 04:52 PM   #1
Member
 
Join Date: Jan 2017
Posts: 32
Transfer Switch dropping out on 2016 Canyon Star

Transfer switch problem on my 2016 Newmar Canyon Star 3710. When I am connected to 120 volt shore power, running minimal load, my Canyon Star recently started experiencing transfer switch drop outs, shutting shore power off, only to kick back in a few minutes later. This repeats at intermittent time intervals. So far no problem when connected to 50 Amp 240 volt shore power, but last week the transfer switch dropped out when we were on our 7000 watt generator power. Generator starts and runs normally, but the transfer switch doesn'the kick in to connect the coach to generator power. Has anyone experienced this? I will be troubleshooting the problem. We have only had this coach a few weeks, and I am assuminging the transfer switch is the box where my shore power cord connects. I have not connected to 50 amp service since the generator problem began, so I don't know if that will be a problem too. Maybe another thread on this, but I haven't found it yet.
__________________

__________________
Brews Cruise is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 09-21-2017, 05:03 PM   #2
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: St. Lucie West, FL
Posts: 4,922
Quote:
Originally Posted by Brews Cruise View Post
Transfer switch problem on my 2016 Newmar Canyon Star 3710. When I am connected to 120 volt shore power, running minimal load, my Canyon Star recently started experiencing transfer switch drop outs, shutting shore power off, only to kick back in a few minutes later. This repeats at intermittent time intervals. So far no problem when connected to 50 Amp 240 volt shore power, but last week the transfer switch dropped out when we were on our 7000 watt generator power. Generator starts and runs normally, but the transfer switch doesn'the kick in to connect the coach to generator power. Has anyone experienced this? I will be troubleshooting the problem. We have only had this coach a few weeks, and I am assuminging the transfer switch is the box where my shore power cord connects. I have not connected to 50 amp service since the generator problem began, so I don't know if that will be a problem too. Maybe another thread on this, but I haven't found it yet.
Yes, it's the box that the power cord goes to.

Tell us the brand and model of transfer switch. Some have protection circuits and drop power when a problem is detected. Comes back online after a 2 minute delay. Some have LEDs that can be used to define a problem.
__________________

__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is online now   Reply With Quote
Old 09-21-2017, 05:24 PM   #3
Member
 
Join Date: Jan 2017
Posts: 32
I will check the model number and get back to you. When on 120 shore power the delay is about 2 minutes. This did not occur the first few weeks we had the coach, but now it happens every time when on the adapter to the 120 power. Generator did great through several days ( not consecutive) of dry camping, but now won't connect at all.
__________________
Brews Cruise is offline   Reply With Quote
Old 09-21-2017, 05:36 PM   #4
Member
 
Join Date: Jan 2017
Posts: 32
The transfer switch is Progressive Dynamics Model PD52 Automatic Transfer Relay Switch. The 50 Amp power cord goes through a Progressive E Industries Electrical Management System w/Smart Surgeon Protection Model EMS-HW50C before going to the transfer switch.
__________________
Brews Cruise is offline   Reply With Quote
Old 09-21-2017, 05:48 PM   #5
Senior Member
 
Stuart W's Avatar


 
Join Date: Nov 2015
Posts: 1,318
[ATTACH] looks like this opened?
Attached Thumbnails
Click image for larger version

Name:	IMG_5039.JPG
Views:	47
Size:	400.9 KB
ID:	177369  
__________________
2018 Dutch Star 4369 on order😊
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 09-21-2017, 05:52 PM   #6
Senior Member
 
Stuart W's Avatar


 
Join Date: Nov 2015
Posts: 1,318
Transfer Switch dropping out on 2016 Canyon Star

Quote:
Originally Posted by Brews Cruise View Post
Transfer switch problem on my 2016 Newmar Canyon Star 3710. When I am connected to 120 volt shore power, running minimal load, my Canyon Star recently started experiencing transfer switch drop outs, shutting shore power off, only to kick back in a few minutes later. This repeats at intermittent time intervals. So far no problem when connected to 50 Amp 240 volt shore power, but last week the transfer switch dropped out when we were on our 7000 watt generator power. Generator starts and runs normally, but the transfer switch doesn'the kick in to connect the coach to generator power. Has anyone experienced this? I will be troubleshooting the problem. We have only had this coach a few weeks, and I am assuminging the transfer switch is the box where my shore power cord connects. I have not connected to 50 amp service since the generator problem began, so I don't know if that will be a problem too. Maybe another thread on this, but I haven't found it yet.


Is it the same 120 outlet your plugged into?[ATTACH]this picture is stock on 2016 3710[ATTACH]
Attached Thumbnails
Click image for larger version

Name:	IMG_5018.JPG
Views:	41
Size:	377.1 KB
ID:	177371   Click image for larger version

Name:	IMG_2482.JPG
Views:	42
Size:	1.64 MB
ID:	177372  

__________________
2018 Dutch Star 4369 on order😊
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 09-21-2017, 06:06 PM   #7
Senior Member
 
Stuart W's Avatar


 
Join Date: Nov 2015
Posts: 1,318
Look at the codes on the lid of the surge protector. You should have a display. In this picture you can see that I installed mine to protect both gen and shore power

Sounds like yours is on the actual shore cord[ATTACH]
Attached Thumbnails
Click image for larger version

Name:	IMG_2483.JPG
Views:	45
Size:	1.06 MB
ID:	177374  
__________________
2018 Dutch Star 4369 on order😊
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 09-21-2017, 06:09 PM   #8
Senior Member
 
Stuart W's Avatar


 
Join Date: Nov 2015
Posts: 1,318
Also make sure it's disconnected from all power and check for loose wire lugs, they have been known to loosen up causing a bad connection
__________________
2018 Dutch Star 4369 on order😊
2017 Jeep Wrangler Smoky Mountain
2016 Canyon Star 3710 SOLD
Stuart W is offline   Reply With Quote
Old 09-21-2017, 06:49 PM   #9
Senior Member
 
bruceisla's Avatar
 
Join Date: Oct 2012
Location: St. Lucie West, FL
Posts: 4,922
Quote:
Originally Posted by Brews Cruise View Post
The transfer switch is Progressive Dynamics Model PD52 Automatic Transfer Relay Switch. The 50 Amp power cord goes through a Progressive E Industries Electrical Management System w/Smart Surgeon Protection Model EMS-HW50C before going to the transfer switch.

Are there any LEDs on the front cover of the Transfer Switch?

Do you have any error codes on the EMS-HW50C?

The genset issue and the shore power issue may not be directly related. Check the genset breaker (next to power switch on the genset upper panel), Turn it fully off then back on. Remove the cover from the Transfer Switch ... green LED on board is on if gen power is reaching Transfer Switch.

As for shore power, if you have an error code on the HW50C, the HW50C may be dropping the power which causes the Transfer Switch to also drop out. My first thought on 120VAC shore power is that you have an undervoltage ... maybe an undersized extension cord ????
__________________
2005 Newmar Essex 4502, 2013 Caddy SRX
1997 HR Endeavor 37, CAT, 1996 Geo Tracker
bruceisla is online now   Reply With Quote
Old 09-21-2017, 07:12 PM   #10
Senior Member
 
siggyd's Avatar
 
Freightliner Owners Club
Join Date: Aug 2005
Location: Chicagoland
Posts: 650
Had the same problem when we lost the Neutral at the transformer in the RV Park , L1 went high and L2 went low. Shut down at 132 volt or 108 volt AC. then it re-connects after a minute or so.
Siggy
__________________
Siggy & Ursula.
2011 Newmar DSDP 4020 (no Tag, no DEF, 07 emission),
FTL XCR ,ISL 400,2015 Jeep Cherokee Limited, 4x4, V6, Active Drive II, BrakeBuddy
siggyd is offline   Reply With Quote
Old 09-21-2017, 07:21 PM   #11
Senior Member
 
Sweetbriar's Avatar
 
Thor Owners Club
Ford Super Duty Owner
Join Date: Jul 2011
Posts: 1,495
I'm not so sure the problem is the transfer switch and I would look closer at the EMS. The symptoms described of losing power and regaining after a few minutes is exactly what the EMS will do during a low or high voltage fault, open neutral or ground and a few other AC power problems. The reset time is 136 second. There should be a remote display somewhere in the coach that the EMS will display a code for the drop out reason. With one relay for shore and the other for generator it would be pretty rare for BOTH to fail as described. But if the EMS is wired in after the switch so it monitors both shore power AND the generator you have a common point for identical problems with both.
__________________
2006 Hurricane 31D built on a 2006 Ford F53
Sweetbriar is offline   Reply With Quote
Old 09-21-2017, 08:21 PM   #12
Member
 
Join Date: Jan 2017
Posts: 32
I haven't opened it yet. I'll be working on it on Monday. At a 50 year high school class reunion for the weekend, then I'll open it up on Sunday afternoon or Monday. Everything on the outside looks the same.
__________________
Brews Cruise is offline   Reply With Quote
Old 09-21-2017, 08:24 PM   #13
Member
 
Join Date: Jan 2017
Posts: 32
Sweetbriar, That sounds logical, and gives me another point to check. I know everything has a common monitor panel that selects between 20 amp, 30 amp, 50 Amp, and generator, and indicates which loads are being fed.Thanks for the advice!
__________________
Brews Cruise is offline   Reply With Quote
Old 09-21-2017, 08:28 PM   #14
Member
 
Join Date: Jan 2017
Posts: 32
Quote:
Originally Posted by Stuart W View Post
Is it the same 120 outlet your plugged into?[ATTACH]this picture is stock on 2016 3710[ATTACH]
Stewart, it is identical to the photo you posted. I will be opening everything up and checking with a multimeter. Thanks. I will also check for loose connections at all points.
__________________

__________________
Brews Cruise is offline   Reply With Quote
Reply

Tags
switch, transfer switch



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newmar Canyon Star :: 2016 Newmar Canyon Star Dngreen51 iRV2 Owners Registry 0 10-28-2016 03:12 AM
Heat pump dropping out Pushrod Winnebago Industries Owner's Forum 11 06-28-2007 01:11 AM
HWH Levelers Dropping Out Electrically... Steady Eddie MH-General Discussions & Problems 2 04-30-2006 03:18 PM
Heat pump dropping out RV Systems & Appliances 11 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.