RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 04-14-2016, 09:18 AM   #1
Senior Member
 
Scottybdivin's Avatar


 
Newmar Owners Club
Join Date: Jun 2012
Location: Spicewood Texas (West of Austin)
Posts: 4,271
Turn / Stop Signal Fuse and Relay Location

My left stop and turn signals quit working yesterday. Kris was following in the toad through heavy Phoenix traffic. Said they suddenly stopped working. I've gone through all my diagrams and fuse panels. The supplied Spartan diagram doesn't resemble the Spartan front fuse panel on my coach. FWIW, the left tail lights still work and everything works on the right. There are 6 bulbs on each side.
__________________

__________________
Scotty and Kristen, Airedales Dagny and Wyatt
2007 Newmar Mountain Aire 4528, 450 HP ISM, Allison 4000, 8 Trojan T-105's
2014 F150 4x4 Crew Cab Platinum 157" WB
Roadmaster Blackhawk 2, RVI2 Brake System
Scottybdivin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-14-2016, 12:51 PM   #2
Senior Member
 
mikelm48's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Nov 2010
Location: Grapevine, TX
Posts: 1,017
I believe it is in the electrical compartment on the passenger side. Mine is behind the rear axle.
__________________

__________________
Mike
2005 Kountry Star 3907, ISC330, Spartan chassis, M&G braking, Blue Ox Aventa XL
mikelm48 is offline   Reply With Quote
Old 04-14-2016, 06:49 PM   #3
Senior Member
 
Join Date: Jan 2011
Posts: 492
I had the same thing happen to my 06 MA. Tried a new flasher and that didn't fix it. Found out the it requires a special flasher that I had to get from Spartan. I ordered two because of that! Good luck!
__________________
2006 Mountain Aire, Jeep LJ, 900 watts of solar, boondocking life away! Volunteer Fire Fighter!
hes4all is offline   Reply With Quote
Old 04-16-2016, 07:49 PM   #4
Senior Member
 
Spartan Chassis
Join Date: Dec 2011
Location: Anywhere, USA
Posts: 415
Your Spartan rear light fuses and relays are on the passenger side. Open the door in front of drive axle and look for a black box mounted on the spartan frame.

Looks like this:

Good Luck!
shaman52 is offline   Reply With Quote
Old 04-16-2016, 10:41 PM   #5
Senior Member
 
Scottybdivin's Avatar


 
Newmar Owners Club
Join Date: Jun 2012
Location: Spicewood Texas (West of Austin)
Posts: 4,271
Quote:
Originally Posted by shaman52 View Post
Your Spartan rear light fuses and relays are on the passenger side. Open the door in front of drive axle and look for a black box mounted on the spartan frame.

Looks like this:

Good Luck!
Great. Been in a low/no cell data area. I will give that a try. I know where that panel is.
__________________
Scotty and Kristen, Airedales Dagny and Wyatt
2007 Newmar Mountain Aire 4528, 450 HP ISM, Allison 4000, 8 Trojan T-105's
2014 F150 4x4 Crew Cab Platinum 157" WB
Roadmaster Blackhawk 2, RVI2 Brake System
Scottybdivin is offline   Reply With Quote
Old 04-17-2016, 08:58 AM   #6
Senior Member
 
Spartan Chassis
Join Date: Dec 2011
Location: Anywhere, USA
Posts: 415
Does the left side RV and Toad light up on turn signal activation but not blink?
shaman52 is offline   Reply With Quote
Old 04-18-2016, 09:29 AM   #7
Senior Member
 
imgoin4it's Avatar
 
Newmar Owners Club
Join Date: Jul 2005
Posts: 359
If it is the relay like mine, good luck finding a replacement. They are little square things with 2 wire like plug in prongs. I nor my dealer could not find one anywhere. Finally called Spartan. Had them in stock and mailed one right away.
__________________
Howard & Connie. USAF Retired
2007 Newmar KSDP tow Jeep 4dr wrangler
member of IRV2since 2003
imgoin4it is offline   Reply With Quote
Old 04-18-2016, 09:51 PM   #8
Senior Member
 
Scottybdivin's Avatar


 
Newmar Owners Club
Join Date: Jun 2012
Location: Spicewood Texas (West of Austin)
Posts: 4,271
Quote:
Originally Posted by shaman52 View Post
Does the left side RV and Toad light up on turn signal activation but not blink?
No. The turn signal does not light up at all on the RV, but it does on the toad.
__________________
Scotty and Kristen, Airedales Dagny and Wyatt
2007 Newmar Mountain Aire 4528, 450 HP ISM, Allison 4000, 8 Trojan T-105's
2014 F150 4x4 Crew Cab Platinum 157" WB
Roadmaster Blackhawk 2, RVI2 Brake System
Scottybdivin is offline   Reply With Quote
Old 04-18-2016, 09:55 PM   #9
Senior Member
 
Scottybdivin's Avatar


 
Newmar Owners Club
Join Date: Jun 2012
Location: Spicewood Texas (West of Austin)
Posts: 4,271
Quote:
Originally Posted by imgoin4it View Post
If it is the relay like mine, good luck finding a replacement. They are little square things with 2 wire like plug in prongs. I nor my dealer could not find one anywhere. Finally called Spartan. Had them in stock and mailed one right away.
Where was this relay located on yours?
__________________
Scotty and Kristen, Airedales Dagny and Wyatt
2007 Newmar Mountain Aire 4528, 450 HP ISM, Allison 4000, 8 Trojan T-105's
2014 F150 4x4 Crew Cab Platinum 157" WB
Roadmaster Blackhawk 2, RVI2 Brake System
Scottybdivin is offline   Reply With Quote
Old 04-19-2016, 08:38 AM   #10
Senior Member
 
Spartan Chassis
Join Date: Dec 2011
Location: Anywhere, USA
Posts: 415
Check Fuse F-18 (7.5 amp) in Black Bussmann Box on frame rail.
Attached Thumbnails
Click image for larger version

Name:	Bussmann Fuses.jpg
Views:	222
Size:	45.3 KB
ID:	124590  
shaman52 is offline   Reply With Quote
Old 04-20-2016, 06:52 PM   #11
Senior Member
 
imgoin4it's Avatar
 
Newmar Owners Club
Join Date: Jul 2005
Posts: 359
The relay on mine is in the small compartment right behind the rear tires on the passenger side. The plastic electrical box is not very big and is on the back wall. There are a total of 4 identical relays. You can switch two of them to see if it changes what works and what does not.this is mine, not sure if yours is ssme
__________________
Howard & Connie. USAF Retired
2007 Newmar KSDP tow Jeep 4dr wrangler
member of IRV2since 2003
imgoin4it is offline   Reply With Quote
Old 04-23-2016, 02:23 PM   #12
Senior Member
 
Scottybdivin's Avatar


 
Newmar Owners Club
Join Date: Jun 2012
Location: Spicewood Texas (West of Austin)
Posts: 4,271
Quote:
Originally Posted by shaman52 View Post
Check Fuse F-18 (7.5 amp) in Black Bussmann Box on frame rail.
Thank you Shaman. I found the fuse and replaced it and everything works. The Spartan diagrams provided with my coach are incorrect. Neither of them, front or rear panels, match what's there. However, there is a printed list of the relays and fuses on the inside cover of the black box. Not sure why I have the wrong diagrams, but I will call Spartan and see if they can send me the right ones for future use.
__________________
Scotty and Kristen, Airedales Dagny and Wyatt
2007 Newmar Mountain Aire 4528, 450 HP ISM, Allison 4000, 8 Trojan T-105's
2014 F150 4x4 Crew Cab Platinum 157" WB
Roadmaster Blackhawk 2, RVI2 Brake System
Scottybdivin is offline   Reply With Quote
Old 04-24-2016, 07:17 AM   #13
Senior Member
 
Spartan Chassis
Join Date: Dec 2011
Location: Anywhere, USA
Posts: 415
Smile

Glad the fuse was your problem. I have had turn signal problems myself with the same K2 chassis. When you call Spartan ask them for the electrical drawings for the 2007 MADP/Essex. I have attached a much reduced PDF file. The whole thing is huge.
shaman52 is offline   Reply With Quote
Old 04-25-2016, 05:21 PM   #14
Senior Member
 
Scottybdivin's Avatar


 
Newmar Owners Club
Join Date: Jun 2012
Location: Spicewood Texas (West of Austin)
Posts: 4,271
shaman52, once again you have been an invaluable help. I copied the schematics. Thanks again.
__________________

__________________
Scotty and Kristen, Airedales Dagny and Wyatt
2007 Newmar Mountain Aire 4528, 450 HP ISM, Allison 4000, 8 Trojan T-105's
2014 F150 4x4 Crew Cab Platinum 157" WB
Roadmaster Blackhawk 2, RVI2 Brake System
Scottybdivin is offline   Reply With Quote
Reply

Tags
cat, fuse



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Fuse Location? jwfanning Monaco Owner's Forum 8 10-19-2015 05:40 AM
turn signal fuse location 99 tradewind pusher don spangler Class A Motorhome Discussions 2 08-26-2015 09:07 PM
hazard and turn signal relay xc chassis olivier Freightliner Motorhome Chassis Forum 4 11-20-2012 08:38 AM
turn signal relay location vectra96 MH-General Discussions & Problems 3 08-04-2010 07:35 AM
Right rear stop and turn signal light Uncle Sam Workhorse and Chevrolet Chassis Motorhome Forum 5 08-13-2008 05:39 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×