RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-18-2017, 11:58 AM   #1
Junior Member
 
Join Date: Jan 2017
Posts: 1
Water heater question

Hi, new to forum...have question I hope someone can help with. Have 2000 Dutchstar. Water heater runs fine on propane but when I put on electric it will work for about 20 min or so then circuit breaker on tank itself will trip. If anyone could suggest what it might be I would sure appreciate it. Thanks! Chris
__________________

Chris81660 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-18-2017, 12:09 PM   #2
Registered User
 
Join Date: Nov 2016
Posts: 520
Quote:
Originally Posted by Chris81660 View Post
Hi, new to forum...have question I hope someone can help with. Have 2000 Dutchstar. Water heater runs fine on propane but when I put on electric it will work for about 20 min or so then circuit breaker on tank itself will trip. If anyone could suggest what it might be I would sure appreciate it. Thanks! Chris
Chris81660
The "heating element" and/or the "thermostat" in your water heater may need to be replaced.

Google "XXX water heater troubleshooting".... (replacing the Xs with the make and model of your water heater).
__________________

Woodchopper is offline   Reply With Quote
Old 01-18-2017, 12:10 PM   #3
Senior Member
 
vito.a's Avatar
 
Monaco Owners Club
Join Date: Oct 2009
Location: Tucson, AZ
Posts: 2,720
It sounds like your electric heating element is bad. I just replaced the water heater in our Windsor. Mine was a Suburban 6 gallon water heater. PPL motorhomes had a great price. It took me about 2 hours to remove the old heater and about 2 hours to install the new one. If I did it again I could cut the time in half.
__________________
97 Monaco Windsor- Sold
07 Monaco Executive McKinley- Sold
04 Monaco Signature Chateau IV
vito.a is offline   Reply With Quote
Old 01-18-2017, 12:11 PM   #4
Senior Member
 
Stiltner's Avatar
 
Thor Owners Club
Freightliner Owners Club
Join Date: Sep 2016
Location: Roseville, Ca
Posts: 413
Hey Chris,

Welcome to the forum! You'll learn a lot here.

As with any electrical issue, I first start with the wiring, plugs and fuses to ensure the circuits are open. What you are describing suggest that the water heater is heating up a wire near the heating element, or there is a short somewhere. Thus, tripping the breaker......I suggest starting with wiring at the tank and move from there. You could start the water heater on electric, then open the panel and watch it to see.
__________________
2016 Thor Palazzo 33.2
14 Honda CRV, Roadmaster Tow Bar, Air Force 1
Stiltner is offline   Reply With Quote
Reply

Tags
heat, heater, water, water heater



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Water heater on 202 Open Road 30GA Water heater not working ButterflyDog Tiffin Motorhomes Owners Forum 7 11-17-2015 07:22 AM
Replace old Atwood Water Heater With New Atwood Water Heater GlennLever RV Systems & Appliances 2 07-14-2015 11:41 AM
Replacing Water heater with tankless water heater? JAFORV2012 Class A Motorhome Discussions 5 09-24-2012 07:48 AM
water heater ac heater failure dirko Winnebago Industries Owner's Forum 3 05-05-2009 12:29 PM
Water heater electric heater replacement dirko Winnebago Industries Owner's Forum 5 10-20-2005 10:53 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.