RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 10-25-2018, 07:09 PM   #1
Senior Member
 
rlott2k's Avatar
 
Join Date: Aug 2013
Location: BC, Cariboo, Lower Mainland.
Posts: 1,700
Water pump failure

Our newish (May 2017)shurflo water pump doesnít work. If I turn on any of the 3 switches the pump doesnít work, fuse blows, and the water level / tank info display also goes dead as itís on the same circuit. We may have left the pump on while hooked to city water.
Is there a pump controller on my unit? Iíve heard if you have multiple switches , yes. Where would it be?
Thanks.
__________________

__________________
2008 KSDP/2013 Flex
2nd year Fulltimers and still loving it.
rlott2k is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-25-2018, 07:24 PM   #2
Senior Member
 
Dutch Master's Avatar
 
Join Date: Nov 2014
Posts: 196
The controller is located near the pump. Blowing fuses maybe bad pump?
__________________

Dutch Master is offline   Reply With Quote
Old 10-26-2018, 04:37 AM   #3
Senior Member
 
C.Martin's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Posts: 2,623
Other than the pump controller, mounted to the sidewall near the pump...which simply turns the ground to the pump on and off...there is a pressure switch mounted on/within the pump. It's what cycles the pump so that if water isn't being used, it cuts the pump off when the lines are pressurized. The pump shouldn't mind city water.



Does the pump turn at all before the fuse blows? You could have a frozen motor/shorted winding...or something in the pump...or simply a wire came off a spade and is grounded against something somewhere.

I would suspect a wire lug near the "newish" pump. Maybe a wire came off...
__________________
Charlie & Ronni
2016 Ventana 4037
C.Martin is online now   Reply With Quote
Old 10-26-2018, 07:39 AM   #4
Senior Member
 
Newmar Owners Club
Spartan Chassis
Join Date: Oct 2014
Location: Lake McClure, CA
Posts: 838
I would start with disconnecting the hot wire to the pump(at the pump) and see if the fuse blows. If it does not blow the fuse , bad pump. If it does blow disconnect hot to the controller.
__________________
2018 Dutch Star 4369 Spartan Chassis
2016 Jeep Cherokee, 1952 Willys CJ3A
10 fan is offline   Reply With Quote
Old 10-26-2018, 07:49 PM   #5
Community Moderator
 
"007"'s Avatar


 
Nor'easters Club
Workhorse Chassis Owner
iRV2 No Limits Club
Join Date: Oct 2004
Posts: 29,723
Diagram for control wiring found in QT's # 3.
__________________
98KSCA, 99MACA, 03 KSCA-3740- 8.1 Chev-- ALLISON Trans
VISIT the NEWMAR QUICK TIPS & EASYMODS 1 & 2
QUICK TIPS # 3
RV SYSTEMS & APPLIANCES & RECALLS --- TECH INFORMATION
"007" is offline   Reply With Quote
Old 10-28-2018, 03:01 PM   #6
Senior Member
 
rlott2k's Avatar
 
Join Date: Aug 2013
Location: BC, Cariboo, Lower Mainland.
Posts: 1,700
Quote:
Originally Posted by C.Martin View Post
Other than the pump controller, mounted to the sidewall near the pump...which simply turns the ground to the pump on and off...there is a pressure switch mounted on/within the pump. It's what cycles the pump so that if water isn't being used, it cuts the pump off when the lines are pressurized. The pump shouldn't mind city water.



Does the pump turn at all before the fuse blows? You could have a frozen motor/shorted winding...or something in the pump...or simply a wire came off a spade and is grounded against something somewhere.

I would suspect a wire lug near the "newish" pump. Maybe a wire came off...


Pump does not turn on at any point.
__________________
2008 KSDP/2013 Flex
2nd year Fulltimers and still loving it.
rlott2k is offline   Reply With Quote
Old 10-28-2018, 06:19 PM   #7
Senior Member
 
StevL's Avatar
 
Ford Super Duty Owner
Join Date: Mar 2016
Posts: 555
I have a different coach and water pump, our controller was bad and blew fuses.

On the controller connect the ground wire to the pump wire(remove wires from controller and connect together - ground & load wires), replace fuse and turn on a faucet. If pump works it’s the controller. Mine cost $34. took maybe 5 minutes to change out.

Same controller 007 posted a photo of.


Steve
__________________
__________________________________________
2017 Newmar CS3710 2019 Jeep Wrangler JLU
StevL is offline   Reply With Quote
Old 10-28-2018, 06:39 PM   #8
Senior Member
 
rlott2k's Avatar
 
Join Date: Aug 2013
Location: BC, Cariboo, Lower Mainland.
Posts: 1,700
Thanks all, Iím on city water right now, once it stops raining Iíll get out there and check the controller.
__________________
2008 KSDP/2013 Flex
2nd year Fulltimers and still loving it.
rlott2k is offline   Reply With Quote
Old 11-01-2018, 02:41 PM   #9
Senior Member
 
rlott2k's Avatar
 
Join Date: Aug 2013
Location: BC, Cariboo, Lower Mainland.
Posts: 1,700
Pump was shorting out . Replaced pump. All good now.
__________________

__________________
2008 KSDP/2013 Flex
2nd year Fulltimers and still loving it.
rlott2k is offline   Reply With Quote
Reply

Tags
water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eng Comm Failure, Trans Comm Failure DaleR Monaco Owner's Forum 7 05-29-2015 03:35 PM
Brake Failure - Total Brake Failure tjshively Alpine Coach Owner's Forum 31 01-25-2015 11:36 AM
Won't start, engine comm failure,trans comm failure twincessna Monaco Owner's Forum 7 12-08-2011 09:50 PM
Won't start, engine comm failure, trans comm failure twincessna Cummins Engines 3 12-06-2011 06:30 PM
Water Pump Failure??? SacsTC Monaco Owner's Forum 13 05-18-2009 10:50 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 06:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×