RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login

Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 06-03-2019, 07:50 AM   #1
Senior Member
 
Bill Hunt's Avatar


 
Join Date: Jun 2014
Location: Waynesboro MS
Posts: 454
Water pump quit working 2017 Ventanna LE 4037

My water pump suddenly quit. Checked fuse it was good but replaced it anyway. No light on any water pump switch. Can anyone tell me what to look for? Not GFCI, checked that.
I really hate to have to take out the panel in the wet bay so before I do that can anyone give me suggestions on where else to look?
Thanks
__________________

__________________
Bill & Sandy Hunt
2017 Ventanna LE 4037, 2014 F-150 4 door & Cricket
Newmar Kountry Klub, Peach State Krackers
Newmar Hoots looking for a roost
Bill Hunt is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 06-03-2019, 07:51 AM   #2
Senior Member
 
450Donn's Avatar
 
Join Date: Jun 2006
Location: Dallas,OR
Posts: 3,337
Get out your VOM start checking voltage.
__________________

__________________
Don and Lorri
2007 Dodge 3500 dually
Resident Dummy.
450Donn is online now   Reply With Quote
Old 06-03-2019, 08:19 AM   #3
Senior Member
 
C.Martin's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Posts: 2,527
First is to understand how it works...

There is a controller in the wet bay usually mounted just behind the panel toward on the left bulkhead.

The controller is used as a method to control a single pump from many locations. When switched ON...it provides the water pump with a ground. 12v+ is always connected to the pump.

So...to test the pump...

BTW...gfci are for 110v circuits...the water pump is all 12vdc.

You do not have to pull the wet bay panel to access the pump or the controller. You do have to contort yourself to peek under and behind the panel.

1) connect a ground from the frame to the pumps ground terminal. If it runs...it is not the problem. If It doesn’t run...check for 12v+ to the positive side...if there is none...replace fuse. If there is...either the pump could be burned out...or the built-in pressure switch isn’t working properly.

2) if connecting a ground made the pump run...you are looking for an issue with the controller.

It has four connections... 12v+ make sure it’s getting power with a voltmeter.
12v- check the continuity of this terminal to a chassis ground.

Switch connections...the yellow black wire goes to all of your switches...if the controller is functioning properly...it will have a HI signal...somewhere around 7v when the PUMP is supposed to be ON. Or a LO signal,,, 2 -3 volts when the PUMP is supposed to be off. The green LEDs on your pump switches glow when the voltage is in HI state...and are dark when the voltage is in LO state. Each time you press a pump switch...it grounds the signal and that’s what tells the controller to switch between ON or OFF. The last terminal is the pathway for the pump to GND the 12v- side of the pump wiring.

If your pump controller has 12v+ and 12v-...and you already proved the pump is working...I would suspect you need to replace the controller.

My C-Storm version went bad in about 1 1/2 years...I replaced it with an Intellitec version.

If this confused you...ask questions...I hope I can answer them to get you back up and running.
__________________
Charlie & Ronni
2016 Ventana 4037
C.Martin is online now   Reply With Quote
Old 06-03-2019, 12:23 PM   #4
Senior Member
 
Bill Hunt's Avatar


 
Join Date: Jun 2014
Location: Waynesboro MS
Posts: 454
C. Martin THANKS! When I get home I'll get try what you've suggested.
At my age it's tough trying to get contorted.
I'll let you know how it goes.
__________________
Bill & Sandy Hunt
2017 Ventanna LE 4037, 2014 F-150 4 door & Cricket
Newmar Kountry Klub, Peach State Krackers
Newmar Hoots looking for a roost
Bill Hunt is offline   Reply With Quote
Old 06-03-2019, 12:42 PM   #5
Senior Member
 
Join Date: Mar 2009
Location: Apollo Beach, FL
Posts: 2,080
Very likely its the latching controller . It's generally located close to the pump. They are known to fail, particularly when you need it ... I carry a spare.
Looks like this one --> https://www.amazon.com/Intellitec-00.../dp/B00A2TBL7A
__________________
2013 DS 4338
2015 F-150 toad with kayaks,bicycles and a Harley in the back
PanJH is offline   Reply With Quote
Old 06-03-2019, 02:04 PM   #6
Senior Member
 
Join Date: Jan 2018
Posts: 1,109
In a pinch you can always bypass the latching controller with a short bit of wire and spade connectors on each end to power the pump.
__________________
Been through all the continental states and provinces. Rinse and repeat. Present coach 2018 VTDP 3407.
Finance is online now   Reply With Quote
Old 06-04-2019, 03:02 PM   #7
Junior Member
 
Join Date: Jan 2014
Location: Prairieville, LA
Posts: 14
Thank you

I was having intermittent cutoff from the water pump and was wondering what was the cause. I ordered a replacement before it goes out completely Thanks for the posts.
__________________
2016 Ventana 4322
GMDLA is offline   Reply With Quote
Old 06-05-2019, 08:13 AM   #8
Senior Member
 
Bill Hunt's Avatar


 
Join Date: Jun 2014
Location: Waynesboro MS
Posts: 454
Where is the controller? Is it the block with 4 connectors on the left of the pump. There are 2or 3 lights on this. None are on??
Thanks
__________________
Bill & Sandy Hunt
2017 Ventanna LE 4037, 2014 F-150 4 door & Cricket
Newmar Kountry Klub, Peach State Krackers
Newmar Hoots looking for a roost
Bill Hunt is offline   Reply With Quote
Old 06-05-2019, 09:53 AM   #9
Senior Member
 
NWIP's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Nov 2017
Posts: 284
Quote:
Originally Posted by Bill Hunt View Post
Where is the controller? Is it the block with 4 connectors on the left of the pump. There are 2or 3 lights on this. None are on??
Thanks
I think your unit came with the C-Storm controller and should look like this one in the link, https://www.ebay.com/p/C-storm-Elect...dule/916862507

Mine failed and replaced with Intellitec as CMartin explained.
__________________
Bill & Lisa
2017 DS 4018
2016 Colorado Z71
NWIP is offline   Reply With Quote
Old 06-05-2019, 10:34 AM   #10
Senior Member
 
C.Martin's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Posts: 2,527
Quote:
Originally Posted by Bill Hunt View Post
Where is the controller? Is it the block with 4 connectors on the left of the pump. There are 2or 3 lights on this. None are on??
Thanks
You've described it perfectly...

There are two LED lights...we'll see if I can find you a link.
__________________
Charlie & Ronni
2016 Ventana 4037
C.Martin is online now   Reply With Quote
Old 06-05-2019, 10:41 AM   #11
Senior Member
 
Bill Hunt's Avatar


 
Join Date: Jun 2014
Location: Waynesboro MS
Posts: 454
Quote:
Originally Posted by C.Martin View Post
You've described it perfectly...



There are two LED lights...we'll see if I can find you a link.


I disconnected the ground wire and the green light came on?? Whatís next?
Thanks again.
__________________
Bill & Sandy Hunt
2017 Ventanna LE 4037, 2014 F-150 4 door & Cricket
Newmar Kountry Klub, Peach State Krackers
Newmar Hoots looking for a roost
Bill Hunt is offline   Reply With Quote
Old 06-05-2019, 10:43 AM   #12
Senior Member
 
Bill Hunt's Avatar


 
Join Date: Jun 2014
Location: Waynesboro MS
Posts: 454
Quote:
Originally Posted by Bill Hunt View Post
I disconnected the ground wire and the green light came on?? Whatís next?
Thanks again.


The switch lights did not come on.
__________________
Bill & Sandy Hunt
2017 Ventanna LE 4037, 2014 F-150 4 door & Cricket
Newmar Kountry Klub, Peach State Krackers
Newmar Hoots looking for a roost
Bill Hunt is offline   Reply With Quote
Old 06-05-2019, 10:46 AM   #13
Senior Member
 
C.Martin's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Posts: 2,527
https://www.google.com/url?sa=t&sour...7ZnZmc_w2mXL76

Cannot seem to find a working link to the C-Storm version...
__________________
Charlie & Ronni
2016 Ventana 4037
C.Martin is online now   Reply With Quote
Old 06-05-2019, 01:03 PM   #14
Senior Member
 
C.Martin's Avatar
 
Newmar Owners Club
Freightliner Owners Club
Join Date: Aug 2015
Posts: 2,527
I had an archived copy...
Attached Files
File Type: pdf Water pump controller.pdf (1.03 MB, 6 views)
__________________

__________________
Charlie & Ronni
2016 Ventana 4037
C.Martin is online now   Reply With Quote
Reply

Tags
vent, water, water pump



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2017 Ventana LE 4037 Dometic Heat Pump/AC Robert T Newmar Owner's Forum 3 11-13-2018 11:46 AM
2017 Newmar Ventanna 4037 Bill Hunt iRV2 Owners Registry 0 11-06-2018 05:04 AM
2017 Ventanna LE full wall slide problem!! Bill Hunt Newmar Owner's Forum 8 10-13-2016 09:35 AM
Ventanna 2009 model3961 heat pumps not working during inspection apgob Newmar Owner's Forum 1 08-27-2015 06:38 PM
In motion satellite 2013 ventanna Razorback198 Newmar Owner's Forum 19 05-23-2013 03:23 PM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:54 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.