Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 08-16-2016, 04:49 PM   #1
Senior Member
 
specmga1's Avatar


 
Join Date: Aug 2011
Posts: 325
What do these dash lights mean?

I am getting both of these lights coming on at the same time periodically. I have a 2016 Canyon Star. Sometimes, if I turn the engine off and restart it, they go away.
Can someone help!
Thanks!
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	167
Size:	283.0 KB
ID:	136145  
__________________

__________________
specmga1 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 08-16-2016, 04:52 PM   #2
Senior Member
 
Mr_D's Avatar
 
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 27,162
What lights are you getting?
__________________

__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 CR-V
Mr_D is offline   Reply With Quote
Old 08-16-2016, 04:53 PM   #3
Senior Member
 
specmga1's Avatar


 
Join Date: Aug 2011
Posts: 325
I just attached the photo. Sorry!
__________________
specmga1 is offline   Reply With Quote
Old 08-16-2016, 07:46 PM   #4
Junior Member
 
Longshot308's Avatar
 
Newmar Owners Club
Join Date: Feb 2015
Posts: 28
Welcome to the dash light club..... This happened to me on the way home with our 2016 Bay Star. The bottom line is that the lights will reset after turning off the engine and restarting. The ECM requires a reflash to be completed by a Ford dealer. There is a mistiming in the BOO switch(brake on/brake off) by a few milliseconds. There is a Technical Service Bulletin in regard to this issue. The TSB is 16-0042. I have not fixed mine yet and have driven well over 1,000 miles. The lights come and go. I hope this helps!
__________________
G Man & Wife
2016 Bay Star 3403
Toad: 2012 Ford Fiesta
Longshot308 is offline   Reply With Quote
Old 08-16-2016, 08:58 PM   #5
Senior Member
 
specmga1's Avatar


 
Join Date: Aug 2011
Posts: 325
Thanks!
__________________
specmga1 is offline   Reply With Quote
Old 08-16-2016, 09:33 PM   #6
Senior Member
 
psi500's Avatar
 
Newmar Owners Club
Ford Super Duty Owner
Join Date: Jul 2015
Posts: 457
Mine did the same thing, took it back to the RV dealer, service rep said they messed with the brake pedal? Havent had a light issue since or about 400 miles.
__________________
2016 Newmar 3710 Canyon Star
2014 GMC Terrain
psi500 is offline   Reply With Quote
Old 08-19-2016, 05:39 AM   #7
Senior Member
 
specmga1's Avatar


 
Join Date: Aug 2011
Posts: 325
Quote:
Originally Posted by Longshot308 View Post
Welcome to the dash light club..... This happened to me on the way home with our 2016 Bay Star. The bottom line is that the lights will reset after turning off the engine and restarting. The ECM requires a reflash to be completed by a Ford dealer. There is a mistiming in the BOO switch(brake on/brake off) by a few milliseconds. There is a Technical Service Bulletin in regard to this issue. The TSB is 16-0042. I have not fixed mine yet and have driven well over 1,000 miles. The lights come and go. I hope this helps!
Thanks for the info! So it's safe to drive until I can get it in for the fix?
__________________
specmga1 is offline   Reply With Quote
Old 08-22-2016, 08:20 AM   #8
Senior Member
 
Boomer's Avatar


 
Newmar Owners Club
Join Date: Apr 2015
Location: State College, PA
Posts: 246
Is this issue only on 2016 Canyon Stars, and if not could it show up after a year?
Thanks,
__________________
Bob and Terri
2015 Newmar Canyon Star 3953,
2013 Wrangler Unlimited Sahara
Boomer is online now   Reply With Quote
Old 08-22-2016, 08:44 AM   #9
Senior Member
 
specmga1's Avatar


 
Join Date: Aug 2011
Posts: 325
No, it's a Ford F53 issue, - nothing to do with the motorhome manufacturer.
__________________
specmga1 is offline   Reply With Quote
Old 08-23-2016, 12:36 PM   #10
Senior Member
 
Boomer's Avatar


 
Newmar Owners Club
Join Date: Apr 2015
Location: State College, PA
Posts: 246
Quote:
Originally Posted by specmga1 View Post
No, it's a Ford F53 issue, - nothing to do with the motorhome manufacturer.
Apparently I should have asked "Is it only on 2016 F53 chassis and if I have a 2015 F53 chassis that currently doesn't have the issue, should I expect to see the issue appear"

Hope this clarifies.
__________________
Bob and Terri
2015 Newmar Canyon Star 3953,
2013 Wrangler Unlimited Sahara
Boomer is online now   Reply With Quote
Old 08-23-2016, 12:43 PM   #11
Senior Member
 
specmga1's Avatar


 
Join Date: Aug 2011
Posts: 325
I don't think so
__________________

__________________
specmga1 is offline   Reply With Quote
Reply

Tags
light, lights, dash



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marker lights,clearance lights and brake lights Ahall Entegra Owner's Forum 1 04-18-2014 05:39 AM
turn signals, running lights, tow lights side clearance lights not working gowhiz Tiffin Motorhomes Owners Forum 3 02-26-2014 07:02 AM
Dash lights on, gauges jump. Low voltage to dash. bobioknight RV Systems & Appliances 3 05-11-2013 10:55 PM
Dash Board Lights and Head Lights LeeB Newmar Owner's Forum 13 07-26-2007 03:33 AM
Dash Board Lights and Head Lights Workhorse and Chevrolet Chassis Motorhome Forum 13 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.