RV Trip Planning Discussions

Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Newmar Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
  This discussion is proudly sponsored by:
Please support our sponsors and let them know you heard about their products on iRV2
 
Thread Tools Search this Thread Display Modes
 
Old 01-14-2018, 01:33 PM   #1
Senior Member
 
flyboy013's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2017
Posts: 467
XSG2NA Infotainment System Video Input

I pulled out the XSG2NA Infotainment System out of the dash on my Ď18 MA to check the antenna connection because I wasnít getting a good radio signal. I unplugged and reinserted the antenna wire and its slightly better now, but nowhere as good as the signal received in my cars. I guess my next step would be to try a different antenna in order to determine if the rooftop antenna is my issue. Has anyone else had an issue with their radio reception and if so what was your solution.

The radio has video inputs for for AUX and Camera. The camera connection has nothing plugged into it. Perhaps Iíll use that for viewing of my dash cam once installed. The AUX input has audio and video cables (RCA) plugged into it, but when selecting the AUX display I get a message that there is NO VIDEO DETECTED. Any idea what the AUX cables are connected to and/or what action I need to take to get the video displayed?
__________________

__________________
2018 Newmar Mountain Aire 4531 - Spartan K3-500
2015 Jeep Grand Cherokee Overland
SMI AFO, Blue Ox
flyboy013 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-14-2018, 02:07 PM   #2
Senior Member
 
turbopilot's Avatar
 
Join Date: Aug 2017
Posts: 2,079
Quote:
Originally Posted by flyboy013 View Post
I pulled out the XSG2NA Infotainment System out of the dash on my Ď18 MA to check the antenna connection because I wasnít getting a good radio signal.
Just too much low frequency RFI from all the microprocessors on board for quality AM radio reception.

I use the TuneIn Radio app on my iPhone with the BlueTooth connection to the Xite Infotainment center anytime I want reliable AM station reception.
__________________

__________________
2018 New Aire 3343
turbopilot is online now   Reply With Quote
Old 01-14-2018, 09:42 PM   #3
Senior Member
 
flyboy013's Avatar
 
Newmar Owners Club
Spartan Chassis
Join Date: Jun 2017
Posts: 467
Quote:
Originally Posted by turbopilot View Post
Just too much low frequency RFI from all the microprocessors on board for quality AM radio reception.

It the FM thatís having the issue. I havenít listened to AM in years.

In your New Aire does selecting the Camera input on the radio display anything on the screen. I have something connected to the radio Camera connectors but I donít know where the cable goes. Not sure if itís supposed to be one of the vehicleís many cameras, a TV, or something else.
__________________
2018 Newmar Mountain Aire 4531 - Spartan K3-500
2015 Jeep Grand Cherokee Overland
SMI AFO, Blue Ox
flyboy013 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 Itasca Meridian 42E Nav unit (XSG2NA-X) cliffm Winnebago Industries Owner's Forum 8 09-03-2016 10:19 AM
XSG2NA infotainment center hutchg Winnebago Industries Owner's Forum 12 10-10-2014 10:06 PM
XSG2NA Nav receiver - late 2013&up - Rand Traffic data hogdriver Entegra Owner's Forum 1 06-04-2014 02:01 PM
The XiteSolutions XSG2NA-X1S radio display is more than disappointing boiledfrog Winnebago Industries Owner's Forum 6 04-30-2014 03:02 PM
Infotainment Center GPS System antenna issue ChrisKW Winnebago Industries Owner's Forum 3 01-19-2014 08:56 AM

» Featured Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 09:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×