Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 01-11-2011, 12:24 PM   #1
Junior Member
 
jr7864's Avatar
 
Alpine Owners Club
Join Date: Oct 2009
Posts: 5
Alpine Coach oil light problem

I am having a problem with the oil light coming on and warning signal. Then all the guages drop on the pannel to zero but then it goes off and all the gauges are back working like nothing has happend. I am lost but think its an electrical problem like a loose ground. Just wondering if anyone has had the same problem...
__________________

__________________
jr7864 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-11-2011, 07:34 PM   #2
Senior Member
 
Algoma's Avatar


 
Join Date: Nov 2007
Location: Charleston, WV
Posts: 2,640
Would help if you stated the year and model of your coach.
__________________

__________________
John and Mary Knight
2015 Newmar Ventana 4311 - wheelchair accessible
2015 Cadillac SRX Luxury AWD
Algoma is offline   Reply With Quote
Old 01-12-2011, 01:30 PM   #3
Junior Member
 
Join Date: Jan 2011
Posts: 1
jr7864 I had a simular problem. It was a simple fix and Specialty RV in Aurora Oregon did the job. The factory put in the least costly power relay they could find and it went bad. We replaced it with a Battery Separator "
smart selenoid" It came from Sure Power Ind. Inc. In Tualatin Oregon 503-692-5360 I have had no problems with it or the installation.
__________________
C FINORTIN is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Towed vehicle brake light problem Janet&Sid Alpine Coach Owner's Forum 16 10-31-2010 05:05 PM
Gas coach charging problem wilythek Class A Motorhome Discussions 13 10-22-2010 09:11 PM
Check Engine Light On in my Cummings 275 Turbo Diesel. Oil Level too high??? leedowney Cummins Engines 37 03-01-2010 03:18 PM
We R Looking to purchase first Alpine Coach Janet and Todd Alpine Coach Owner's Forum 16 05-03-2007 04:39 PM
Alpine Coach Owner's Forum Member Ted III Alpine Coach Owner's Forum 6 01-03-2006 04:27 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 01:04 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.