Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-10-2008, 07:42 PM   #1
Senior Member
 
Alpine Owners Club
Join Date: Dec 2006
Location: Olympia
Posts: 670
On Saturday, I discovered that my turn signal loghta aren't working too well. The Right side works then it doesn't then it does again. Thr Left side lights will light up if I manually blink them. I thinking that it is the flasher unit but in reading other posts I wonder if it is that simple. So perhaps someone might have ideas on what the culprit is if not the flasher and where the flash unit is on a '99.
__________________

__________________
Jeff
'99 Alpine Coach
Jeff and Cheryl is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-10-2008, 07:42 PM   #2
Senior Member
 
Alpine Owners Club
Join Date: Dec 2006
Location: Olympia
Posts: 670
On Saturday, I discovered that my turn signal loghta aren't working too well. The Right side works then it doesn't then it does again. Thr Left side lights will light up if I manually blink them. I thinking that it is the flasher unit but in reading other posts I wonder if it is that simple. So perhaps someone might have ideas on what the culprit is if not the flasher and where the flash unit is on a '99.
__________________

__________________
Jeff
'99 Alpine Coach
Jeff and Cheryl is offline   Reply With Quote
Old 04-11-2008, 08:00 AM   #3
Senior Member
 
Join Date: Jan 2006
Location: Simi Valley, Calif
Posts: 127
on my 2001 the flasher is located in front of the passenger seat. Behind the removable panel
There are two one for the hazard flashers and one for the turn signals. I think you will find them in the lower right corner. The spring clip tends to crush the flasher and cause it to fail. easy to replace
__________________
Sandy and Debi
2004 Alpine 36 FDDS
sandy1 is online now   Reply With Quote
Old 04-11-2008, 07:12 PM   #4
Senior Member
 
Alpine Owners Club
Join Date: Dec 2006
Location: Olympia
Posts: 670
Sandy1,

Thank-you for the information. At about the same time you posted this morning, Mark from WRV called. My wife took the call as I was at work. I love this forum!! Having a 10 year old coach, I wouldn't expect to get a call from the factory, perhaps a return call but not a factory initated call before 9 in the morning. Great helpful owners and great customer service!!
__________________
Jeff
'99 Alpine Coach
Jeff and Cheryl is offline   Reply With Quote
Old 04-12-2008, 01:47 PM   #5
Senior Member
 
Alpine Owners Club
Join Date: Nov 2006
Location: Douglas, GA
Posts: 117
Just a brief note. Re: your specific problem, I feel a little bit related, with differences. Since you don't mention any other problems, I'd would second the idea of the flashers. However, when my '03 started kicking off the cruise control when I signaled for a turn, and then the cruise wouldn't cancel when I tapped the brake, I had to look further. Fortunately, the area behind the dash directly in front of my "navigator" turned up two different blown blade fuses. Problems solved. Moral: Check all those fuses while you've got the panel off.

Good luck.

Jim E. '03 FDTS, 38' w/Cummins 350
__________________
J.S.Eddy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is the "New PM" tab blinking at Me? golden Forum 101 | Announcements | Member Concerns 6 03-05-2009 03:09 PM
Need help 1998 Ford E450 blinkers quit. Chandler1 Class C Motorhome Discussions 2 11-10-2008 06:15 PM
Problem with Blinkers. Rick 2005 Dolphin 5376 MH-General Discussions & Problems 7 03-31-2008 06:00 AM
lights blinking rjw Alpine Coach Owner's Forum 3 06-12-2007 12:37 AM
Blinkers interfere with trailer brakes captaintabasco Trailer Towing and Tow Vehicles Discussion 7 04-20-2006 07:01 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 12:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.