Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 01-05-2014, 06:30 PM   #1
Join Date: Sep 2013
Posts: 40
Check engine light on 99 36fds

Is their a way I can retrieve the trouble codes without a scan tool?
Coach starts and runs fine but light just came on

Justinmartin is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 01-05-2014, 06:38 PM   #2
Senior Member
sswilson's Avatar
Winnebago Owners Club
Join Date: Nov 2012
Location: Cobble Hill, B.C.
Posts: 1,198
Could be from something stupid that happened when you started it. Disconnect battery to get rid of light and if it comes back on, get a reader to get codes. I had my light come on on the way home 2 years ago and all was well on my instruments. Drove it all the way home, did the battery thing and light has not come on since. I have gone south again since. Also happened the other day with my Ford pickup, disconnected, light went out and has not come on again.

Steve and Sheri with Archie (and Hiro, R.I.P.)
2000 Winnebago 35U, Ford F53/6.8l V10
F150 Ford and Vintage Aspencade.
sswilson is offline   Reply With Quote
Old 01-05-2014, 06:41 PM   #3
Senior Member
mrt_1111's Avatar

Fleetwood Owners Club
Ford Super Duty Owner
iRV2 No Limits Club
Join Date: Oct 2012
Location: Colorado Springs, CO
Posts: 697
Originally Posted by Justinmartin View Post
Is their a way I can retrieve the trouble codes without a scan tool?
Coach starts and runs fine but light just came on
check with local auto part store, they sometime scan it for free. Maybe a local RVer might have a scan tool.
Mark Taylor
1999 Bounder 32H Ford V10, 2012 Ford Focus, Pretty DW, 2 cats. Retired USAF
mrt_1111 is online now   Reply With Quote
Old 01-06-2014, 09:39 AM   #4
Join Date: Sep 2013
Posts: 40
It's not an obd2 connector
I'd like to see what codes in it instead of just clearing it
Justinmartin is offline   Reply With Quote
Old 01-06-2014, 09:58 AM   #5
Senior Member
Join Date: Nov 2005
Posts: 2,807
Its a Cummins--their engine, their code reader. Common but useless codes include loose fuel caps [maybe????] and "high" manifold temp based on wax valve not opening soon enough if you start driving in cool temps before engine has gotten above 150 degrees or so. Could also be fuel flow issues. Beyond these, the codes/causes are endless. Dont know of any DIY ways to decode these "warnings" in the earlier engines [think the later Activa gauges have a hidden decoder mode???]
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 01-06-2014, 11:13 AM   #6
Senior Member
Algoma's Avatar

Join Date: Nov 2007
Location: Charleston, WV
Posts: 2,163
As Old Scout said, the only way you will find out what the codes are is to go to a Cummins shop and get them to scan it. I assume it stores old codes so even if your light goes off they may be able to tell you what the problem was. I am assuming you have the ISC engine.

John and Mary Knight
2015 Ventana 4311, 2015 Cadillac SRX
Algoma is offline   Reply With Quote

check engine light

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine "miss" at 25-30 mph linda7915 Workhorse and Chevrolet Chassis Motorhome Forum 17 12-20-2013 08:57 PM
New MADP 4361 having issues DebbieS Newmar Owner's Forum 14 11-20-2013 08:22 AM
Check engine light ShadowBolt Entegra Owner's Forum 27 08-17-2013 01:08 PM
50,000 Mile Report on the Brazel's UltraPower Engine Mod Duner Workhorse and Chevrolet Chassis Motorhome Forum 6 07-29-2013 01:30 PM
Engine threw a Rod or 2..need advice AlanTerry Class A Motorhome Discussions 68 06-17-2013 07:02 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 10:59 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.