Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-07-2010, 12:18 AM   #1
Senior Member
 
anthem4us's Avatar
 
Join Date: Dec 2003
Posts: 110
Dead Battery

Came home the other day and tried to put the front power shades down but I had no 12v power. I turned the key to the on position but nothing happened. I then pushed the battery boost and then tried again and I had power. I started the coach and let it run for about ten minutes. I let the coach sit for a while and then tried to start the coach again but when I turned the key on their was nothing. The coach is plugged into shore power. Any ideas?

Larry
2004 40' MDTS
__________________

__________________
anthem4us is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-07-2010, 12:36 AM   #2
Senior Member
 
takepride's Avatar
 
Alpine Owners Club
Join Date: Aug 2007
Location: Long Beach, CA
Posts: 1,563
Sounds like no charging at the engine batteries. Ten minutes running the engine is not enough to recharge it. If you have an Echo Charger (some Vansco coaches have added it), the inline fuse is probably bad. It is near the batteries (glass fuse). More likely it is the oft defective solenoid, as described in multiple, multiple threads. It allows the charger on you inverter to charge the engine batteries after the house batteries are full, (just like an Echo Charger). Search for Fatboy or Trombetta. You'll get lots of hits.
__________________
2003 Alpine 40FDTS (400HP)
Long Beach, CA
takepride is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Toad Battery dead Field Trip Newmar Owner's Forum 9 02-07-2009 04:35 PM
Chassie battery dead luceil Winnebago Industries Owner's Forum 9 05-07-2008 04:18 PM
Resurrect - Dead Cordless Battery Oemtech iRV2.com General Discussion 5 09-17-2005 07:09 PM
Dead battery question Britej RV Systems & Appliances 37 08-25-2005 06:12 AM
Dead chassis battery after 2 days Fla2RI Workhorse and Chevrolet Chassis Motorhome Forum 14 06-27-2005 08:14 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 07:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.