Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 05-09-2015, 06:49 PM   #15
Senior Member
ralph0808's Avatar
Join Date: Mar 2010
Location: Eucha,OK
Posts: 141
Stan, you can do a search on the forum about the use of mineral oil. That would allow you to be better informed than what I can tell you. I just know that I used it with my previous class A & with my new 2012 Jayco class C my battery compartment was able to stay a lot cleaner & little to no corrosion. Time will tell on my Alpine the results of using mineral oil.

2005 Alpine 40 FDQS

2005 Alpine 40 FDQS, 2011 Chevy Equniox, Ready Brute Elite Towbar, Ralph & Debbie with Sassie & Shelby
ralph0808 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Large power draw on chassis battery '94 Kountry Star omegacanuck Newmar Owner's Forum 54 01-31-2016 08:22 PM
Palazzo Battery Monitor Install (Magnum ME-BMK) Redridge Palazzo Motorhomes 6 09-17-2014 06:30 AM
Fixin' the battery shut down issue ..... finally Karlos National RV Owner's Forum 2 07-21-2014 02:52 AM
My Aux Start Battery Switch Is Not Working Yellowboat Winnebago Industries Owner's Forum 14 04-06-2014 08:01 AM
Deep cycle as starting battery Jayrock3570 RV Systems & Appliances 3 03-15-2014 09:28 AM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 02:54 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.