Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-31-2005, 04:00 PM   #1
Member
 
Join Date: Feb 2003
Posts: 43
My 2004 gen slide was coming out slower. Got to looking for problems and found 4 of the 10 rollers with needle bearings rusted solid! Probably from salt on highways or near the coast. Check them out. I had to replace 4 and now liberally spray them with lithium spray grease.
__________________

__________________
royboy is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 07-31-2005, 04:00 PM   #2
Member
 
Join Date: Feb 2003
Posts: 43
My 2004 gen slide was coming out slower. Got to looking for problems and found 4 of the 10 rollers with needle bearings rusted solid! Probably from salt on highways or near the coast. Check them out. I had to replace 4 and now liberally spray them with lithium spray grease.
__________________

__________________
royboy is offline   Reply With Quote
Old 08-08-2005, 01:50 PM   #3
Senior Member
 
Stretch's Avatar


 
Join Date: May 2004
Location: cayucos, ca
Posts: 1,126
Royboy:
Had same problem with our 03. We have the 12v electric jack screw type of actuator. I think you do too. I found that the jackscrew motor was failing. I called the Jackscrew mfg. (the same folks that mfg the steps) and they sent me a new unit, no charge. That solved my problems
__________________
Ross Starkenburg
2017 Newmar Dutch Star 4369. Spartan chassis w/full disc brakes. 2015 Jeep Grand Cherokee toad
Stretch is online now   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gen Slide/Fuel Fill RedHotSoup Alpine Coach Owner's Forum 11 01-04-2009 07:02 PM
Gen-Slide Problem RedHotSoup Alpine Coach Owner's Forum 3 11-26-2008 02:15 PM
2004 Dynasty Regal Gen Set issues mhgypsy Monaco Owner's Forum 5 06-24-2008 06:31 AM
Associated problems with 2004 Eagle 42R boaterok Fleetwood Products Owner's Forum 5 05-26-2008 10:46 PM
2004 Dynasty Regal Gen Set issues MH-General Discussions & Problems 5 12-31-1969 07:00 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 11:47 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.