Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-04-2015, 03:30 PM   #1
Junior Member
 
Join Date: Sep 2011
Location: Shawnee, KS
Posts: 17
Electical problems SUPREME

Wow! Just when I thought it couldn't get any worse.

This is a long-lasting problem and we seem to be going backwards.

We had the floor tile replaced in the bathroom of our 40 foot 2004 Alpine. Afterward the Xantrex remote panel was going crazy with blinking lights all over. We determined that since the batteries were at least five years old that we would replace them -- ALL of them, chassis and house. Voila. The situation was corrected -- or so we thought. The Xantrex panel worked fine and all seemed great.

We took the RV on a short trip and the chassis batteries were dead the second morning when we tried to start the RV. We jumped it. We found, though, when we traveled that the house batteries did not charge when the engine was running. Likewise the chassis batteries did not charge when on shore power or when running the generator. We were told that the problem was the "Low Voltage Disconnect", Model 3104 that was behind the clear plastic panel in the battery compartment. That was replaced with a Sure Power "Interconnect Controller" Model 3104 -- which may or may not have been the right thing to do as it looks right now.

So we came on this trip and two days into it the inverter will not work. We have tried everything to reboot it or reset it -- whatever. And today the chassis batteries are dead and the generator cannot start. What is going on and where can I go to get help? Sounds like a total electrical miswiring situation to me, but I don't know jack about this. I would sure appreciate any help anyone could give me.

Bill
__________________

__________________
billvietti is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 10-04-2015, 04:43 PM   #2
Senior Member
 
Old Scout's Avatar
 
Join Date: Nov 2005
Posts: 3,929
Doesnt sound like a "miswiring" issue if once it worked and now it doesnt--what changed????? The solenoid you replaced is triggered by a signal from the charging logic in the Vansco communications modules--light #19. Notwithstanding your inverter issues?????, sounds like the triggering signal might be an issue. However, your admission that you "dont know jack about these things" worries me that you may not be "equipped" to diagnose and fix this via internet. Since you recently changed bats and charging solenoid, and now you are seeing blinking lights on your inverter panel--think I would bite the bullet and find a qualified RV tech to help you figure out what is going on....




no
__________________

__________________
Old Scout
2003 40' MDTS
Garden Ridge, Texas
Old Scout is offline   Reply With Quote
Old 10-04-2015, 05:10 PM   #3
Senior Member
 
HHIDan's Avatar
 
Join Date: Mar 2011
Location: Ottawa Ontario Canada
Posts: 1,254
A good friend of mine had blinking lights on Xantrex remote contol panel, 12 volts light dimming and fan on inverter going on and off, inverting but not charging properly (going on and off). 2004 AllegroBus and Xantrex Prosine 3. I disconnected the 12 volt cables at the Xantrex and connected one good battery. The Xantrex was still acting weird so friend is taking it to Lazy Days to see if it can be fixed, company (Xantrex) is out of business so I am thinking we will probably replace the whole thing for a Magnum MS2812.

Be careful working around batteries, wear eye protection and maybe ear muffs. Know someone that had a battery blow up near his face and he lost the hearing on one side...
__________________
DanielB
'06 Mountain Aire 4309, ISL 400-CM850, Spartan MMGT
'16 Jeep Wrangler
HHIDan is offline   Reply With Quote
Old 10-04-2015, 05:19 PM   #4
Senior Member
 
Mr_D's Avatar
 
Solo Rvers Club
iRV2 No Limits Club
Join Date: May 2011
Location: Vancouver, WA
Posts: 28,452
Quote:
Originally Posted by HHIDan View Post
(Xantrex) is out of business
Really?

Xantrex | Power Inverter, Inverter Charger, Battery Charger Manufacturer
__________________
2009 45' Magna 630 w/Cummins ISX 650 HP/1950 Lbs Ft
Charter Good Sam Lifetime Member, FMCA, SKP
RV'ing since 1957, NRA Benefactor Life, towing '14 CR-V
Mr_D is offline   Reply With Quote
Old 10-04-2015, 05:22 PM   #5
Junior Member
 
Join Date: Sep 2011
Location: Shawnee, KS
Posts: 17
Yes. I think the only choice now is professional help. Thanks for your input.
__________________
billvietti is offline   Reply With Quote
Old 10-04-2015, 05:35 PM   #6
Senior Member
 
HHIDan's Avatar
 
Join Date: Mar 2011
Location: Ottawa Ontario Canada
Posts: 1,254
Quote:
Originally Posted by billvietti View Post
Yes. I think the only choice now is professional help. Thanks for your input.
I take that back, sorry.
__________________
DanielB
'06 Mountain Aire 4309, ISL 400-CM850, Spartan MMGT
'16 Jeep Wrangler
HHIDan is offline   Reply With Quote
Old 10-04-2015, 10:18 PM   #7
Senior Member
 
DrDaveMA's Avatar


 
Alpine Owners Club
Join Date: Jun 2007
Location: Cotuit, MA
Posts: 2,251
I wonder if there is a battery installed backwards? When replacing the 6v cells it is EASY to connect one backwards.

As far as the Vansco is concerned a reset is ALWAYS a good idea when things go crazy.

I agree, if you are not familiar with these problems get to a service center and let them sort it out, don't let the people here lead you into doing things that are beyond your skill set.


Sent from my iPad using iRV2 - RV Forum
Dave, Bobbi and Fenway
__________________

__________________
Dave, Bobbi and Fenway
2005 38' FDTS Alpine Limited, 2016 Jeep Grand Cherokee Limited
Cape Cod, MA
DrDaveMA is offline   Reply With Quote
Reply

Tags
problems



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Rig Problems Greg813 New Rig Show-Off! 31 12-01-2014 09:50 PM
Travel Supreme owners linthib New Member Check-In 8 10-26-2014 08:44 AM
Garmin 760 dezl lmt problems THERAPY GUY Newmar Owner's Forum 2 03-03-2014 01:03 PM
EGR soot cleaning to have less replacement problems tom chelbana Cummins Engines 2 02-14-2014 09:09 PM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.