Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Click Here to Login
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-12-2015, 03:26 PM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 10
Electric sun visor not working

any suggestions on how to fix
__________________

__________________
rywren is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-12-2015, 08:03 PM   #2
Senior Member
 
DrDaveMA's Avatar


 
Alpine Owners Club
Join Date: Jun 2007
Location: Cotuit, MA
Posts: 2,252
I have had similar problems, I found a loose connection in the wiring harness attached to the switches. Look for a bad connection in that harness.


Sent from my iPad using iRV2 - RV Forum
Dave, Bobbi and Fenway
__________________

__________________
Dave, Bobbi and Fenway
2005 38' FDTS Alpine Limited, 2016 Jeep Grand Cherokee Limited
Cape Cod, MA
DrDaveMA is offline   Reply With Quote
Old 04-13-2015, 02:54 PM   #3
Senior Member
 
Join Date: May 2004
Location: Auburn, CA, Havasu, AZ & Mulege, BCS
Posts: 5,217
On my rig there are 4ea 3 amp fuses in a block located to the right of the driver's right knee. See if one is burnt out, & regardless pull them all & reseat just for assurance of full contact.
__________________
Baja-tested '08 2-slide 36'
Alpine: The Ultimate DIY'er Project
EngineerMike is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hot water heater.....no electric? Born2RV RV Systems & Appliances 24 08-11-2014 11:03 AM
Electric awning not working urude RV Systems & Appliances 6 06-23-2014 01:40 PM
Hot Water Heater electric side not working cc8375 RV Systems & Appliances 5 06-11-2014 11:23 PM
All Electric? KarenS144 Newmar Owner's Forum 25 06-10-2014 08:20 PM
Electric step not working 2007 QRH espy1949 Tiffin Motorhomes Owners Forum 8 03-28-2014 11:48 AM

» Virginia Campgrounds

Reviews provided by


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 05:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.