Go Back   iRV2 Forums > THE OWNER'S CORNER FORUMS > Alpine Coach Owner's Forum
Join iRV2 Today

Mission Statement: Supporting thoughtful exchange of knowledge, values and experience among RV enthusiasts.
Thread Tools Search this Thread Display Modes
Old 04-13-2007, 03:57 PM   #15
Senior Member
gator67's Avatar
Join Date: Feb 2005
Location: everywhere
Posts: 510
We had a GE Advantium and our fuse failed, too. The whole unit had to be taken down in order for the GE guy to replace the fuse. He said the failure is not an uncommon occurrence, and it is due to a poor design. My wife didn't like the Advantium anyway because 1) it didn't broil and 2) you couldn't put in a 9 X 13 pan because you couldn't turn off the turntable. We replaced the Advantium with a Sharp 1870 (which we had in our Alpenlite 5th wheel) and that took care of the GE problem. I was amused to see in an ad for a $700,000 Newell recently that it had a GE Advantium oven.

Jerry & Shirley Friedman; Dusty & Cricket
2014 Chevy Silverado 3500HD
2015 Mobile Suites 38RSSB3
gator67 is offline   Reply With Quote
Join the #1 RV Forum Today - It's Totally Free!

iRV2.com RV Community - Are you about to start a new improvement on your RV or need some help with some maintenance? Do you need advice on what products to buy? Or maybe you can give others some advice? No matter where you fit in you'll find that iRV2 is a great community to join. Best of all it's totally FREE!

You are currently viewing our boards as a guest so you have limited access to our community. Please take the time to register and you will gain a lot of great new features including; the ability to participate in discussions, network with other RV owners, see fewer ads, upload photographs, create an RV blog, send private messages and so much, much more!

Old 04-27-2007, 07:47 PM   #16
Posts: n/a
Hi guys

Just to provide an update...I recently got my Advantium 120 working again. In my case...it wasn't a fuse or the thermistor, but TCO sensor.

The sensor must have failed which then burnt up some of the wires and melted one of the plug connectors. I ordered the new part, replaced the wires and added an inline fuse. Should this part fail again...it won't be such a fire hazard.

I included some information that may be helpful to anyone trying to find part numbers (etc.) on parts to repair your Advantium.My epinions review.

  Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Advantium Oven saydiver RV Systems & Appliances 2 06-23-2008 04:45 PM
GE Advantium has foggy door Ed & Diane Alpine Coach Owner's Forum 2 05-26-2007 02:48 PM
Buzz in Advantium Oven OldForester Alpine Coach Owner's Forum 7 04-28-2007 06:34 PM
GE Advantium Microwave Oven EasternAirLines Newmar Owner's Forum 8 03-27-2007 05:33 AM
GE Advantium 120 oven skyguy62 Alpine Coach Owner's Forum 7 12-10-2006 05:55 PM

» Virginia Campgrounds

Reviews provided by

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -6. The time now is 03:17 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.